


EXCEL 2021
FOR BEGINNERS AND ADVANCED LEARNERS

A STEP-BY-STEP PRACTICAL GUIDE TO MASTERING EXCEL

PETER JOHN

LEGAL NOTICE
The information contained in this book is for information and educational purposes. No part of this book may be
duplicated, transmitted, or distributed in any form or by any means, including photocopying, recording, and other

mechanical or electronic methods, without the prior written permission of the publisher and the author, except in the
case of brief quotations embodied in reviews and other non-commercial uses permitted by copyright law.

Copyright © 2021 Peter John

All Rights Reserved

TABLE OF CONTENT
LEGAL NOTICE

TABLE OF CONTENT

INTRODUCTION

CHAPTER ONE

INTRODUCTION TO OFFICE 2021

WHY SHOULD YOU USE OFFICE 2021?
VERSIONS OF MICROSOFT OFFICE 2021

CHAPTER TWO

INTRODUCTION TO MICROSOFT EXCEL 2021

WHAT IS EXCEL 2021?
FEATURES OF EXCEL 2021
IMPORTANCE OF USING EXCEL 2021

CHAPTER THREE

GETTING FAMILIAR WITH EXCEL SCREEN INTERFACE

EXCEL’S START SCREEN

EXCEL’S WORKBOOK USER INTERFACE

NAVIGATING THROUGH THE EXCEL RIBBON

COMPONENTS OF EXCEL RIBBONS

CUSTOMIZING THE QUICK ACCESS TOOLBAR

CHAPTER FOUR

UNDERSTANDING THE BASICS OF EXCEL

WHAT IS A WORKBOOK

WHAT IS A WORKSHEET

UNDERSTANDING COLUMNS, ROWS, AND CELL ADDRESS.
THE KINDS OF DATA A WORKSHEET ACCEPTS

HINTS TO OBSERVE BEFORE ENTERING DATA



ENTERING DATA INTO THE CELLS

EDITING YOUR WORKSHEET DATA

COPYING AND MOVING DATA IN A WORKSHEET CELLS

MOVING AROUND IN A WORKSHEET

APPLYING FORMATTING TO NUMBERS

DISPLAYING NUMBERS WITH A THOUSAND SEPARATOR (COMMA)
DISPLAYING NUMBERS WITH CURRENCY SYMBOLS

DISPLAYING NUMBERS AS PERCENTAGE

CHANGING THE DATE FORMAT IN YOUR CELL

CHANGING THE TIME FORMAT IN YOUR CELL

THE FLASH FILL COMMAND

COMBINING DATA USING THE FLASH FILL

EXTRACTING DATA WITH FLASH FILL

THE AUTOFILL COMMAND

ENTERING A SERIES OF VALUE USING AUTOFILL

COPYING DATA USING THE AUTOFILL

SAVING A FILE

SAVING A FILE FOR THE FIRST TIME

THE DOCUMENT AUTO RECOVERY COMMAND

LEARNING DATA VALIDATION

APPLYING THE DATA VALIDATION TO CELLS

TRANSFERRING THE DATA VALIDATION TO OTHER CELLS IN THE WORKSHEET

REMOVING THE DATA VALIDATION FROM YOUR CELLS

FILTERING DATA IN EXCEL

GROUPING OF DATA IN EXCEL

CHAPTER FIVE

FORMATTING AND MANAGING THE WORKSHEET

NUMBERS AND TEXT ALIGNMENT IN ROWS AND COLUMNS

THE VERTICAL ALIGNMENT

THE HORIZONTAL ALIGNMENT

CHANGING TEXT AND NUMBER ORIENTATION

WRAPPING TEXT IN YOUR WORKSHEET

MERGING CELLS

INSERTING ROWS AND COLUMNS

INSERTING A ROW

INSERTING A COLUMN

DELETING ROWS AND COLUMNS

ADJUSTING ROWS AND COLUMNS SIZE

ADJUSTING THE HEIGHT OF THE ROW

ADJUSTING THE COLUMN WIDTH

CHANGING THE COLUMN WIDTH TO AUTOMATICALLY FIT THE CONTENTS

CHANGING THE ROW HEIGHT TO AUTOMATICALLY FIT THE CONTENTS

RESIZING ALL COLUMNS AND ROWS TO FIT THE DATA OR CONTENT

FREEZING AND SPLITTING ROWS AND COLUMNS

FREEZING YOUR ROWS AND COLUMNS

UNFREEZING PANES ROWS AND COLUMNS

SPLITTING IN WORKSHEET

HIDING AND UNHIDING THE ROWS AND COLUMNS

HIDING THE COLUMNS

UNHIDING THE COLUMNS

HIDING THE ROWS

UNHIDING THE ROWS

MANAGING YOUR WORKSHEET

RENAMING YOUR WORKSHEET

SELECTING WORKSHEETS.
REARRANGING WORKSHEETS

INSERTING A NEW WORKSHEET

COPYING A WORKSHEET

DELETING A WORKSHEET

ADDING COLOR TO THE WORKSHEET TAB

USING THE COMMENTS IN YOUR WORKSHEET

ADDING COMMENT TO YOUR WORKSHEET

VIEWING THE COMMENT ON THE YOUR WORKSHEET

EDITING A COMMENT IN YOUR WORKSHEET

DELETING A COMMENT

SHOWING OR HIDING ALL COMMENTS

SHOWING OR HIDING COMMENTS INDIVIDUALLY

HIDING YOUR WORKSHEET

PROTECTING YOUR WORKSHEET

CHAPTER SIX

CUSTOMIZING THE WORKSHEET

CHANGING THE WORKSHEET THEME

CHANGING THE THEME COLOR

CHANGING THE THEME FONTS



CHANGING THE THEME EFFECTS OF YOUR WORKSHEET

CHANGING THE FONT, FONT STYLE, AND FONT SIZE

CHANGING THE FONT OF YOUR WORKSHEET

CHANGING THE FONT STYLE OF YOUR WORKSHEET

CHANGING THE FONT SIZE OF YOUR WORKSHEET

CHANGING THE FONT COLOR OF YOUR WORKSHEET

CHANGING THE CELL BACKGROUND COLOR OF YOUR WORKSHEET

APPLYING BORDERS TO YOUR WORKSHEET

REMOVING BORDER FROM YOUR WORKSHEET

REMOVING GRIDLINES FROM YOUR WORKSHEET

CHANGING THE COLOR OF GRIDLINES IN A WORKSHEET

USING THE CELL STYLES IN YOUR WORKSHEET

APPLYING CELL STYLES TO YOUR WORKSHEET

CREATING A CUSTOM CELL STYLE

CREATING A CELL STYLE BY MODIFYING AN EXISTING CELL STYLE

DUPLICATING AN EXISTING CELL STYLE

REMOVING CELL STYLES FROM A WORKSHEET

DELETING A CELL STYLE FROM A WORKSHEET

CHAPTER SEVEN

THE EXCEL FORMULA AND FUNCTIONS

WHAT IS A FORMULA

WHAT IS A FUNCTION

GETTING FAMILIAR WITH THE FORMULA TAB

CATEGORIES OF DATA EXCEL’S FORMULA ACCEPTS

INSERTING FORMULAS INTO YOUR WORKSHEET

EDITING THE FORMULA

UNDERSTANDING THE FORMULA OPERATORS

THE ORDER OF OPERATOR PRECEDENCE IN EXCEL FORMULAS

MANIPULATING THE ORDER OF PRECEDENCE USING THE PARENTHESES

CELL REFERENCING

TYPES OF CELL REFERENCES

RELATIVE REFERENCES

ABSOLUTE CELL REFERENCE AND MULTIPLE CELL REFERENCE

REFERENCING OTHER WORKSHEETS IN A WORKBOOK
HOW TO COPY FORMULA FROM ONE CELL TO ANOTHER

COPYING FORMULA DOWN A COLUMN

COPYING A FORMULA DOWN A COLUMN WITHOUT COPYING THE FORMATTING

COPYING FORMULA TO THE ENTIRE COLUMN

COPYING FORMULA TO NON-ADJACENT CELLS/RANGE

ENTERING A FORMULA INTO MULTIPLE CELLS WITH A SINGLE KEY STROKE

COPYING EXCEL FORMULA WITHOUT THE FORMATTING USING THE COPY & PASTE FEATURES

DEALING WITH ERRORS IN YOUR FORMULA

EXCEL FORMULA ERROR MESSAGES

USING THE ERROR CHECKER BUTTON

TRACING CELL REFERENCES

TRACING PRECEDENTS

TRACING DEPENDENTS

WORKING WITH A FUNCTION

UNDERSTANDING THE FUNCTIONS ARGUMENTS
LOCATING THE ARGUMENTS IN A FUNCTION

TAKING A LOOK AT COMMONLY USED FUNCTIONS IN EXCEL

SUM FOR ADDING UP DATA

AVERAGE FOR AVERAGING DATA

DERIVING THE FUNCTION OF A CELL USING FORMULATEXTS
COUNTING THE NUMBER OF DATA ITEMS USING COUNT
COUNTING ALL DATA TYPE USING THE COUNTA
COUNTING BLANK SPACES USING COUNTBLANK
CONCATENATE FOR COMBINING VALUES

FINDING THE LOWEST NUMBER USING MIN
FINDING THE HIGHEST NUMBER USING MAX
COUNTING TEXT CHARACTERS WITH LEN FUNCTION

CHANGING THE ORIENTATION OF THE CELLS WITH TRANSPOSE
CAPITALIZING THE FIRST LETTER OF YOUR TEXT STRING WITH PROPER
REMOVING SPACES WITH TRIM
FINDING THE POSITION OF A SUBSTRING IN A TEXT STRING USING THE SEARCH FUNCTION

FINDING THE POSITION OF A SUBSTRING IN A TEXT STRING USING THE FIND FUNCTION

MAKING LOGICAL COMPARISON WITH VALUES USING THE IF FUNCTIONS

CHECKING THE CURRENT DATE AND TIME WITH TODAY AND NOW

CHAPTER EIGHT

TABLES AND CHARTS IN EXCEL

CREATING A TABLE

CHANGING YOUR TABLE STYLE

REMOVING THE TABLE

RENAMING A TABLE



FILTERING THE DATA IN YOUR TABLE

GROUPING OF DATA IN YOUR TABLE

SORTING OUT DATA IN YOUR TABLE

ADDING SLICER IN YOUR TABLE

CREATING PIVOT TABLE

INSERTING RECOMMENDED PIVOTTABLE IN YOUR DATA

WORKING WITH CHARTS IN EXCEL

TYPES OF CHARTS

CREATING A CHART WITH YOUR DATA

CHANGING THE CHART STYLES

CHANGING THE CHART LAYOUT

CHANGING THE CHART TYPES

SWITCHING THE ROWS AND COLUMNS IN YOUR CHART

MOVING YOUR CHARTS FROM ONE WORKSHEET TO ANOTHER

CREATING PIVOT CHART

CHAPTER NINE

SOLVING COMMON PRINTING PROBLEMS IN EXCEL

CHANGING THE EXCEL WORKSHEET ORIENTATION BEFORE PRINTING

PRINTING ONE OR SEVERAL WORKSHEETS

PRINTING AN ENTIRE WORKBOOK

PRINTING A SELECTION

PRINTING EXCEL TABLES

PRINTING CHARTS WITHOUT WORKSHEET DATA IN EXCEL

PRINTING FORMULA IN EXCEL

PRINTING GRIDLINES IN EXCEL WORKSHEET

PRINTING OUT COMMENT IN EXCEL

SETTING THE PRINT AREA BEFORE PRINTING

INSERTING THE PAGE BREAK BEFORE PRINTING EXCEL WORKSHEET

USING THE PREVIEW OPTION BEFORE PRINTING YOUR WORKSHEET

SCALING TO FIT BEFORE PRINTING YOUR WORKSHEET

CHAPTER TEN

EXCEL SHORTCUTS

EDITING SHORTCUT

NAVIGATION SHORTCUTS

FILE SHORTCUTS

FORMULA SHORTCUTS

PASTE SPECIAL SHORTCUTS

RIBBON NAVIGATION SHORTCUTS

CLEAR SHORTCUTS

SELECTION SHORTCUTS

DATA EDITING SHORTCUT

DATA EDITING (INSIDE A CELL) SHORTCUTS

OTHER SHORTCUTS

CHAPTER ELEVEN

TIPS AND TRICKS

REMOVING DUPLICATES VALUES FROM YOUR WORKSHEET

DELETING ERROR CELLS

CHANGING NEGATIVE VALUES TO POSITIVE VALUES IN YOUR WORKSHEET

DISABLING THE EXCEL START SCREEN

HOW TO MAKE EXCEL SHOW LEADING ZERO?
CHANGING THE SCREEN BACKGROUND OF YOUR EXCEL ENVIRONMENT

LOCKING A FILE WITH A PASSWORD

SAVING EXCEL FILE AS A PDF

CONCLUSION

INDEX

INTRODUCTION



Truth be told, Excel program is a must to have for both small and large scale business, especially in the time as such
as this. Both large and small businesses rely on Excel software to their financial planning and accounting needs
which are a major part of every organization.
To some people, Excel is a program that arranges data in rows and columns. However, Excel goes far beyond that,
rather it contains features that allow you execute operations such as data entry, analysing data in table, charts, and
graphs, statistics, financial analysis and modelling, data management, forecasting, track inventory, macro
programming etc.
With this user guide, you will be learning the most crucial parts of Excel which will help you harness your skills
and boost your confidence when it comes to using Excel. In a nutshell, you will be learning the different concepts in
Excel; workbook, worksheet, functions and formulas, tables and charts, and lots more.
Although, Excel is not easy to learn, but you know? with this guide, you are one step ahead to master Excel with
ease.



CHAPTER ONE
INTRODUCTION TO OFFICE 2021

Before we begin to dive into Word 2021 fully, we must have in-depth knowledge about Office 2021.
Office 2021 is a replacement and an upgrade version of Office 2019 and Office 2021. Office 2021 is a single
payment or non-subscription version of Microsoft Office that comes along with a lot of new features and upgrades,
specifically created for consumers and small businesses.
Office 2021 is also designed for consumers who don’t want to subscribe to the cloud-powered Microsoft 2021
variants.
Office 2021 contains the same applications as previous versions of Office such as Word, Excel, PowerPoint,
Outlook, OneNote, and depending on the plan or bundled subscribed to, you may get to use other applications and
services such as Publisher, Planner, OneDrive, Exchange, SharePoint, Access, Skype, Yammer, and Microsoft
Teams.

Why Should You Use Office 2021?
There is no doubt that Office 2021 and other versions of Office Suite have so many similarities. Despite all these
similarities, Office 2021 has some exclusive features that make it different from the other versions of Office Suite.
However, these features are the major factors that will intrigue you to use Office 2021. Now let us highlight them.

Easy Access from Anywhere: Office 2021 allows you to access your file anytime and anywhere
using an internet connection, from any device. Office 2021 runs in a Microsoft data center, which
allows the users to connect to the internet to access the software.
SharePoint: One of the advantages of using Office 2021 is that it allows you to use SharePoint
Online. Using this service allows you to share and collaborate with others. To view the document
by anyone in the organization, this service set up security permission.
Software Update: Another advantage to the use of Office 2021 is that it allows the users to get
frequent software updates. These updates allow access to the latest features such as security
updates, and bug fixes.
Dark Mode: Office 2021 comes with a feature known as “Dark Mode”. This feature allows you to
make things darker and easier for the eyes. The dark mode makes late-night writing and editing
very much easier to do. 
Secured Cloud Storage: Office 2021 has a secure working environment with high-security
measures set in place such as two-factor authentication, which obstructs any authorized people to
gain access to your files even while on your devices. With this in place, your confidential files are
secured without any security threat or breach.
Improved Communication: Office 2021 comes with tools such as Skype, Yammer, Microsoft
Teams, and Outlook, which help to enhance communication. For instance, Skype for Business
allows you to hold conference calls and meetings with staff and external agencies anywhere in the
world, regardless of the distance or location. Yammer, another tool for communication in Office
2021which serves as another form of social network used in an organization is used to post news
feeds, email notifications, and create different channels for different purposes.
Automatic Upgrades: Applications such as Word, Excel, Outlook, etc. are upgraded from time to
time automatically at scheduled intervals.  With this in place, the stress and cost involved in buying
new software are removed as updates are included in the subscription for the Office 2021 licenses.
Business Continuity: Threats such as disasters and thefts cannot affect the flow of your business



no matter what happens to your physical devices, emails, files, and data. This is because all files
and data needed for workflow are saved and regularly backed up in Office 2021 cloud.

Versions of Microsoft Office 2021
Office 2021 comes in two versions; consumer Office 2021 and Office LTSC (Long Term Servicing Channel) for
commercial customers. Office LTSC includes enhanced features such as dark mode supports for visuals,
accessibility improvements, and performance improvements on Word, Excel, and PowerPoint. Consumer Office
2021 also has similar features to Office LTSC for commercial users.
These versions of Office 2021 are both compatible with Windows and Mac.

CHAPTER TWO
INTRODUCTION TO MICROSOFT EXCEL 2021

Before we go deep into the basic operations of EXCEL 2021, we must first learn what EXCEL 2021 is all about, its
features, and its importance.

What is Excel 2021?
Excel 2021 is a spreadsheet program in Office 2021 Microsoft to record and analyze numerical and statistical data.
Excel 2021, being a spreadsheet program uses spreadsheets to organize numbers and data with formulas and
functions. Excel contains features that allow you to carry out several operations such as calculation, graph tools,
pivot tables, macro programming, and many more.
Excel 2021 uses cloud storage to save its file, and can be accessed from a web browser on the computer system.

Features of EXCEL 2021
Excel and traditional Excel have some features in common. Right now, I will be listing out some features that make
Excel different from the traditional Excel



Online Subscription: Excel 2021 is the subscription-based version of Excel designed to regularly
release updates and features that will enhance the productivity of its users. The subscription
payment can be done monthly, semi-annually, or annually.
Custom Visuals: One of the features available in Excel 2021 is custom visuals such as bullet
charts, speedometer, and word cloud which were available only available in Power B1.
Custom Functions: This feature allows you to create custom functions by using JavaScript which
permits for better interconnection.
Full SVG Graphics: Excel 2021 comes with SVG graphics support and 500 built-in icons which
look great on infographics and dashboards.
3D Models with Full Rotation: Excel 2021 has many 3D models that are for free on the internet,
with extensions such as. fbx., obj., ply., stl., and gbl.
XLOOKUP Function: Another feature in Excel 2021 is the XLOKUP function. This function
allows you to find the value that is located within a spreadsheet range or table.
More Images, Icons, Backgrounds, and Templates: Excel 2021 comes thousands of new designs
such as images, icons. Backgrounds and templates.
Ideas: Another feature in Excel 2021 is the Idea function. The Idea function offers help on how to
express data or put them into visualization.
Black Theme: The black theme in Excel 2021 makes late-night work editing with ease.
Split Columns to Rows: This is a new feature in Power Query where each delimiter generates a
new row.
Funnel Chart: This is a chart type that comes in handy for illustrating a sales funnel
Co-authoring Features: This feature in EXCEL 2021 allows two or more users to simultaneously
edit a workbook when stored on OneDrive or SharePoint.

Importance of Using EXCEL 2021
Now let’s talk about the importance of using Excel 2021 compare to traditional Excel.

Preparation of Financial data: One of the reasons to use Excel 2021 is that it allows you to
prepare financial data such as budgets, account balance information, taxes, payrolls, receipts, and a
lot more.
Mathematical Formulas: With Excel 2021, you can solve complex mathematical problems by
making use of the mathematical formulas in Excel.
Online Storage and Access: Excel 2021 which is a part of Office 2021 allows you to access their
files online, without the need to move around with their computers. In a nutshell, you can access
your files anytime and anywhere using any device compatible with the use of Excel 2021

Easy and Effective Comparison: With Excel 2021, you can analyze a large amount of data which
can be used to get trends and patterns that can influence or affect decisions.
Co-authoring: Excel 2021 allows you to work on the spreadsheet at the same time with other
users.
Improved Security: In contrast to the traditional Excel, Excel 2021 offers an advanced security
system to the files on it. This denies intruders access to the files by either using a password using
the Visual Basic Programming or directly within the Excel files.
Creating Forms: With Excel 2021, you can create form templates that can be used for handling
inventories, performance, evaluation ,questionnaire, and reviews.

CHAPTER THREE
GETTING FAMILIAR WITH EXCEL SCREEN INTERFACE

In this chapter, you will be learning about Excel’s screen interface which includes the Start Screen, Ribbon



Interface, and how to customize the ribbons on Excel’s interface.

Excel’s Start Screen
When you open an Excel application for the first time, the first thing that pops up is the start screen, which is
divided into two parts. 

The Left Navigation Pane
The Right Pane

The Left Navigation Pane
The Left Navigation pane comprises a list of recently opened Excel files and a link which is “Open Other
Workbooks”. When you click on “Open Other Workbooks”, this takes you to the backstage view of Excel where
you can access options such as New, Open, Save, Save As, etc.
The Right Pane
The Right Pane displays a list of thumbnails that includes templates that can be used to create a new workbook. To
view more templates to create a new workbook, click on the Find More in New link on the right side of the Home
screen. To open a new blank Excel workbook, you can click on Blank workbook

Excel’s Workbook User Interface
From the Excel Home Screen, you open a new, blank workbook by clicking on the New Workbook thumbnail.
When a new, blank workbook is opened, the following options are displayed on the user interface

File Menu Button: The File Button takes you to the Backstage View of Excel, and this contains
several options such as New, Open, Save As, Print, etc. to work with the Excel file.



Quick Access Toolbar: This tool is located above the Excel ribbon and by default, it contains commonly used
commands such as Save, Undo, and, Redo. This Quick Access Toolbar can be customized by adding any other
commonly used command to it, by clicking on Customize Quick Access Toolbar button located beside the Quick
Access Toolbox button

Ribbon: This contains most of the commonly used commands in Excel. They are displayed on the
Excel interface in tabs ranging from the Home tab to the View tab

Formula Bar: The Formula bar is located at the top of the Excel worksheet window. The Formula
bar has three parts; the cell name, the Formula bar button, and the contents of the currently selected
cell.

Worksheet Area: This is the area that contains all the cells in the current worksheet. The
worksheet is identified by column headings with letters at the top, and rows headings with numbers
at the left edge, with tabs for making selections.

Status Bar: The Status bar keeps you abreast of the current mode of the Excel worksheet you are engaged with.
The Status bar also contains the worksheet views and the Zoom tool for zooming in and out of the worksheet.



Windows Controls: The Window controls are used to control the main Excel window. The Window controls
contain three buttons; maximizing the window, restoring the window, and closing the window.

Ribbon Display Options: The Ribbon Display Options button is located at the top of the Excel
window, and when clicked on, the three options are displayed; Auto-hide Ribbon, Show tabs, Show
Tabs, and Commands.

Horizontal Scrollbar and Vertical Scrollbar: The Horizontal scrollbar and Vertical scrollbar are
used to scroll the content in the worksheet horizontally or vertically.

Navigating Through the Excel Ribbon
The Excel ribbon is a row of tabs, buttons, and icons located at the top of the Excel window. These tabs, icons, and



buttons are categorized based on their functions or categories.

Components of Excel Ribbons
The Excel ribbons are divided into four components; Tabs, Groups, Buttons, and Dialog Box launcher.
Tabs
Tabs are a group of commonly used commands brought and displayed to perform an essential task. The following
are the tabs in Excel

File Tab: This is the first tab in Excel which is used to open the Excel Backstage View. The Excel
Backstage View has several options for customizing, editing, and managing Excel files.
Home Tab: The Home tab contains commands that are commonly used in Excel, and some of
these commands are copy, paste, format, find, replace, etc. The Home tab is arranged into the
following groups; Clipboard, Font, Alignment, Number, Styles, Cell, and Editing.
Insert Tab: The Insert tab contains objects or elements that can be inserted into the worksheet.
The elements include graphics, pivot tables, charts, hyperlinks, shapes, 3D models, pictures, etc.
The Insert table is arranged into the following groups; Table, Illustration, Apps, Charts, Reports,
Sparkline, Filter, links, Text, and Symbols.
Page Layout: The Page Layout tab contains options for Excel page setup and print. The Page
Layout tab is arranged in the following group; Themes, Page Setup, Scale to Fit, Sheet Options,
and Arrange.
Formulas Tab: This tab contains options for adding formulas and functions in a worksheet, and
troubleshoot the functions for errors. The Function tab is arranged in the following group; Function
Library, Defined Names, Formula Auditing, and Calculation.
Data Tab: The Data tab contains options for filtering, sorting, and manipulating data. The Data tab
is arranged in the following groups; Get External Data, Connections, Sort & Filter, Data Tools, and
outline.
Review Tab: The Review tab contains options for spell checking, thesaurus, sharing, protecting,
and tracking changes in the worksheet. The Review tab is arranged in the following groups;
Proofing, Language, Comments, and Changes.
View Tab: The View tab contains options for changing the display of the worksheet and its
contents. The view tab is arranged in the following groups; Workbook View, Show, Zoom,
Windows, and Macros groups.
Developer Tab: The Developer tab contains options for creating, playing, and editing macros. It
can also be used to import and map XML files. The Developer tab is arranged in the following
group; Code, Add-ins, Controls, and XML.
Help Tab: The Help tab is where you get online help and training, and feedback on Excel.

Groups
The groups contain related commands buttons which are arranged into subtasks. Each contains buttons, sub-menu,
and dialog launchers.

Command Buttons
These are tools in the group that are used to execute an action in the worksheet. The command buttons in the tab are
organized into mini-toolbars. 



Dialog Box Launcher
The Dialog Box Launcher is located at the right bottom corner of each group. When you click on it, the Dialog Box
launcher opens a dialog box that displays additional options that can be selected from.

Customizing the Quick Access Toolbar
The Quick Access Toolbar is located above Excel Ribbon, and by default contains the following four buttons:

AutoSave: This option automatically saves all the future edits made in the Worksheet.
Save: This option allows you to manually save the changes made to the worksheet you are
currently working on.
Undo: This option undoes the last editing action made on the worksheet you are currently working
on.
Redo: This option repeats the previous editing action recently removed using the Undo bottom.

You can add more commands to the Quick Access Toolbar by clicking on the Customize Access Toolbar button
located beside the Quick Access Toolbox button.
By default, the Quick Access Toolbar is located at the top left corner of the Excel application, and it can also be
moved under the Ribbon area by clicking on the Customize Access Toolbar and then click on Show Below



CHAPTER FOUR
UNDERSTANDING THE BASICS OF EXCEL

In this chapter, you will be learning the basics of Excel such as the workbook, worksheet, rows and columns, cell
address, active cells, creating and opening a new Excel workbook, creating a new worksheet, entering data into the
worksheet, and lots more

What is a workbook
A workbook is a file that contains one or more collections of worksheets.
To open a new workbook, follow the steps given below

Open the Excel program
Select Blank workbook

What is a Worksheet
A worksheet is a collection of organized cells in rows and columns, where data are stored, updated, and
manipulated. A worksheet contains 1048576 rows and 16384 columns. The worksheets are also known as
spreadsheets.
To create a new worksheet, click on the plus sign at the bottom of the document window.

Understanding Columns, Rows, and Cell Address.
Rows: Rows are part of the Excel worksheet identified by numbers ranging from 1 to 1048576. The total number of



rows in Excel is 1048576.
Columns: Columns are part of the Excel worksheet identified by letters from A to XFD. The total number of
columns in Excel is 16384.
Cell Address: The Cell address otherwise known as the cell reference is an alphanumeric value used in identifying
a specific cell in the worksheet. Each cell address contains one or more letters followed by a number.

The Kinds of Data a Worksheet Accepts
The worksheet contains the three types of data; labels, values, and formulas

Labels: Labels are otherwise known as texts.
Values: These are numbers be it whole o decimal numbers. Values also include the date
Formulas: These are commands on Excel to execute calculations e.g. SUM, MAX, LOOKUP, etc.

Hints to Observe Before Entering Data
Before entering data into the worksheet, take note of the following rules:

Select the cell you want to enter the data into
Any new entry makes into a cell replaces the original data already contained in it.

Data entered in a cell must be completed by clicking on the Enter button on the Formula bar,
pressing the Enter key, or selecting a new cell before the entry is officially entered in the cell.

Entering Data into the Cells
There are three major ways to enter data into the cells in the worksheet and they are as follow

Double-clicking: To enter data into the cell, double click on the cell and start typing inside of it.
This is the most commonly used method to enter data into the cell.

Clicking on the Formula Bar: One of the ways to enter the data into the cell is to click on the
formula bar.



You can also put the cell in the edit mode by pressing F2

Editing Your Worksheet Data
You can edit your worksheet data by either replacing the cell’s content, delete the characters in the cell entry, or
insert new characters in the cell entry. Now let’s quickly learn how these can be done.
Replacing a Cell’s Content
To replace the content of a cell, do the following:

Place the cell pointer in the cell

Start typing the new entry over it and the new entry will replace the original entry.

Deleting Characters in a Cell Entry
To delete characters in a cell entry, follow the steps given below

Place the insertion point in the cell entry using the Formula bar, double-clicking in the cell, or
pressing F2



Move the insertion point using the Home, End, or ← and → keys
Then use the Backspace and Delete keys to delete the characters you want.

Inserting New Character in the Cell Entry
Inserting a new character in the cell entry implies that you want to add a new character to the already existing data
in the worksheet. To do this, follow the steps given below:

Place the insertion point in the cell entry using the Formula bar, double-clicking in the cell, or
pressing F2
Move the insertion point using the Home, End, or ← and → keys to where the new characters are
needed.

Start typing the new characters and then click on Enter button to complete the editing changes



Copying and Moving Data in a Worksheet Cells
While working on the worksheet, there may be the need to copy or move the content of a cell to another location.
Briefly, let’s learn how to copy and move the content of a cell.
Copying Data in a Worksheet Cells
There are several ways to copy the content of a cell, but we will be using the Copy and Paste command by
following the steps provided below

Select the cell or range of cells you wish to copy.
Go to the Home tab and click on Copy in the Clipboard group

Move the cell pointer to where you wish to paste the content of the cells, and then click on the
Paste command in the Home tab or use the Ctrl V to paste

Moving Data in a Worksheet Cells Using the Cut Command
To move data from one cell to another, use the cut command following the steps provided below:

Select the cell or range of cells you wish to move
Go to the Home tab and click on Cut in the Clipboard group.



Move the cell pointer to where you wish to paste the content of the cells, and then click on the
Paste command in the Home tab or use the Ctrl V to paste

Moving Data in a Worksheet Cells by Dragging and Dropping
You can also move the content of a cell by dragging and dropping. To use this technique, follow the steps given
below

Select the cell or range of cells you wish to move
Point to the border of the selected cells
When the pointer becomes a move pointer, drag the selected cells to the desired location.



Moving Around in a Worksheet
As the worksheet becomes larger, the harder it is to move around the worksheet. Because of this, Excel provides
some shortcut keys for navigating around the worksheet with ease, and they are listed in the table below:

Shortcut Keys Functions
Home To column A
Ctrl + Home To cell A1; the first cell of the worksheet.
Ctrl + End To the last cell in the last row with data in it.
←, →, ↑, ↓ To move to the next cell.
Ctrl + ←, To move in one direction toward the nearest.
→, ↑, ↓ To move to a cell with data in it or the first or last cell

in the column or row.
Page Up or Page Down To move up or down one
Alt +Page Up or Alt + Page Down To move to the left or right one screen’s worth of

columns.
Ctrl + Page Up or Ctrl + Page Down To move backward or forward from one worksheet to

another within the workbook.

Apart from the shortcut keys, you can use the techniques below to navigate from one worksheet to another within
the workbook

Scroll Bars: Use the vertical and horizontal scroll bars to move to different areas within the
worksheet. To cover long distances, drag the scroll bar and to cover a long distance quickly, hold
down the Shift keys as you drag the scroll box on the vertical scroll bar.
Scroll Wheel on the Mouse: If your mouse has a scroll wheel attached to it, turn the wheel to
quickly scroll up and down.
The Go-To Command: One of the techniques to navigate around the worksheet is the Go-To
command.  To locate the Go To command, go to the Home tab, click on the Find & Select button,
and then select Go To in the drop-down list. Enter a cell address in the reference box and click on
Ok.
The Find Command: To locate the Find command, go to the Home tab, click on the Find &
Select button, and then select Find in the drop-down list. Enter the data you wish to find in the
Find What box and then click on the Find Next button.

Applying Formatting to Numbers
Applying formatting to numbers involves displaying numbers with thousand separators, displaying numbers with a
currency symbol, displaying numbers with percentages, etc.
The number format applied on data tells the Excel worksheet the type of data you are using. In few minutes, let’s
check how to apply a format to numbers.

Displaying Numbers with a Thousand Separator (Comma)
You can display a number with a thousand separators using the following steps

Right-click on the cell you wish to add a thousand separators to, and then click on Format Cell.



In the Format Cell dialog box, click on the Number tab, and then select Number under
Categories
In the right-hand side of the Format Cell dialog box, mark Use 1,000 separator, and change the
decimal place to 0 in the Decimal Place button.
Then click on Ok for the changes to occur in the worksheet.



Displaying Numbers with Currency Symbols
To display numbers using the currency symbols, follow the steps given below:

Right-click on the cell you wish to add a currency symbol to, and then click on Format Cell.
In the Format Cell dialog box, click on the Number tab, and then select Currency under
Categories
In the left-hand side of the Format cell dialog box, go to the Symbol button and click on the
Symbol drop-down menu to select the currency you wish to add.
Then click on Ok for the changes to occur in the worksheet.



Displaying Numbers as Percentage
You can display numbers as percentages by following the steps given below:

Right-click on the cell you wish to add a percentage to, and then click on Format Cell.
In the Format Cell dialog box, click on the Number tab, and then select Percentage under
Categories
Then click on Ok for the changes to occur in the worksheet.



Changing the Date Format in your Cell
You can change the way dates are displayed in your worksheet by following the steps given below;

Right-click on the cell you wish to change the date format, and then click on Format Cell.
In the Format Cell dialog box, click on the Number tab, and then select Date under Categories.
Select any of the date formats you want
Then click on Ok for the changes to occur in the worksheet.



Changing the Time Format in your Cell
To change the time format in your cell, follow the steps provided below

Right-click on the cell you wish to change the time format, and then click on Format Cell.
In the Format Cell dialog box, click on the Time tab, and then select Date under Categories.
Select any of the date formats you want
Then click on Ok for the changes to occur in the worksheet.



The Flash Fill Command
The Flash Fill is a tool that analyses the information entered in a cell and automatically fills the data when a pattern
is set. To locate the Flash Fill command, go to the Data tab and click on Flash Fill in the Data Tools group.

The Flash Fill command can be used to combine and extract data.

Combining Data Using the Flash Fill
To join data together using the Flash Fill command, follow the steps given below by making use of the table
provided



Click into cell C1 and type “Mike John”

Go to the Data tab and click on Flash Fill in the Data Tools group.

Once this is done, Excel will replicate the pattern on the worksheet

Extracting Data with Flash Fill
The Flash Fill does not only combine data, it can also extract data too. To extract data, follow the steps given below
by making use of the table provided.



Click into cell B1 and type “123/58”

Go to the Data tab and click on Flash Fill in the Data Tools group.

Once this is done, Excel will replicate the pattern on the worksheet

The AutoFill Command
The AutoFill command is a feature that allows you to enter sequential numbers, months, or days automatically. The
AutoFill command looked at the cells you have already filled in, and guess how to fill in the rest of the series. For
instance, when you fill in Monday, Autofill automatically completes the following days for you.
The AutoFill is accessed by using the Fill handle. The Fill handle is a small square at the bottom-right corner of the
box that allows you to fill the adjacent cells.

Entering a Series of Value Using AutoFill
With the AutoFill command, you can complete a series of values once the pattern has been recognized. Briefly, we
will be using the AutoFill command to complete the days of the week using the following steps below:

Select the cell with the first value of a series (Monday)
Move the mouse to the bottom right corner of the cell and allows it to display a black plus symbol.
Click and drag down or across the cell you wish to fill



Finally, the AutoFill complete the days of the week as shown in the table below

Copying Data Using the AutoFill
With the AutoFill Command, you can copy and paste data to other cells within the worksheet. To do this, follow the
steps given below.

Select the cell that contains the data you wish to copy
Move the mouse to the bottom right corner of the cell and allows it to display a black plus symbol.
Click and drag down or across the cell you wish to fill

Finally, AutoFill copies the data into the designated cells.



NOTE: With the AutoFill command, you can also do the following:
Fill formatting only
Fill without formatting
Fill weekdays
Fill months
Fill years

Saving a File
Saving a file helps to prevent file loss especially when the file is large or important. To save a file, choose any of
the following techniques:
It is not enough that you create a new file, you must ensure to save it. Failure to save your file will only cause you
to lose your file, especially where there is a power outage or malfunction with the computer system. It is very
important to always save your file every ten minutes.
To save a file, use any of the following techniques

Go to the File tab and click on the Save menu

Click the Save button located in the Quick Access toolbar

Press Ctrl + S

Saving a File for the First Time
Saving a file for the first time, the Save As window appears where you enter the name of the file and the location
where you want the file to be saved.



The Document Auto Recovery Command
The Auto Recovery command is a feature in Excel 2021 that allows you to recover your document when lost due to
a power outage, computer crash, or failure. The Auto Recovery is programmed to save changes made to the
workbook automatically (For a file to use the Auto Recovery feature, the file must be saved)
To enable the Auto Recovery command, follow the steps given below

Go to the File tab and click on Options

In the Options dialog box, select the Save category
Enter the minute interval in the Save AutoRecovery Information Every box
Then click on Ok

Learning Data Validation



Data Validation is a feature in Excel that determines what is to be entered in the worksheet by the users. With the
Data validation feature, Excel can

Permit only number or text values in the worksheet
Permit number with a specific range in the worksheet
Obstruct dates and times that are given out of the time frame
Display a warning sign when the wrong data is inputted.
Locate the wrong entries in the validated cells

To locate the Data Validation command, go to the Data tab and select Data Validation in the Data Tool
group

Applying the Data Validation to Cells
To apply the Data Validation to your cells, follow the steps given below:

Select the cells to apply the Data Validation to
Go to the Data tab and select the Data Validation in the Data Tool group.

In the Data Validation dialog box, go to the Settings tab and select any of the following options
under Allow

Whole Number: To restrict the cell to accept only whole
Decimal: To allow the cell to accept only decimal numbers.
List: To pick data from the drop-down list.
Date: To restrict the cell to accept the only date.
Time: To restrict the cell to accept only time.
Text Length: To restrict the length of the text.
Custom: To custom formula



Under Data, select a condition and set the other required values based on what you chose for
Allow and Data.

Click on the Input Message tab and enter the title and text of the message connecting to the field.
Select the Show input message when cell is selected the checkbox to display the message when
the user selects or moves over the selected cells



Select the Error Alert tab and enter the title and text of the error message, and then click on Style
to select the alert type.

Then click on Ok

Transferring the Data Validation to Other Cells in the Worksheet
In case you applied the data validation to a cell and you wish to replicate it to the other cells in the worksheet,
follow the steps below

Select the cell that contains data validating feature
Move the mouse to the bottom right corner of the cell and allows it to display a black plus symbol.
Click and drag down or across the cell you wish to fill



Finally, the AutoFill copies the data into the designated cells.

Removing the Data Validation From your Cells
To remove the data validation from your cells, follow the steps given below:

Select the cells with data validation
Go to the Data tab and select the Data Validation in the Data Tool group.
On the Setting tab, select the Clear All button, and then click on Ok.

Filtering Data in Excel
In case you are wondering how to display and hide some data in your worksheet. The Filter command is what you
need to use. To use the Filter

Click on the column of the header in the worksheet
Go to the Data tab and click on Filter in the Sort & Filter group.
Click on the Filter drop-down arrow that appears on the header of the column



In the window that displays, unmark the box you don’t in your worksheet, and then click

The filtered data is shown in the table below



Grouping of Data in Excel
Grouping data in Excel allows you to hide data from either the rows or columns. To group data, follow the steps
given below:

Select the data you want to group
Go to the Data tab and click on Group in the Outline group.

Select Row and click on Ok.

In the image below, the data in the cells are group

CHAPTER FIVE
FORMATTING AND MANAGING THE WORKSHEET

Here in this chapter, you will be learning how to format your worksheets. Formatting your worksheet includes
numbers and text alignment in rows and columns, inserting rows and columns, adjusting the rows and columns,
freezing, and splitting the columns and rows, number and text alignment in rows and columns, etc.
To manage a worksheet, you will be learning how to rename your worksheet, moving a worksheet, copying a
worksheet, etc.



Numbers and Text Alignment in Rows and Columns
By default, Excel aligns texts to the bottom-left of the cells and numbers to the bottom right of the cells. However,
these alignments can be changed to any of the alignment types you desire.
There are two types of alignments in Excel: vertical and horizontal alignments

The Vertical Alignment
The vertical alignment allows you to align your texts and numbers using the following options

Top Align: This aligns the text or numbers to the top of the cell
Middle Align: This aligns the text or number to the center of the cell i.e. in between the top and
bottom of the cells.
Bottom Align: This aligns the text to the bottom of the cells.

To apply vertical alignment to your text or number, follow the steps given below
Select the cells that contain the text or number you wish to align

Go to the Home tab and click on either Top Align, Middle Align, or Bottom Align in the
Alignment group. Here we will be using the Top Align

In the image shown below, the selected cells are aligned to the top of the cells.



The Horizontal Alignment
Just like the vertical-horizontal, the horizontal alignment also allows you to align your texts and numbers using the
following options

Align Left: This aligns the text or numbers to the left edge of the cell
Center: This aligns the text or number to the center of the cell.
Align Right: This aligns the text to the right edge of the cell.

To apply horizontal alignment to your text or number, follow the steps given below
Select the cells that contain the text or number you wish to align

Go to the Home tab and click on either Align Left, Middle, or Align Right in the Alignment
group. Here we will be using the Center

In the image shown below, the selected cells are aligned to the center of the cells.



Changing Text and Number Orientation
The Orientation command allows you to rotate your text or number to any angle you desire. Changing the text
orientation is also a great way to label the column headings in the worksheet.
To change the text or number orientation in your worksheet, here are what to do

Select cells that contain the text or numbers you wish to change

Go to the Home tab and click on Orientation in the Alignment group

In the Orientation drop-down menu, select any of the following options; Angle
Counterclockwise, Angle Clockwise, Vertical Text, Rotate Text Up, and Rotate Text Down



In the image shown below, the selected cells are rotated Angle Counterclockwise.

Wrapping Text in Your Worksheet
In case you have a long text string extending from a cell to another and you do not wish to adjust the size of the cell
to contain the long text, all you need to do is used the Wrap command.
The Wrap command allows you to display a long text on multiple lines in a single cell. To use this command,
follow the steps given below:

Select the cell with the long text

Go to the Home tab and click on Wrap Text in the Alignment Group. Here, the text will be
adjusted to multiple lines in a single cell.



Merging Cells
The Merge command allows you to merge or join cells together to create a larger cell without adjusting or changing
the row or column size
To merge cells, follow the cells given below

Select the cells you wish to merge
Go to the Home tab, and click on Merge & Center in the Alignment group
In the Merge & Center drop-down menu, select any of the following options

Merge & Center: To combine and center the contents of the selected cells into a
single and larger cell.
Merge Across: To join the cells selected in the same row into a single cell.
Merge Cells: To merge the cells selected into a single cell.

In the image shown below, the selected cells are merged using the Merge & Center option.



To unmerge cells, you can click on Unmerge Cells in the Merge & Center drop-down menu

Inserting Rows and Columns
There are several ways provided by Excel to insert rows and columns, which include using the keyboard shortcuts
or Insert commands. Before you insert a row or column into your spreadsheet, take note of the following

A new row is always inserted above the row you select
A new column is always inserted to the left of the column you select

Inserting a Row
To insert a new row to your worksheet, follow the steps given below

Select any cell within the row, go to the Home tab, click on Insert and select Insert Sheet Rows.

The new rows are inserted above the selected row in the worksheet.



NOTE: To add a new row, you can also click on the row, select Insert, and then click on Entire Row.

Inserting a Column
To insert a new column to your worksheet, follow the steps given below

Select any cell within the column, go to the Home tab, click on Insert and select Insert Sheet
Columns.

The new columns are inserted to the left of the column you select

NOTE: To add a new column, you can also click on the column, select Insert, and then click on Entire Column.

Deleting Rows and Columns
To delete a column from the worksheet, follow the steps given below

Select any cell within the column, go to the Home tab, click on Insert and select Delete Sheet
Columns.



The selected column is deleted from the worksheet

To delete a row from the worksheet, follow the steps given below
Select any cell within the column, go to the Home tab, click on Insert and select Delete Sheet
Rows.

The selected column is deleted from the worksheet



NOTE: To delete a column or row, you can also click on the column or row, select Delete, and then click on
Entire Column or Entire Row.

Adjusting Rows and Columns Size
While working on your worksheet, there may be the need to expand or reduce Excel’s row width and column
heights. There are many techniques to adjust them. Let’s quickly check out one of those techniques

Adjusting the Height of the Row
To adjust the height of the row, follow the steps provided below

Select a row or a range of rows you wish to change
Go to the Home tab, click on the |Format in the Cell group

Type in the height of the row in the Row Height dialog box and click on Ok

Adjusting the Column Width
To adjust the column width, follow the steps given below

Select a column or a range of columns you wish to change
Go to the Home tab, click on the |Format in the Cell group



Type in the width of the column in the Column Width dialog box and click on Ok

Changing the Column Width to Automatically Fit the Contents
You can change the column width to automatically fit the content of the cells by following the steps given below

Select a column or a range of columns you wish to change
Go to the Home tab, click on the |Format in the Cell group, and then select AutoFit Column
Width

Changing the Row Height to Automatically Fit the Contents



You can change the row height to automatically fit the content of the cells by following the steps given below:
Select a row or a range of rows you wish to change
Go to the Home tab, click on the |Format in the Cell group, and then select AutoFit Row Height.

Resizing All Columns and Rows to Fit the Data or Content 
Rather than adjusting the width of the columns or the height rows separately, you can adjust all the rows or columns
at the same time. To do this, follow the steps given below

Click on the Select All button at the top of the worksheet to select all columns and rows.
Double-click on a boundary to resize the columns or rows

Freezing and Splitting Rows and Columns
Freezing your rows and columns keeps them visible or static when you navigate through the worksheet. The Freeze
pane is useful when checking out data in other parts of the worksheet without losing the header or labels.
Splitting your worksheet helps to create either two or four separate worksheet areas that you can navigate within,
while the rows and columns in the non-scrolled area remain visible.

Freezing Your Rows and Columns
To freeze your row, follow the steps provided below:

Select the rows below the row you to freeze



Go to the View tab, click on the Freeze Panes command in the Window group, and then select
Freeze Pane from the drop-down menu

The rows will be frozen in place indicated by a gray line.

To freeze your column, follow the steps provided below:
Select the column to the right of the column below the row you to freeze



Go to the View tab, click on the Freeze Panes command in the Window group, and then select
Freeze Pane from the drop-down menu.

The column will be frozen in place indicated by a gray line.

Unfreezing Panes Rows and Columns
To unfreeze rows and columns, follow the steps given below

Go to the View tab, click on the Freeze Panes command in the Window group, and then select
Unfreeze Pane from the drop-down menu.



Splitting in Worksheet
To split a worksheet, follow the steps below

Select the cell you wish to split the worksheet
Go to the View tab, click on the Split command in the Window group.

The Workbook is split into different panes.



Hiding and Unhiding the Rows and Columns
There are times you want to hide and unhide your rows and columns rather than deleting them. With these
commands, you can determine which data you want other users to see or the data you wish to print out. Now let’s
talk about how to hide and unhide rows and columns.

Hiding the Columns
To hide the columns in your worksheet, follow the steps provided below:

To select a column, click on its heading
Right-click on the selected columns, and then Hide

Unhiding the Columns
To unhide the columns in your worksheet, follow the steps given below

Select the adjacent columns for the hidden column
Right-click the selected column, and then select Unhide



You can also double-click the double line between two columns where the hidden columns exist.

Hiding the Rows
To hide the rows in your worksheet, follow the steps provided below:

To select a row, click on its heading
Right-click on the selected rows, and then Hide



Unhiding the Rows
To unhide the rows in your worksheet, follow the steps given below

Select the adjacent columns for the hidden column
Right-click the selected rows, and then select Unhide



Managing Your Worksheet
As earlier said at the beginning of this chapter, managing your worksheet involves renaming a worksheet, moving a
worksheet, copying a worksheet, etc. Now let’s go into full details on how to manage your worksheet.

Renaming Your Worksheet
When you open a new worksheet, the default name that comes with it is Sheet 1, Sheet 2 depending on how many
new worksheets you open. However, you can rename the worksheet to any name of your choice. To rename a
worksheet, use any of the following techniques

Right-click the sheet tab, click Rename and type the new name.
Double-click the sheet tab, and type the new name
Use the Shortcut Keyboard Alt + H > O R, and then enter the new name.

Selecting Worksheets.
There are so many ways of selecting a worksheet in a Workbook. Use any of the following techniques

To select a single tab, click on the worksheet’s tab
To select several worksheets, use Ctrl + click their tabs, or click the first tab and then press Shift +
click the last tab in the set.

To select all the worksheets, right-click on the tab, and then choose Select All Sheets on the
shortcut menu.

Rearranging Worksheets
You can choose to change the location of your worksheet by using any of the following techniques



Dragging the Worksheet
To rearrange the worksheet, click and drag the worksheet tab to a new location. As the worksheet tab is dragged, a
tiny black arrow appears, and a page icon is displayed to where the worksheet will land when the mouse button is
released.
The Format Button
To rearrange the worksheets using the Format button, follow the steps provided below

Go to the Home tab, click on Format in the Cell group, and select Move or Copy Sheet

In the Move or Copy dialog, click on where you want the sheet to be located, and then click on Ok



Inserting a New Worksheet
To insert a new worksheet in your workbook, use any of the following techniques
The Insert Button
To use the Insert button, follow the steps given below:

Go to the Home tab, select the Insert button in the Cell group, and click on Insert Sheet.

Using the New Sheet Tab
To use the New Sheet tab, right-click on the New Sheet tab at the right lower side of the worksheet.



NOTE: You can also use the shortcut key Shift + F11 to insert a new worksheet.

Copying a Worksheet
To copy a worksheet, hold down the Ctrl key and drag the worksheet tab to a new location.

Deleting a Worksheet
To delete a worksheet, follow the steps provided below

Select the worksheet you wish to delete
Go to the Home tab and click on the Delete button in the Cell group.

NOTE: You can also right-click on the worksheet tab and select Delete.

Adding Color to the Worksheet Tab
To add color to the worksheet tab, use any of the following techniques
The Format Button
To use the Format button to add color to your worksheet tab, follow the steps provided below:

Select the worksheet tab

Go to the Home tab, click on the Format button under the Cell group.
Click on the Tab Color and then select any color from the submenu.



Using the Right-click
You can use the right-click to add tab color to your worksheet tab. To do this, follow the steps provided below:

Right-click on the worksheet tab
Click on the Tab Color and then select any color from the submenu.



Using the Comments in Your Worksheet
The Comment command is one of the features in Excel that allows users to collaborate easily and effectively and
make suggestions within themselves. Here, we will be learning how to insert a comment, delete comments, view
comments, and lots more.

Adding Comment to Your Worksheet
To add a comment to your worksheet, follow the steps provided below

Select the cell you wish to add the comment

Go to the Review tab and click on the New Comment in the Comment group

In the comment box that appears, type the comment, and then click anywhere outside the box to
close the comment.



The comment added to the cell is represented or indicated by a red triangle in the top-right corner.

Viewing the Comment on the Your Worksheet
To view the comment on your worksheet, select the cell again

Editing a Comment in Your Worksheet
To edit a comment in your worksheet, follow the steps given bellow

Select the cell you wish to edit its comment
Go to the Review tab and click on the Edit Comment in the Comment group.

In the comment box that appears, edit the comment, and then click anywhere outside the box to
close the comment.



Deleting a Comment
To delete a comment from your worksheet, follow the steps given below:

Select the cell containing the comment you wish to delete

Go to the Review tab and click on the Delete Comment in the Comment group.

In the table below, the comment will be deleted

Showing or Hiding All Comments
To show or hide all comments, do the following

Go to the Review tab and click on the Show All Comments in the Comment group, and all the



comments in your worksheet will be displayed. To hide all comments, follow the same procedures
as showing all comments.

Showing or Hiding Comments Individually
You can hide or show individual comments by following the steps provided below

Select the cell you wish to show or hide comment
Go to the Review tab and click on the Show/Hide Comments in the Comment group

Hiding Your Worksheet
You can choose to hide or remove your worksheet from view, by using the Hide command. Hiding your worksheet
is different from deleting them. When you hide your worksheets, you can still reference them in formulas, and
charts found on other worksheets or other workbooks. To hide the worksheet, follow the steps provided below

Select the worksheet tab you wish to hide
Go to the Home tab and select the Format button in the Cell group.
Click on Hide & Unhide and select Hide Sheet



NOTE: You can also hide your worksheet by right-clicking on the worksheet to open the contextual menu. Click on
the Hide option to hide the selected worksheet.
Unhiding Your Worksheet
To unhide your worksheet, follow the steps provided below:

Select the worksheet tab you wish to hide
Go to the Home tab and select the Format button in the Cell group.
Click on Hide & Unhide and select Unhide Sheet



Select the sheet you wish to unhide in the list that pops up and then click on OK.

NOTE: You can also unhide your worksheet by right-clicking on the worksheet to open the contextual menu. Click
on the Unhide Sheet, click on the sheet you wish to unhide in the list that pops up, and then click on OK.

Protecting Your Worksheet
To restrict others from intentionally or unintentionally changing, formatting, inserting new rows and columns,
deleting rows and columns, and many others, you can activate the protection features to lock your worksheet with a
password.
To protect your worksheet from being tampered with by other users, follow the steps given below

Select the worksheet you wish to protect
Go to the Review tab and click on Protect Sheet in the Protect Group.



In the Protect Sheet dialog box, select the elements you want people to change in the Allow all
users of the worksheet to list.

In the Password to unprotect sheet box, enter the password, and click on Ok



Re-enter the password in the Confirm Password dialog box, and then click on Ok 

CHAPTER SIX
CUSTOMIZING THE WORKSHEET

Looking at the Excel default worksheet is just boring, and this is because the default worksheet looks so plain, with
nothing attractive about it. To make the excel worksheet captivating and exhilarating, you will be learning some
important techniques that include changing the theme of the worksheet, changing the theme color of the worksheet,
adding borders to the worksheet, changing the font color and sizes, and many others. Now let’s take our time to
explore how to customize Excel’s worksheet.

Changing the Worksheet Theme
The worksheet theme uses a unique set of colors, fonts, and effects to create a consistent look and feel. To change
the worksheet theme to another, follow the steps provided below:

Go to the Page Layout and click on Theme in the Theme group



In the Theme drop-down menu, select any theme of your choice

Changing the Theme Color
Changing the theme color of your worksheet will affect the colors available in your color picker and the color used
in the worksheet. The theme colors change all the colors used in the worksheet by selecting a different color palette.
To change the theme color, follow the steps given below:

Go to the Page Layout and click on Theme Color in the Theme group
In the Theme Color drop-down menu, select any theme color of your choice



Changing the Theme Fonts
The theme fonts change the entire text in your worksheet by picking a new font set.

To change the theme fonts of your worksheet, follow the steps below:
Go to the Page Layout and click on Theme Font in the Theme group
In the Theme Font drop-down menu, select any theme font of your choice



Changing the Theme Effects of Your Worksheet
Changing the theme effect in your worksheet affects the look of objects inserted in your worksheet. To change the
theme effects in your worksheet, follow the steps given below

Go to the Page Layout and click on Theme Effects in the Theme group
In the Theme Effects drop-down menu, select any theme font of your choice.



Changing the Font, Font Style, and Font Size
Apart from using the Theme features to change the font, you can use the Font group to change the font. With the
Font group, you can also change the font style, font sizes, and lots more

Changing the Font of Your Worksheet
To change the font of your worksheet, follow the steps given below:

Select the cell or a range of cells you wish to change the font.
Go to the Home tab and click on Font and in the Font group.
In the Font drop-down - menu, select any font of your choice



Changing the Font Style of Your worksheet
To change the font style of the cells in your worksheet to either bold, italics, or underline, follow the steps provided
below:

Select the cell or a range of cells you wish to change the font.
Go to the Home tab and click on Bold, Italics or Underline in the Font group to change the font
style



Changing the Font Size of Your Worksheet
To change the font size of your worksheet, follow the steps provided below

Select the cell or a range of cells you wish to change the font.
Go to the Home tab and click on Font Size and in the Font group.
In the Font Size drop-down menu, select any font size of your choice

Changing the Font Color of Your Worksheet
To change the font color or the text color of your worksheet, follow the steps provided below:

Select the cell or range of cells that contain the text you wish to change

Go to the Home tab and click on Font Color and in the Font group.
In the Font Color drop-down menu, select any color of your choice



Changing the Cell Background Color of Your Worksheet
To change the cell background color of your worksheet, follow the steps given below

Select the cell or range of cells you wish to change the background color
Go to the Home tab and click on Fill Color in the Font group.
In the Fill Color drop-down menu, select any color of your choice

Applying Borders to Your Worksheet
To apply a border to your worksheet, follow the steps given below

Select the cell or range of cells you wish to apply the border.
Go to the Home tab and click on Border in the Font group
In the Border drop-down menu, select any of your choices



Here the border is applied to the selected cells in the worksheet

Removing Border from Your Worksheet
To remove the border from your worksheet, follow the steps provided below:

Select the cell or range of cells with border 
Click the Border drop-down in the Font group and select No Border



Here the border applied to the selected cells in the worksheet is removed

Removing Gridlines From Your Worksheet
The gridlines are lines in the Excel worksheet that help divide cells from each other inside a worksheet. With the
gridlines, data are separated and organized concisely,
To remove gridlines from your worksheet, follow the steps provided below

Go to the View tab and click on Gridlines in the Show group.

When you uncheck the gridlines, the gridlines are removed from the worksheet as shown in the
image below



Changing the Color of Gridlines in a Worksheet
By default, the gridline's color is black. However, you can change the color of gridlines. To do this, follow the steps
provided below:

Select the worksheet you wish to change the gridline color
Go to the File tab, select Excl and click on Options.

In the Advanced category, under Display options for this worksheet, click on the Gridline color
box to select any color of your choice and click on Ok



The gridlines of your worksheet are changed to the desired color as instructed.

Using the Cell Styles in Your Worksheet
A cell style comprises several formatting options such as font size, font styles, font colors, number formats, cell
borders, and shading that constitute a worksheet. The cell styles are related to the themes in the worksheet. Anytime
the theme is changed, the cell styles change as well.

Applying Cell Styles to Your Worksheet
To apply a cell style to your worksheet, follow the steps given below

Select the cell or range of cells you wish to apply the cell style to.
Go to the Home tab, click on Cell Styles in the Styles group, and then select any cell style in the
Cell Style drop-down menu.

The selected cell style will appear in the worksheet



Creating a Custom Cell Style
Rather than using the built-in cell style, you can create your own cell style. To do this, follow the steps provided
below

Go to the Home tab, click on Cell Styles in the Styles group, and then select New Cell Style in the
Cell Style drop-down menu

In the Style dialog box, enter the name of the new cell style in the Style name box

Click on Format to open the Format Cell dialog box, where you select the formatting you want,
and then click on OK.



Go back to the Style dialog box to clear the checkboxes of any formatting you don’t want in the
cell style under the Styles Includes (By Example)

Click on Ok and a new custom cell style will be created.

Creating a Cell style by Modifying an Existing cell Style
Rather than starting from scratch to create a new cell style, you can modify the existing cell style to create your own
cell style, using some of the formatting options in the existing cell style.
To create a cell style by modifying the existing cell style, follow the steps below:

Go to the Home tab and click on Cell Styles in the Styles group
In the Cell Style drop-down menu, right-click on any cell style to open the context menu, and then



select Modify

In the Style dialog box, enter the name of the new cell style in the Style name box

Click on Format to open the Format Cell dialog box, where you select the formatting you want,
and then click on OK.



Go back to the Style dialog box to clear the checkboxes of any formatting you don’t want in the
cell style under the Styles Includes (By Example)

Click on OK and the cell style modified will be updated to effect the changes made to it.



Duplicating an Existing Cell Style
You can create a duplicate of a built-in cell style or custom cell style, all you need to do is follow the steps below:

Go to the Home tab and click on Cell Styles in the Styles group
In the Cell Style drop-down menu, right-click on any cell style to open the context menu, and then
select Duplicate.

In the Style dialog box, enter the name of the new style, and click on the Ok button to close the
dialog box and return to the worksheet.

After closing the Style dialog box, the duplicated cell style will be updated to reflect the changes.

Removing Cell Styles from a Worksheet



You can remove the cell styles from your worksheet without the need to delete the cell styles. To do this, follow the
steps provided below
Select the cells you wish to remove the cell style

Go to the Home tab and click on Cell Styles in the Styles group,
In the Cell Style drop-down menu, select Normal under Good, Bad, and Neutral. Here, the cell-
style formatting will be removed from the worksheet.

Deleting a Cell Style from a Worksheet
All other cell styles such as the built-in and custom styles in the Styles group can be deleted, except for the Normal
styles. To delete a cell style from your worksheet, follow the steps provided below

Go to the Home tab and click on Cell Styles in the Styles group
In the Cell Style drop-down menu, right-click on any cell style you wish to delete to open the
context menu, and then select Delete.

When this is done, the cell style is deleted completely from the cell style gallery.

CHAPTER SEVEN



THE EXCEL FORMULA AND FUNCTIONS
Before you begin to go through this chapter, keep this in mind, this chapter is the most important and complicated
part of this book. Despite knowing this, do not fret because everything you will be learning here will be done with
simplicity.
In this chapter, we will be emphasizing everything you need to know about formulas and functions, and how they
can be applied in the worksheet. Before we go, we must understand what formula and a function are all about.

What is a Formula
A formula is an expression that is used to calculate the values of cell or range cells. The formula begins with an
equal sign, followed by the cell addresses that will be calculated upon, making use of the right operand (this is also
known as the order of operations).  For instance, =A2+A3+A4 calculates the sum of the cell range from cell A2 to
cell A4.

What is a Function
A function is a predefined formula containing a special name and purpose. The function begins with an equal sign,
followed by the function’s name, and ends with its arguments.
The functions help to remove the stress of entering your data manually. For instance, =SUM (A2:A6) sums all the
values from A2 to A3

Getting Familiar with The Formula Tab
The Formula tab is one of the tabs in Excel used to insert functions, define names, create name ranges, review
formulas, etc.
The Formula tab is divided into five groups

Function library
Defined Names
Formula Auditing
Calculation
Solutions

Function Library: The Function Library group contains the 461 functions and it contains the following options;

Insert Function: This is what displays the Insert Function dialog box which allows you to search
for a particular function or display the list of functions by category.
AutoSum: This option allows you to insert functions such as Sum, Average, Count Numbers, Max,
Min, or More Functions.
Recently Used: This option gives quick access to the 10 functions that were recently used.
Financial: This option provides quick access to all functions in the Financial category.
Logical: This option provides quick access to all functions in the Logical category.
Text: This option provides quick access to all functions in the Text category.
Date & Time:  This option gives quick access to all the functions in the Date & Time category.
Lookup & Reference: This option provides quick access to all functions in the Lookup &
Reference category.
Math & Trig: This option provides quick access to all functions in the Math & Reference
category.
More Functions: This provides access to the Statistical, Engineering, Cube, Information,
Compatibility, and Web categories.

Define Names: With this Define Names group, you can define the name of a cell. Not only that, this allows you to
view the named sections on the worksheet in the Name Manager, and edit then them to the name you want or
desire. The Define Names contains the following:



Define Name: This button contains two commands; Define Names and Apply Names. The Define
Names are used to create a workbook and worksheet level named ranges, and the Apply Name
shows the Apply Name dialog box.
Use in Formula: This contains a list of all the named ranges in the workbook alongside the Paste
Names command.
Create from Selection: With this option, you can name a cell or range of cells selected making use
of the row or column title that has been previously entered.

Formula Auditing: The Formula Auditing group is responsible for checking and correcting formulas. The
following are the options in Formula Auditing

Trace Precedents: This helps to know the cells that affect the value of the currently selected cell.
Trace Dependents: This helps to know the cells that are affected by the value in the cells that are
currently selected.
Remove Arrows: This is the option that removes all the arrows drawn by the trace precedents and
trace dependents.
Show Formulas: This is what displays the formula instead of the result in the worksheet.
Error Checking: This is what checks the errors in a formula on the worksheet.
Evaluate Formula: This allows you to thoroughly go through a formulation
Watch Window: This option shows you where to view and monitor all the contents of the cells
and their result as changes as made.

Calculation: The Calculation group help to switch from calculation from automatic to manual. The following are
the options in Calculation

Calculation Options: This option allows you to change the calculation in your active workbook
from manual to automatic except for the data in tables. If you make a change that affects a value,
Excel will automatically recalculate it.
Calculate Now: This is used to calculate the entire workbook now. This is only used when the
automatic calculation is turned off.
Calculate Sheet: This is used to calculate the entire active cell, and it is used when the automatic
calculation is turned off.



Solutions:  The Solution group is only displayed when there is a Euro Currency Tool add-in loaded in Excel. The
following are the options in the Solution group:

Euro Conversion: This launches the Euro Conversions Wizard
Euro Formatting: This is used to apply Euro formatting to the cells selected.
Quick Conversion: This is used to execute quick conversions

Categories of Data Excel’s Formula Accepts   
The Excel formula is characterized by the data values it accepts, and anything short of this data value may not work.
These data values are highlighted below:
Constant: These are numbers inserted directly into the formula bar. For instance, inputting =4+8 into the formula
bar to get 12

Operators: These are symbols used in Exel to perform arithmetic operations (addition, subtraction, multiplication,
etc.), comparing values (greater than or less than), and merging values (&). For instance, entering =7<10 into the
formula bar returns the value to TRUE; this is because 7 is less than 10



Cell Reference: This is a cell or a range of cells on the worksheet that can be used in a formula so that Excel can
find the values or data you want the formula to calculate. For instance, entering =A1-A3 connotes that Excel will
subtract the value in cell A3 from cell A1

Inserting Formulas into your Worksheet
Learning how to enter formulas into your worksheet is very important. So, you will be learning how to insert
formulas in your worksheet using several methods, and they are highlighted below
Simple Insertion: The Simple Insertion method has to do with entering the formula into the cell or Formula Bar.
The Formula bar can be seen above the column header. To use the Simple Insertion method,

Go to the Formula bar or click on a cell
Start typing an equal sign (=), followed by the name of the function, and then press Enter.

The Insert Function: One of the methods to enter a formula in Excel is the Insert Function command. The Insert
Function consists of all functions found in Excel’s worksheet. To locate the Insert Function

Go to the Formula tab and click on Insert Function in the Function Library

In the Insert Function dialog box, click on any function you wish to use on the worksheet, and
then click on OK.



Group of Formula: Another way to enter a formula in your worksheet is by using selecting any
formula from the group of formulas in the Function Library group.

The group of formulas includes AutoSum, Recently Used, Financial, Logical. Text, Date & Time,
Lookup & Reference, Math & Trig, and More Functions

AutoSum Option: This is used for quick and everyday tasks. To use the AutoSum Option, go to the
Formula tab and click on Recently Used in the Function Library

Recently Used Tab: This tab comes in handy when you want to relieve the stress of re-tying your
most recent formula. To locate this tab, go to the Formula tab and click on Recently Used in the



Function Library.

Editing the Formula
To edit the formula in your worksheet, you can use any of the following techniques

Using the Formula bar: To edit your formula, go to the Formula Bar, and start editing the
formula.

The Formula Cell: To edit the formula in your worksheet, click directly into the cell, and the cell
will be activated into an Edit mode where you can make changes to the formula.



Understanding the Formula Operators
The Formula operators specify the type of calculation that you want to execute in the worksheet. Such operations
include addition, subtraction, multiplication, or division, etc.
The following are types of Formula operations in Excel
Arithmetic Operators: Arithmetic operators are operators that are concerned with basic mathematical operations
such as addition subtraction division or multiplication. These operators work with numbers.
The following are the examples of arithmetic operations

ARITHMETIC
OPERATOR

NUMBERS
OF
OPERANDS

ARITHMETIC
FUNCTION

EXAMPLES

Plus sign + 2 Addition 3+1
Minus sign - 2 Subtraction 4-2
Minus sign - 1 Negation -3
Asterisk * 2 Multiplication 3*7
Forward slash / 2 Division 4/3
Exponentiation
^

2 Raise the power
of a value

4^1

Percent % 1 Divide by 100 35%

Comparison Operators: These are operators that compare two values to carry out operations such as less than,
greater than, equal to, etc. When these two values are compared, the result is always in a logical value which could
be TRUE or FALSE.
The following are the comparison operators listed in the table below:

COMPARISON
OPERATOR

MEANING EXAMPLE

Equal sign = Equal to 2=2
Less than sign < Less than 2<6
Greater than sign > Greater than 5>1
Greater than or
equal to sign>=

Greater than or equal
to

67>=333

Less than or equal
to sign =<

Less than or equal to 52<=321

Not equal to sign <> Not equal to 5<>7
Concatenation Operator: This operator joins or combines two or more springs to form a single text or string. The
Concatenate operation receives text as their input values and if they are not texts, they are transformed into texts.
OPERATOR MEANING EXAMPLE
Ampersand & Connect or join two

values to produce a
single text

‘’In’’ & ‘’put’’ to
form ‘’Input’’

Logical Operators: These are operators that accept Boolean values as the values of their operands, and they
produce one Boolean value as their result or outcome.



The logical operators are highlighted in the table below
LOGICAL
OPERATOR

NUMBERS
OF
OPERANDS

MEANINGS EXAMPLE

And 2 True if both
input values are
true

5<3 and
amount <3

Or 2 True if one of
the input values
is true

7>5 or 4<7

Not 1 Reverses the
value of its
input value

not 5>6

Reference Operator: These operators combine ranges of cells for calculations, and they are highlighted in the
table:

REFERENCE OPERATOR MEANING
Colon): Range operator: This gives one

reference to all the cells between
two reference 

Comma ‘ Union operator: This joins
multiple references into one
reference

Space Intersection operator: This gives
one reference to cells common to
the two references.

Access Operators: The access operators consist of the following operators; the Dot operator (.), the index operator
([]), and the At operator (‘@).
The Alt Operator: This is the operator is used to specify or indicate many alternative formulas that can be used in
a cell.
The IF Operator: The IF operator is used to perform conditional calculations.

The Order of Operator Precedence in Excel Formulas
Just as BODMAS is to mathematics, the Operator Precedence is to Excel’s worksheet.
The order of operator precedence can be defined as the specific order at Excel evaluates and carry out calculations
when a formula is created using many operators. For example, Excel executes multiplication before addition.
The following is the order of precedence in Excel:

Evaluate the values in parentheses
Evaluate the range (:)
Evaluates the intersections (spaces)
Evaluate unions (,)
Perform negation (-)
Convert percentages (%)
Perform exponentiation (^)
Perform multiplication (*) and division (/), that are of equal precedence
Perform addition (+) and subtraction (-) which are of equal precedence
Evaluate text operators (&)
Perform comparisons (=, <>, <=,>=).

Manipulating the Order of Precedence Using the Parentheses
To change the order of precedence in your Excel worksheet, enclose the part of the formula into a parenthesis.
Doing this, the formula enclosed in parentheses is calculated first.
For instance, if the parentheses are applied to these values; =(6+2)*3, the values enclosed in the parentheses are
calculated first i.e.  6 and 2 are added together and then multiplied by 3 to produce 36.
In contrast, if the parentheses are not applied in the same values: =6+2*3, Excel multiplies 2 by 3 following the
order of precedence, and then adds 6 to it producing 12.



In a nutshell, applying parentheses to your formula makes the calculation clearer and easier.

Cell Referencing
A cell reference is an alphanumeric value or data used in excel to locate or identify a cell in the worksheet. The cell
reference comprises one or more letters for the columns and a number for the row e.g. A1. You can locate the data
you wish to calculate using the cell reference. The cell reference is also known as cell address.

Types of Cell References
To have a better understanding of how to use the cell references together with formulas, it is pertinent to know
about the types of cell references. Now let’s quickly go examine the types of cell references.

Relative References
By default, the cell references in the Excel worksheet are relative. When the cells are copied across the multiple
cells, the cells change based on the relative position of rows and columns. For instance, when you add =B3+C3 in
cell D3 and copied it to cell D4, the formula will change to =B4+C4. The relative references are best used when
you want to replicate the same action across multiple rows and columns.
To create and coy formula using the relative references, use the following procedures

Click on the cell (D1) where you  wish to enter the formula and type in the formula =(B1*C1) in
the cell to get the anticipated result

Press the Enter key and the formula will be calculated, showing the outcome of the formula in the
cell

Locate the Fill handle in the lower part of cell D2, click on it, then hold and drag it down to cell
D6.
When you release the mouse, the formula will be copied to the cells selected, showing the result in
each cell.



Absolute Cell Reference and Multiple cell Reference
An absolute cell reference is a cell reference that stays locked on a specific cell or cell ranged, even if the formula is
changed making use of the dollar sign ($). In other words, an absolute cell reference makes use of the dollar sign ($)
to keep both row and column constant when copying a formula from one cell to the other in a worksheet.
A multiple cell uses the dollar sign to keep either the row or column constant.
$A$3 The column and the row will not change when copied
A$2 The row will not change when copied
$A2 The column will not change when copied

In the example below, we will be using cell D1 that contains the tax rate of 8% to calculate the sales of each item in
column E. However, we will need to make the D1 constant when we copy the formula to fill other cells. If the D1 is
not made constant, the following result will be gotten.

To avoid getting the result shown in the table above, follow the steps given below using the dollar sign
Click on the cell (E3) where the formula will contain and type in the formula =(B3*C3)*$D$1 in
the cell to get the anticipated result.



Press the Enter key and the formula will be calculated, showing the outcome in the cell.

Locate the Fill handle in the lower part of cell E4, click on it, then hold and drag it down to cell
E8.
When you release the mouse, the formula will be copied to the cells selected, showing the result in
each cell

REFERENCING OTHER WORKSHEETS IN A WORKBOOK
Referencing another worksheet within a workbook allows you to use the same value on one or more worksheets
without writing or copying the formula from the scratch. This saves time and makes the work easier to do. To
reference another worksheet within a worksheet, follow the steps provided below:

Locate the cell (E9) you want to reference and keep track of the name of the worksheet (January
sales tax).



Open the worksheet (Total sales tax) you wish to apply the reference to and select the cell you want to
insert the value. Enter the equal sign (=), the sheet name, an exclamation mark (!), and the cell address
E9; =' January sales'!E

Press Enter on the keyboard and the value of the reference will be displayed in the new worksheet. In
case any change is made in the January sales, it will be updated automatically in the Total sales tax



How to Copy Formula from One Cell to Another
Copying of cells in Excel is one of the easiest tasks to learn. Here in this session, you will be learning the various
ways you can use to copy a formula from one cell to the other.

Copying Formula Down a Column
To quickly copy a formula down a column, follow the steps given below

Type the formula into the top cell and press Enter on your keyboard

Select the cell with the formula, move the mouse cursor over a small square at the lower right-hand
corner of the cell (Fill handler). When you click on this, the cursor changes to a thick black cross.
Hold and drag the fill handle down the column over the cell and the formula will be copied on the
selected cells.



Copying a Formula Down a Column Without Copying the Formatting
Copying a formula down a column without copying the formatting implies that when you copy a formula, the
formatting such as font, font color, background color, currency, etc. will not be copied. To do this, follow the steps
given below:

Type the formula into the top cell and press Enter on your keyboard
Select the cell with the formula, move the mouse cursor over a small square at the lower right-hand
corner of the cell (Fill handler). When you click on this, the cursor changes to a thick black cross.

To remove the cell formatting, hold and drag the fill handle and click on Auto Fill Options drop-
down menu at the bottom of the cells the formula was copied to. Then click on Fill Formatting
only.



The cell formatting is removed as shown in the table below

Copying Formula to the Entire Column
Instead of using the Fill handle to copy the formula by dragging it down to hundreds of sheets, you can double-click
the plus sign.
To copy an Excel formula by double-clicking the plus sign, follow thee

Enter the formula in the top cell
Place the cursor to the lower right corner of the cell with the formula, pause until it changes into
the plus sign, and then double click the plus.

After doing this, the formula is copied down to the last row in the worksheet.



Copying Formula to Non-adjacent Cells/Range
There is a limit to what the fill handle can do and one of it is that it cannot copy the formula to a non-adjacent cell.
To copy a cell to a non-adjacent, use the copy and paste method by following the steps provided below:

Click on the cell with the formula and click on Ctrl + C to copy the formula

Select a cell or the range of cells where you wish to paste the formula.
Press Ctrl + V to paste the formula and then press the Enter button to complete the formula entry

Entering a Formula into Multiple Cells with a Single Key Stroke
To copy a formula into more than one cell, follow the steps given below

Select the cell or range of cell you want to input the formula
Press F2 to enter the edit mode and enter the formula in a cell.



Press Ctrl + Enter and the formula will be replicated in the selected cells.

Copying Excel Formula Without the Formatting Using the Copy & Paste Features
Apart from using the Fill handle to copy the formula without copying the cell formatting, another better and
advanced method is to use the Copy & Paste feature

Select the cell with the formula
Right-click on the cell and select Copy in the context menu



Select the cells you wish to copy the formula to
Right-clicked on the cells selected and select Formulas under Paste Options. As shown in the table
below, the formula is copied without the cell formatting

Dealing with Errors in Your Formula
While working on Excel especially in inserting formulas into your worksheet, mistakes are bound to occur from
time to time. When these mistakes are not rectified, most times, you end up getting stuck in the middle of the
calculation.  To avoid this calamity, Excel provides several methods to rectify these errors. But before we go, let’s
quickly go through Excel Formula Errors Messages.

Excel Formula Error Messages
The following are the Excel formula Error Messages, meanings, and their causes.
#DIV/0!
Excel displays this error value when you are asking Excel to divide a formula by zero or an empty cell.
Mathematically, if you try dividing a number by zero. It will not work, and this is also applicable in Excel. To
rectify this error, change the value of the cell to a value that is not equal to 0 or add a value to the blank cell.
#NAME?
This error value appears when Excel does not recognize the name of the formula used as a valid object. This error
occurs when one types the incorrect range name, refers to a deleted range name or forgets to place the quotation



marks around a text string in a formula. To resolve this error, thoroughly check the spelling of the formula you are
trying to run, or you can use the Formula Builder to have Excel build the function for you.
#N/A
This error value appears when the numbers being referred to in the formula cannot be found. This can occur when
you mistakenly deleted a number or row that is used in the formula, or when you refer to a sheet that has been
removed or not saved.
To rectify this error, thoroughly check all the formulas be used and make sure to identify all the sheets or rows that
may have been deleted or referenced incorrectly.

#NUM!
This error value is displayed when the formula in your worksheet contains numeric values that are different from
the arguments used.
To rectify this error, thoroughly check to see if you have inputted any formatted currency, dates, or special symbol.
After this, you can now remove the formatting from the formula and keep the numbers.
#NULL!
This error value is displayed when you specified an intersection of two areas that do not intersect, or when the
incorrect range operator is used. For instance, when you use a space instead of a comma between ranges in the
function arguments, Excel will display the formula as #NULL! value error.
To rectify this error, ensure to check if the correct syntax is used in the formula. You can also follow the tips below
to avoid

Use a colon to separate the first cell from the last cell when referring to a continuous range of cells
in a formula.
Use a comma when referring to two cells that don’t intersect

#REF!
This error value is displayed when you referring to a cell or a range of cells that doesn’t exist. This occurs when you
delete, a cell, column, or row, and then build a formula around the deleted cell, column, or row.
To rectify this error, check to see if there is no formula referring to any cell you have deleted. Before deleting cells,
carefully where the formulas are referred to in those cells.
#VALUE!
This error value is displayed when Excel find spaces, characters, or text formula in a place where it is expecting a
number.
To rectify this error, carefully check your formula to use numbers where it is needed. Ensure to also check out for
blank checks, missing formulas that are linked to cells, or any special characters that are being used.

Using the Error Checker Button
One of the ways to check errors in your formula is to use the error checker. Using the Error checker keeps you
informed on whatever error is faced or encountered.
To use the error checker, follow the steps given below to correct the error in the table provided



Go to the Formula Bar and click on the Error Checking button in the Formula Auditing group

In the Error Checking dialog box, the error in the formula is clearly stated and then click on Edit
in Formula Bar to repair the formula error.
When you are done with the repairing of the formula error, click on the Resume button

After this is done, the error is removed as shown in the table below



Tracing Cell References
Tracing cell references allows you to see how data in a cell figure into a formula in another cell, and how a cell
containing formula gathers its data from to make its computation. This also allows you to know how formulas are
created and connected to the worksheet. There are two ways of tracing cell references; tracing precedents and
tracing dependant.

Tracing Precedents
Tracing precedents allows you to select a cell with a formula in it and locate the cells that are computed to produce
the outcome or result of the formula. When you use the cell tracer, Excel points an arrow from the referenced cells
to the cell that contains the formula result.
To use the trace precedents, follow the steps given below

Select the cell with the formula you wish to trace
Go to the Formula tab and click on Trace Precedents in the Formula Auditing group.
In the table below, arrows leading from the selected cell extend and point to the cells that use its
data in their calculation.

Tracing Dependents
Tracing dependents allows you to select a cell and trace its dependants to locate the cells that contain a formula that
uses the data from the cell selected. When you use the cell tracer, Excel points an arrow from the cell you selected
to cells with formula result in them.
To use the trace dependents, follow the steps given below

Select the cell with the formula you wish to trace
Go to the Formula tab and click on Trace Dependents in the Formula Auditing group.
In the table below, arrows leading from the selected cell extend and point to the cells with the
formula result in them



NOTE: To remove the cell tracer arrows from your worksheet, go to the Formula tab and click on the Remove
Arrow button in the Formula Auditing group.

Working with a Function
As earlier said at the beginning of this chapter, a function is a predefined formula containing a special name and
purpose. The function begins with an equal sign, followed by the function’s name, and ends with its arguments.

UNDERSTANDING THE FUNCTIONS ARGUMENTS
The function arguments are the inputs or values inside the parenthesis that are used to execute or carry out
calculations in the Excel worksheet. Let’s quickly highlight the categories of function arguments

Functions with no Arguments: These are functions that do not need any arguments to execute
their operations in Excel. Some of the functions without the use of arguments include the following
RAND (), TODAY (), and NOW (). Although these functions do not need any argument to work,
they still require the use of open and close parenthesis to work.
Function with One Argument: These are also some functions that use one argument to execute
their operations in |Excel. An example of a function with an argument is the UPPER function; the
UPPER function takes accepts one argument as input, and then converts the lower-case letters to
upper-case letters.

Functions with Multiple Arguments: Some functions use more than one argument to execute
their operations. To use multiple functions in a function, a comma is used in between them.  For
instance, suppose you wish to find the sum of the number in a cell range, you can use two
arguments with a comma to separate them. E.g. =SUM (B3:B8, C3:C8)



Functions with Required and Optional Arguments: Apart from using the required argument,
some functions come with optional arguments. One of these functions is NETWORKDAYS. The
NETWORKDAYS function gives or returns the numbers of workdays between the start date and
the end date. The following is the syntax of the NETWORKDAYS function:

NETWORK DAY (start_date, end_date, [holidays])

Locating the Arguments in a Function
While working on your worksheet, you can locate the arguments used in your function using the following
methods;

The Function Dialog Box
Tooltip Windows in Excel

The Function Dialog Box
The Function dialog box contains or displays the list of the required and optional arguments a function has
To check the arguments in your function, follow the steps provided below

Go to the Formula tab and click on the Insert Function in the Function Library
In the Insert Function dialog box, the function arguments are displayed.

The Tooltips
Another way to locate the function argument is to use the Tooltips. To find the arguments using the Tooltips, do

the following
Enter the function’s name with the open parenthesis in a cell

After doing this, the argument is displayed in the Tooltips



Taking a Look at Commonly Used Functions in Excel
There are some functions in Excel that are used from time and time, and these functions are functions you must
know as a user of Excel. Now let’s check these functions out.

FUNCTION USES

SUM(number1, [number 2], …) This returns the aggregate value of the numbers
in the arguments

AVERAGE (number1, [number 2], …) This returns the average of the numbers in the
cells listed in the arguments.

COUNT(value1, [value2], …) This counts the number of cells that have a
number value in them.

COUNTA (value1, [value2], …) This does not only count the number of cells
with numbers in them, it also counts the dates,
time, strings, logical values, empty string, or
text.2

MAX(number1, [number 2], …) This is used to find the largest value in the cells
listed in the arguments.

MIN(number1, [number 2], …) This is used to find the lowest value in the cells
listed in the arguments

PRODUCT(number1, [number 2], …)  This finds the product of multiplying the cells
found in the arguments.

IF(logical_test, [value_if_true], [value_if_false]) This is used to sort out data according to the
logic given or provided.

TRIM(text) This is used to ensure that your function does not
return an error due to unruly space I.e., it is used
to remove empty spaces

VLOOKUP (lookup value, range, column number, false
or true).

This is used to find a certain value in a column to
return a value from a different column in the
same row

AND

SUM for Adding Up Data
The SUM function allows you to find the total value of data within a cell range. The SUM function uses the
following arguments
SUM(number1, [number2], [number3]……)   
With the table below, calculate the sales made from January to June using the SUM function. 



To calculate the sales of Jan to July using the SUM function, follow the steps below

Select an empty cell B8 and enter the function with cell range in it; =SUM(B2:B7)

Press Enter and the total sales of Jan to June is calculated as displayed in the table below

AVERAGE for Averaging Data
The AVERAGE function returns the average value of data within a cell range and it uses the following arguments
for its operations



AVERAGE (number1, [number 2], …)
With the table provided below, calculate the average sales made from January to June using the AVERAGE
function. 

Select an empty cell B8 and enter the function with the cell range in it; =AVERAGE(B2:B7)

Press Enter and the total average sales of Jan to June is calculated as shown in the table below



Deriving the function of a Cell Using FORMULATEXTS
The FORMULATEXT function returns the formula used in a given reference in a text form.
The FORMULATEXT function contains a single argument
= FORMULATEXT(reference)
With the data provided below, find the formula used using the FORMULATEXT function

To use the FORMULATEXT function to find the formula used in a text, follow the steps given below
Select an empty cell C8 and enter the function with the cell range in it; = FORMULATEXT (B8)

Press Enter and the formula used in the cell selected will be displayed.



Counting the number of Data Items Using COUNT
The COUNT function This counts the number of cells that have a number value in them.
The COUNT function uses the following arguments
COUNT(value1, [value2], …)

With the range of cells provided below, use the COUNT function to find the number of cells with numerical values
in them

To find the cells with number values using the COUNT function, follow the steps provided below
Select an empty cell C8 and enter the function with the cell range in it; = COUNT (A1:C8)

Press Enter and the number of cells with number value will be displayed.



Counting All Data Type Using the COUNTA
The COUNTA function does not only count the number of cells with numbers in them, it counts the dates, time,
strings, logical values, empty string, or text.2
The COUNTA function uses the arguments below
COUNTA(value1, [value2], …)
Using the data given below, use the COUNTA function to find the number of cells containing data in them.

Select an empty cell D7 and enter the function with the cell range in it; = COUNTA (A1:C6)



Press Enter and the number of cells with data will be displayed.

Counting Blank Spaces Using COUNTBLANK
The COUNTBLANK function returns the numbers of empty cells in a range of cells, and the COUNTBLANK
function has just an argument
COUNTBLANK(range)
With the data below, find the number of empty cells with the range of cells using the COUNTBLANK function



Select an empty cell D7 and enter the function with the cell range in it; = COUNTBLANK
(A1:C6)

Press Enter and the number of cells without data will be displayed.

CONCATENATE for Combining Values
The CONCATENATE is a text function that allows you to join values from different cells into one cell in a
worksheet.
The CONCATENATE function uses the arguments below
CONCATENATE(text1, text2, text3…)
With the table provided, join the first and last name using the CONCATENATE function.



Select an empty cell C2 and enter the function with the cell range in it; = CONCATENATE (A1,
B2)

Press Enter and the values in the two cells will be joined together.

Finding the Lowest Number Using MIN               
The MIN function helps to return the lowest value in a given set of cells or arguments.
The MIN function includes the following arguments
MIN (number1, [number2],…)
With the data provided below, find the lowest number using the MIN function. 

Select an empty cell B7 and enter the function with the cell range in it; =MIN (A1:B6)



Press Enter and the lowest value in the data will be calculated in the cell selected.

Finding the Highest Number Using MAX
The MAX function helps to return the highest value in a given set of cells or arguments.
The MAX function includes the following arguments
=MAX(number1, [number2],…)
With the data provided below, find the highest number using the MAX function. 

Select an empty cell B7 and enter the function with the cell range in it; =MAX (A1:B6)



Press Enter and the highest value in the data will be calculated in the cell selected.

Counting Text Characters with LEN Function
The LEN is a text function that returns the number of text characters in a cell and it uses the argument provided
below to execute its operations
LEN(text)
With the data provided below, find the number of text characters in cell A5 using the LEN function.

Select an empty cell B5 and enter the function with the cell range in it; =LEN (A5)



Press Enter and the number of text characters will be calculated in the cell selected.

Changing the Orientation of the Cells With TRANSPOSE
The TRANSPOSE function is a function that changes the orientation of a given range of cell or array from vertical
range to horizontal range, and from horizontal range to vertical range. When using the TRANSPOSE function, the
range or array selected must have the same number of rows and columns.
The TRANSPOSE uses the following argument
TRANSPOSE(array)
With the data provided below, change the orientation of the range of cells from vertical to horizontal using the
TRANSPOSE function

Select a range of cells (A8:F9) and make sure that the cells selected have the same rows and
columns as the original set of cells arranged in a vertical direction.



In the selected cells, enter the function with the cell range in it; =TRANSPOSE(A1:B6)

Press Enter and the orientation of the range of cells selected will be changed from vertical to
horizontal

Capitalizing the First Letter of your Text String with PROPER
The PROPER function changes the first letter of each word in the cell to uppercase.
The PROPER function uses the following argument
PROPER(Cell address)
With the data provided below, change the first letter of a cell to an uppercase using the PROPER function.



Select an empty cell B3 and enter the function with the cell range in it; =PROPER(A3)

Press Enter and the first letter of the selected cell will be capitalized.

Removing Spaces With TRIM
The TRIM function removes spaces that cause errors in the data. The TRIM function can only work on a single cell.
The TRIM function uses the following argument
TRIM(text)
Use the TRIM function to remove the spaces in the data below

Select an empty cell B1 and enter the function with the cell range in it; =TRIM(A1)



Press Enter and the space in the selected cell will be removed. 

Finding the Position of a Substring in a Text String Using the SEARCH Function
The SEARCH function is a function that allows you to find the location of a substring in a string. This SEARCH
function is case insensitive and allows the use of wildcards.
The SEARCH function uses the following arguments
SEARCH (find_text, within_text, [start_num]

Find_text= The text to search for
Within_text= The text to search from
Start_num= The location to start the search for within the text

In the data given below, find the position of L in cell B3 using the SEARCH function.

Select an empty cell C3 and type =SEARCH(“L”, B3, 1)

Press Enter and the function will return the location of the substring text within the text.



Finding the Position of a Substring in a Text String Using the FIND Function
Just like the SEARCH function, the FIND function returns the position of a substring within a string. However,
unlike the SEARCH and FIND functions; unlike the SEARCH function, the FIND function is case sensitive i.e. it
can work on both small and letters.
The FIND function uses the followings arguments
=FIND (find_text, within_text, [start_num]

Find_text= The text to search for
Within_text= The text to search from
Start_num= The location to start the search for within the text

In the data given below, find the position of DANGER in cell B2 using the FIND function.

Select an empty cell C3 and type =FIND(“DANGER”, B2,1)

Press Enter and the function will return the location of the substring text within the text.

Making Logical Comparison with Values Using the IF Functions
The IF function tests a given condition and returns one value for a TRUE and another value for a FALSE result.
The function makes a logical comparison between values. While using the IF function, it can use the following
logical operators



Equal to (=)
Greater than (>)
Greater than or equal to (>=)
Less than (<)
Less than or equal to (<=)
Not equal (<>)

The following are the arguments in the IF functions
=INDEX(Logical_text,[ Value_if_true],[ Value_if_false])

Logical_text (Required Argument): This is the value or logical expression that is to be tested and
evaluated as either TRUE or FALSE
Value_if_true (Optional Argument): This is the value that will be returned if the logical test
evaluates to TRUE

Value_if_false (Optional Argument): This is the value that will be returned if the logical test
evaluates to FALSE

With the data provided below, test the values in each cell. If the value of each cell is less than 70, return fail, and if
it is greater than 70, return Pass.

Select an empty cell C3 and type =IF(B2<70,"Fail","Pass")

Press Enter and the function will return the value of the cell to Pass



Drag the fill handle down to apply the formula to other cells

Checking the Current Date and Time with TODAY and NOW
The TODAY function returns the current and the NOW function returns the current date. These functions do not
use any argument.
TODAY()
NOW()

CHAPTER EIGHT
TABLES AND CHARTS IN EXCEL

In this chapter, you will be learning how to use tables and charts to illustrate your data. For tables, you will learn
how to insert tables, change the table layout. And for charts, you will learn how to edit charts, create elements in a
chart, and lots more.

Creating a Table
Before creating a table, there are certain hints to take note of. These hints allow you to create a perfect table for
your data. The hints are stated below:

Ensure to arrange and organize the rows and columns
Each column in the first row must have a heading
All the columns must contain one set of data each



There must be no blank row or column in the list 

To create a table, follow the steps provided below
Select the cell or range of data you wish to create the table for

Go to the Insert tab and click on Table in the Tables group

In the Create Table dialog box, the selected range of cells is displayed.
Checkmark My table has a header if you want the first row of the range to be the header row,
and then click on OK

Finally, the selected range of cells is formatted into a table



Changing Your Table Style
You can change the table style applied to your data. To do this, follow the steps provided below

Select the cells or range of cells you wish to change the table format

Go to the Design tab, click on Table Styles, and select the More drop-down arrow to see the table
styles available.

Select the desired table style and it will be applied to the selected range of cells.



Removing the Table
To remove the table from your cell, follow the steps provided below

Select the cell or range of cells in your table

Go to the Design tab and click on Convert to Range in the Tools group.

In the dialog box that appears, click on Yes

Here, the table will be removed and the cell will keep their data and formatting.



To remove the formatting from your table, go to the Home tab, select Clear, and then click on
Clear Formats.

In the data below, the formatting is removed



Renaming a Table
By default, the name of a table could be table 1, table 2, table 3, etc. However, you can rename your table, to do
this, follow the steps given below

Go to the Design tab and click on Table Name in the Properties group, and then change the
name of the table

Here, the table is renamed

Filtering the Data in Your Table
Filtering the data in your table helps to determine the data you wish to hide or display in your worksheet. To do this,
follow the steps given below
In case you are wondering how to display and hide some data in your worksheet. The Filter command is what you
need to use. To use the Filter

Click on the column of the header in the worksheet
Go to the Data tab and click on Filter in the Sort & Filter group.
Click on the Filter drop-down arrow that appears on the header of the column



In the window that displays, unmark the box you don’t in your worksheet, and then click on OK

The filtered data is shown in the table below



Grouping of Data in Your Table
Grouping data in Excel allows you to hide data from either the rows or columns. To group data, follow the steps
given below:

Select the data you want to group

Go to the Data tab and click on Group in the Outline group.

Select Row and click on Ok.

In the image below, the data in the cells are group



Sorting Out Data in Your Table
Sorting out data in your table helps you to determine how the data will appear in your table. To sort out data in your
table, follow the steps provided below

Click on the arrow next to the column heading
In the window that pops up, select any method of sorting out your data and then click on Ok

In the table below, data is sorted from A to Z

Adding Slicer in Your Table
The slicer command provides options that allow you to filter your data in the table or pivot table. To add a slicer to
your table, follow the steps below



Click anywhere in the table
Go to the Insert tab, and click on Slicer in the Filter group

In the Insert Slicers dialog box, choose the checkboxes for the field you wish to display, and then
click on OK

Here in the table, a slicer will be created for the fields selected

Creating Pivot Table



To create a pivot table, follow the steps giving below:
Select the cells you wish to create a pivot table for
Go to the Insert tab, and click on PivotTable in the Table group
In the Create PivotTable dialog box, set the following

Click on Select a table or range under Choose the data you want to analyze
Verify the cell range under the Table/Range
Select New worksheet or Existing worksheet under Choose where you want the
PivotTable report to be placed

Then click on Ok
In the PivotTable Field task pane, drag the field names into the four areas displayed below
(Filters, Columns, Rows. And Values)



After doing this, the data with the pivot table is displayed like the image shown below

Inserting Recommended PivotTable in Your Data
One of the easiest and fastest ways of inserting a pivot table in your data is using the recommended pivot table
provided by Excel.
To use the recommended pivot table, follow the steps given below
Select anywhere in your data list to insert the recommended pivot table



Go to the Insert tab and click on Recommended PivotTable in the Table group

In the Recommended PivotTable dialog box, choose any style of your choice and then click on
the OK button

Here, the data is arranged inside the recommended pivot table



Working with Charts in Excel
Charts in Excel are powerful tools that help to interpret data graphically. With charts, the users can get the meaning
behind the numbers, using comparison and trend.

Types of Charts
There are so many charts in Excels used for different purposes, however, we will highlight just a few out of them
below
Column Charts
The Column Charts use vertical bars to represent data. The column charts show the categories on the horizontal axis
and the values on the vertical axis.
These charts work with different kinds of data and can be frequently used in comparing information.  The following
are the types of Column Charts

Clustered Column
Stacked Column
100% Stacked Column
3-D Clustered Column
3-D Stacked Column
3-D Column

Line Charts
Lines Charts are best suited for displaying trends in data over years, months, or days. Here, the data point is linked
with lines which makes it easy to see if the values are increasing or decreasing.
The following are the types of Line Charts

Line
Stacked Line
100% Stacked Line



Line with Markers
Stacked Line with Markers
100% Stacked Line with Markers
3-D Line

Pie Chart
The Pie Chart displays the size of items in a data series with the sum of the items. Each value in the data is
displayed as a slice of the pie, thereby, making it easy to see all the values that sum up the percentage of a whole.
The following are the types of pie charts

Pie
Pie of Pie
3-D Pie
Bar of Pi

Bar Charts
The Bar Charts help to show the comparison among individual items. The bar charts display the categories on the
vertical axis and the values on the horizontal axis. The following are the types of Bar Charts:

Clustered Bar



100% Stacked Bar
Stacked Bar
3-D Stacked Bar
3-D Clustered Bar
3-D 100% Stacked Bar

Area Chart
The Area Charts can be used to illustrate the change over time and bring attention to the total value across a trend.
The following are the types of Area Charts

Area
Stacked Area
100% Stacked Area
3-D Stacked Area
3-D Area
3-D 100% Stacked Area

Stock Charts
The Stock Chart is a price chart that shows or displays a stock’s price that is plotted over a period.  It displays the
rise and fall in stock prices.
The Stock Charts can also reveal the fluctuation in other data such as rainfall or annual temperature. The following
are the types of Stock Chart

High-Low-Close
Open-High-Low-Close
Volume-High-Low-Close



Volume-Open-High-Low-Close

Creating a Chart with Your Data
To create a chart with your data, follow the steps given below

Select the cells or the range of cells you wish to add a chart to; ensure to add the column titles and
row labels

Go to the Insert tab and click on any of the charts (Column or Bar Chart) you want in the Chart
group

Choose the chart type you want from the drop-menu



Finally, the selected chart appears in the data provided

Changing the Chart Styles
To change the chart styles of your data, follow the steps provided below

Click on the chart, go to the Design tab



In the Chart Styles group, select any chart style you want, and it is reflected in the chart

Changing the Chart Layout
To change the chart layout, follow the steps provided below

Click on the chart, go to the Design tab
Click on Quick Layout in the Chart Layouts group



In the Quick Layout drop-down menu, select any of the layouts you want.

The chart appears with the new chart layout

Changing the Chart Types
To change the chart type in your data, follow the steps given below

Select the chart



Go to the Design tab, click on Change Chart Type

In the Change Chart Type dialog box, click on the chart you want, and then click on Ok.

The chart is changed as illustrated in the image below



Switching the Rows and Columns in Your Chart
To switch the rows and columns, follow the steps provided below

Select the Chart

Go to the Design tab and click on Switch Row/Column command in the

Here, the chart rows/columns will be adjusted



Moving Your Charts from One Worksheet to Another
To move your chat from one worksheet to another, follow the steps given below

Click on the Chart
Click on the Design tab and select the Move Chart command

In the Move Chart dialog box, select the location you wish to move the chart to

Click on Ok and the chart will be moved to another worksheet.

Creating Pivot Chart
To create a pivot chart, follow the steps giving below:

Select the cells you wish to create a pivot chart for
Go to the Insert tab, click on PivotChart in the Chart group, and then select PivotChart in the
drop-down menu
In the Create PivotChart dialog box, set the following



Click on Select a table or range under Choose the data you want to analyze
Verify the cell range under the Table/Range
Select New worksheet or Existing worksheet under Choose where you want the
PivotTable report to be placed

Then click on Ok
In the PivotChart Field task pane, drag the field names into the four areas displayed below
(Filters, Columns, Rows. And Values)



After doing this, the data will be displayed in the pivot chart



CHAPTER NINE
SOLVING COMMON PRINTING PROBLEMS IN EXCEL

One of the most important things to know in Excel is how to print. In this chapter, you will be learning various
techniques on how to prints. Some of them are changing the orientation before printing an Excel worksheet,
printing one or several worksheets, printing workbooks, printing part of a worksheet, printing the formula, and lots
more.

Changing the Excel Worksheet Orientation Before Printing
You can change the orientation format of your Excel worksheet to either landscape or portrait. To do this, follow
the steps given below

Select the worksheet you wish to print

Go to the Page Layout tab, and select Orientation in the Page Setup group
In the Orientation drop-down menu, click on either Portrait or Landscape

Printing One or Several Worksheets



To print one or several worksheets, do the following
Select the worksheet(s) you wish to print

Go to the File tab and click on Print

In the Print Range drop-down menu, click on Print Active Sheet

Then click on the Print button



Printing an Entire Workbook
To print an entire workbook, ensure you are currently on the workbook and then follow the steps provided below

Go to the File tab and click on Print

In the Print Range drop-down menu, click on Print Entire Workbook



Then click on the Print button

Printing a Selection
To print a specific part of the Excel worksheet, follow the steps given below

Select the part of the worksheet you wish to print

Go to the File tab and click on Print



In the Print Range drop-down menu, click on Print Selection

Then click on the Print button



Printing Excel Tables
To print tables in your worksheet, follow the steps provided below

Click on any cell within the table

Go to the File tab and click on Print



In the Print Range drop-down menu, click on Print Selected Table.

Then click on the Print button



Printing Charts Without Worksheet Data in Excel
You can choose to print the chart in your worksheet neglecting the data in it. To do this, follow the steps given
below

Select the chart you wish to print

Go to the File tab and click on Print



In the Print Range drop-down menu, click on Print Selected  Chart

Then click on the Print button



Printing Formula in Excel
Instead of getting the calculated results printed out n Excel, you can print out the formula. To do this,

Go to the Formula tab, and click on Show Formula in the Formula Auditing group

The formula used in the worksheet is displayed for printing

Printing Gridlines in Excel Worksheet
By default, when you print out the worksheet, the gridlines will not appear. However, you can print the gridlines in
your worksheet by following the steps provided below

Open the worksheet you wish to print
Go to the Page Layout tab and click on Print under the Gridlines check box in the Sheet Options
group.

Printing Out Comment in Excel
In case you may need to print out the comments in your Excel worksheet, these are what you need to do
Go to the Page Layout tab, go to the Page Setup group, and click on the dialog launcher.



In the Page Setup dialog box, go to the Sheet tab and then click on the arrow next to Comments. Then select how
you want the comments to be printed.

Setting the Print Area Before Printing
Setting the print area allows you to remove the part of the worksheet you do not need to print out. To do this, follow
the following procedure:

Select the part of the worksheet you wish to print
Go to the Page Layout tab and click on Print Area in the Page Setup group



In the Print Area drop-down menu, click on Set Print Area

To clear the print area, click on Clear Print Area

Inserting the Page Break Before Printing Excel Worksheet
The page break comes in handy when you wish to print a large volume of spreadsheets. The page break helps you
determine how the data in your worksheet are split over multiple pages.
To insert a page break in your worksheet, follow the steps provided below

Select the part of the worksheet you wish to print
Go to the Page Layout, and click on Breaks in the Page Setup group
In the Breaks drop-down menu, select Insert Page Break

Using the Preview Option Before Printing Your Worksheet
The Preview option gives you a display of how your Excel worksheet will look like before printing it out. To use
the preview option, follow the steps below:

Go to the File tab and click on Print
On the right-hand side of the Print Panel, the preview of the worksheet to be displayed



Scaling to Fit Before Printing Your Worksheet   
The Scale to Fit option allows you to scale and fit more data in your worksheet on a page before printing them out.
This comes in handy when your worksheet contains a lot of columns
To use this feature, here is what to do:

Go to the Page Layout tab and move to the Scale to Fit group
In the Scale to Fit group, select 1 page in the Width box and Automatic in the Height box

CHAPTER TEN
EXCEL SHORTCUTS

There are so many shortcuts in Excel, however, I will be introducing you to some shortcuts that are mostly used in
Excel

Editing Shortcut
Shortcut Keys Functions
F2 For editing cell
Ctrl + C For copying cell content
Ctrl + V For pasting cell content
Ctrl + X For cutting cell content to another cell
Ctrl + D To fill down
Ctrl + R To fill right
Alt+ E+ S Paste special



F3 For pasting the name into a formula
F4 Toggle reference
Alt +Enter For starting another new line within the same old

cell
Shift + F2 For inserting or edit a cell comment
Shift + F10 For displaying a shortcut menu
Ctrl + F3 For defining the name of a cell
Ctrl + Shift + A For inserting arguments names with parentheses for

a function after typing a function name in a formula
Alt + I + R For inserting a row
Alt + I + C For inserting a column

Navigation shortcuts
Shortcut Keys Functions
Arrow For moving from one cell to the next
F5 Go to
F6 For switching between the worksheet, the Ribbon,

the task pane, and the Zoom controls
Home To go to the beginning of a row
Ctrl + Home For moving to the beginning of a worksheet
Ctrl + End For moving to the last cell that has content in it in

the  worksheet
Shift + Arrow For selecting the adjacent cell
Shift + Spacebar For selecting an entire row
Ctrl + Spacebar For selecting an entire column
Ctrl + Shift + Home For selecting all to the start of the sheet
Ctrl+ Shift + End For selecting all to the last used cell of the sheet
Ctrl + Shift + Arrow To select the end of the last used row/column
Ctrl + Left Arrow For moving the word to the left while in a cell
Ctrl +  Right Arrow For moving the word to the right while in a cell
PageUp For moving the screen up
PageDown For moving the screen down
Alt + PageUp For moving the screen to the left
Alt+ PageDown For moving the screen to the right
Ctrl + PageUp/Down For moving the next or previous worksheet  
Ctrl + Tab To move to the next worksheet while on the

spreadsheet
Shift + Tab For moving cell to the right

Tab For moving to the next cell

File shortcuts
Shortcut Keys Functions
Ctrl + N New
Ctrl + O To open
Ctrl + S To save workbook
F12 Save As



Ctrl + P Print
Ctrl + F2 For opening the preview print window
Ctrl + Tab For moving to the next workbook
Ctrl + F4 For closing a file
Alt + F4 To close all open Excel files

Formula shortcuts
Shortcut Keys Shortcuts
Ctrl + Shift + Enter To enter an array formula
Ctrl + / For selecting array formula range
Ctrl + ‘ To copy a formula from cell and edit
Ctrl + [ For selecting all precedents cells
Ctrl + ] For selecting all dependent cells
F4 For changing the type of cell reference from relative

to absolute
Alt + = Sum range
F3 For displaying the range names

Paste special shortcuts
Shortcut Keys Functions
Ctrl + Alt + V+T Paste Special formats
Ctrl + Alt + V+V Paste Special values
Ctrl + Alt + V+F Paste Special formulas
Ctrl + Alt + V+ C Paste Special comments

Ribbon Navigation shortcuts
Shortcut Keys Functions
Alt To display Ribbon shortcut
Alt +F To go to the File tab
Alt + H To go to the Home tab
Alt + N To go to the Insert tab
Alt + P To go to the Page Layout tab
Alt + M To go to the Formulas tab
Alt + A To go to the Data tab
Alt + R To go to the Review tab
Alt + W To go to the View tab
Alt + Q To put the cursor in the Search box
Alt + JC To go to the Chart Design tab when the cursor is on

a chart
Alt + JA To go to the Format tab when the cursor is on a

chart
Alt + JT To go to the Table  tab when the cursor is on a table
Alt + JP To go to the Picture Format tab when the cursor is

on a picture



Alt + JI To go to the Draw tab
Alt + B To go to the Power Pivot tab

Clear shortcuts
Shortcut Keys Functions
Delete For clearing cell data
Alt+ h + e + f For clearing cell format
Alt+ h + e + m For clearing cell comments
Alt+ h + e + a For clearing all data formats and comments

Selection shortcuts
Shortcut Keys Functions
Shift + Arrow For selecting a cell range
Ctrl + Shift + Arrows For highlighting a contiguous range
Shift + Page Up For extending selection up one screen
Shift + Page Down For extending selection down one screen
Alt + Shift + Page Up For extending selection left one screen
Alt + Shift + Page Down For extending selection right one screen
Ctrl + A For selecting or highlighting all cells in the

worksheet
Ctrl + Space To select the whole column or row
Shift + Ctrl + Space Bar For selecting table
Alt + ; For selecting visible cells
Shift + Home For selecting a range from start cell to far left
Shift + End + Arrow For selecting a range from the start cell to the

direction of the arrow
Ctrl + * For selecting a continuous range of data
Ctrl + Shift + 0 For selecting all cells with comment
F5 + Alt +S +K + Enter For selecting all blank cells

Data editing shortcut
Shortcut Keys Functions
Ctrl + D To fill down from cell above
Ctrl + R To fill right from cell left
Ctrl + F To find and replace
F5 + Alt + s +o For showing all constants
F5 + Alt + s +c For highlighting the cell with comments

Data editing (inside a cell) shortcuts
Shortcut Keys Functions
F2 For editing the active cell
Enter To confirm a change in a cell before opting out of

that cell
Esc To cancel a cell entry before opting out of that cell



Alt + Enter To insert a line break within a cell
Shift + Left/Right For highlighting within a cell
Ctrl + Shift + Left/Right For highlighting contiguous items
Home To move to the beginning of the cell contents
End For moving to the end of a cell content
Backspace For deleting a character from left
Delete For deleting a character from the right
Tab For accepting autocomplete suggestion
Ctrl + Page Up/Down + Arrows For referencing a cell from another worksheet

Other shortcuts
Shortcut Keys Functions
Ctrl + Z To undo last action
Ctrl + Y To redo the last action
Ctrl + 9 To hide selected rows
Ctrl + 0 To hide selected rows
Ctrl + Shift + ( To unhide hidden rows in a selection
Ctrl + Shift + ) To unhide hidden columns in a selection
Ctrl + ; To enter date
Ctrl +: To enter time
Ctrl + ‘ To show formula
Ctrl + ] For selecting an active cell
Alt To drive menu bar
Alt + Tab To open the next program
Alt + = To autosum

CHAPTER ELEVEN
TIPS AND TRICKS

Here in this chapter, you will be learning some tips and tricks that will advance your skills in the use of Excel.
These tips and tricks will also save your time and energy to carry out certain tasks.
Below are some of the tips and tricks you will be needing in the course of working with Excel

Removing Duplicates Values from Your Worksheet
While working with large data, one of the problems to face is duplicate values. To remove duplicate values from
your worksheet, follow the steps given below

Select any of the cells in the worksheet.
Go to the Data tab and click on Remove Duplicates in the Data Tools group



In the Remove Duplicate dialog box, you can select or deselect the columns that contain duplicates.
Then click on Ok

Deleting Error Cells
It is normal to have error values when working with large data. However, it is not professional to still keep them on
the worksheet. To remove error cells in your worksheet, follow the steps below

Go to the Home tab, click on Find and Select command in the Editing group
In the Find and Select drop-down menu, click on Go To Special



In the Go To Special dialog box, click on Formula, and mark the Error check box.
Then click on OK. Here, all the errors in the worksheet are deleted, and then click on the Delete
button to delete them.

Changing Negative Values to Positive Values in Your Worksheet
To change a negative value to a positive value, use the ABS function as displayed in the image below



Disabling the Excel Start Screen
Maybe you are one of those people who don’t like seeing the Excel start screen each time you open the Excel
program; all you need to do is to disable it. To do this, follow the steps given below

Go to the File tab and navigate down to Options
In the Excel Options dialog box, go to General, and unmark Shows the Start screen when the
application starts under Start-up Options

How to Make Excel Show leading Zero?
By default, when a value begins with zero, Excel removes the zero automatically. To ensure that the zero that
begins your value is not deleted, enter a single quote mark before the zero



Changing the Screen Background of Your Excel Environment
To change the background screen of your Excel interface, follow the steps given

Go to the File tab and click on Account
Go to the Office Theme and choose any option in the drop-down list.

Locking a File with a Password
You can lock your file with a password to others from accessing your files. To password your file, follow the steps
given below

Go to the File tab and click on Info
In the Info window, click on Protect Document button, and choose Encrypt with Password on
the drop-down list.



In the Encrypt dialog box, input the password in the Password text box and then click on Ok.

Enter the password again in the Confirm Password dialog box.



Then click on Ok

Saving Excel File as a PDF
PDF, an acronym for Portable Document File is a file created to be displayed and printed in a Web browser and
Adobe Acrobat Reader.
To save an Excel file as a PDF, follow the steps given below

Go to the File tab and click on Export to open the Export window
Click on Create a PDF/XPS button

In the Publish as PDF or XPS dialog box appears, enter the name of the file and the location
where you want to save the file.
Then click on the Publish button



CONCLUSION
The use of Excel cannot be over emphazied especially in a world where the introduction of computer has led to
various changes in every sphere of influence especially in the area of business.
It is therefore pertinent that as an individual who is concerned about creating impact most importantly in the
workplace, should ensure he or she gets more acquinted to the use of Excel of which this guide will be of great help
to achieve this purpose.
Lest I forget, don’t forget to recommend this guide to everyone around you.
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