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Chapter 1 - Introduction 

About Navicat Data Modeler 

Navicat Data Modeler is a powerful and easy-to-use GUI tool for creating and manipulating database models. It 

enables users to design database structures, generate data dictionaries, reverse engineer, forward engineer, compare 

models, generate SQL/script files and print diagrams to files, etc. 

Navicat Data Modeler is available on three platforms - Microsoft Windows, macOS and Linux. Here are some highlights 

of Navicat Data Modeler: 

• Create and manipulate conceptual/logical/physical models. 

• Support various database systems: MySQL, MariaDB, Oracle, PostgreSQL, SQLite, SQL Server and 

MongoDB (including cloud databases like Amazon RDS, Amazon Redshift, Alibaba Cloud, Microsoft Azure). 

• Reverse engineer databases/schemas to a model. 

• Forward engineer a physical model to a SQL/Script file or a database/schema. 

• Compare two model workspaces. 

• Create and edit table structures directly. 

• Generate data dictionaries from models. 

• Support Navicat Cloud and Navicat On-Prem Server. 

For details, visit our website: https://www.navicat.com 

System Requirements 

Windows 

• Microsoft Windows 7, Windows 8, Windows 8.1, Windows 10, Windows 11, Server 2012, Server 2016, Server 

2019, Server 2022 

macOS 

• macOS 11 Big Sur, macOS 12 Monterey, macOS 13 Ventura, macOS 14 Sonoma, macOS 15 Sequoia 

Linux 

x86_64 

• Debian 10, Debian 11, Debian 12, Ubuntu 20.04, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora 

40, Linux Mint 20, Linux Mint 21, Deepin 20, KylinOS Desktop 10 

https://www.navicat.com/
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aarch64 

• Debian 11, Debian 12, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora 40, Linux Mint 20, Linux Mint 

21, KylinOS Desktop 10 

Supported Databases 

• MySQL 3.23 or above 

• PostgreSQL 7.3 or above 

• Oracle 8i or above 

• SQLite 3 

• SQL Server 2000 or above and SQL Azure 

• MariaDB 5.1 or above 

• MongoDB 2.6 or above 

• Redshift 1.0 

• GaussDB 3.2 and openGauss 

• OceanBase Community 3.1 or above and Enterprise 3.2 or above (Enterprise Oracle Mode is not available in 

macOS Edition) 

• TiDB 7 or later 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Installation for Download Version 

1. Download Navicat Data Modeler Windows version. 

2. Open the .exe file. 

3. Click Next at the Welcome Screen. 

4. Read the License Agreement. Accept it and click Next. 

5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder, 

click Browse. 

6. Follow the remaining steps. 

Installation for CD Version 
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1. Load the Navicat Data Modeler CD Installation disk into the CD-ROM drive. 

2. Open the .exe file. 

3. Click Next at the Welcome Screen. 

4. Read the License Agreement. Accept it and click Next. 

5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder, 

click Browse. 

6. Follow the remaining steps. 

Registration 

When the trial period is finished, Navicat Data Modeler requires a license key or a subscription plan to continue using 

the features. 

Note: Perpetual License and Subscription Plan cannot be used at the same Navicat Data Modeler. Before changing 

the registration method, you need to deactivate the license key or sign out your Navicat ID. 

Perpetual License 

If you have purchased a perpetual license, you will receive a license key for activating Navicat Data Modeler. 

In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat Data 

Modeler contacts our licensing server to activate the license key. If the activation process is successful, the license key 

details are displayed. 

Manual Activation 

Manual activation is available when your computer does not have an internet connection. You will need another 

computer with an internet connection to complete this activation process. 

1. If the online activation is failed, click Manual Activation. 

2. Copy the Request Code in the Copy the Request Code Here: box. 

3. Open web browser on a computer with an internet connection and then go to 

https://customer.navicat.com/manual_activate.php. 

4. Paste/Enter the Request Code into the left box. 

5. Click Get Activation Code. 

6. Copy the generated Activation Code in the right box. 

7. Go back to the computer where you are activating Navicat Data Modeler. 
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8. Paste the Activation Code into the Paste the Activation Code Here: box. 

9. Click Activate. 

Subscription Plan 

If you have subscribed a plan, you can sign in your Navicat ID to use Navicat Data Modeler during the subscription 

term. 

Note: Navicat ID is the Email address that you used to subscribe the plan. 

In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are 

displayed. 

Navicat Data Modeler contacts our licensing server once per hour to auto reload the plan by default. If you have 

updated your plan in the portal site, you can use the Reload Plan button to force reloading the new plan. 

Note: Each Navicat ID can connect to only one Navicat Data Modeler. If you sign in your Navicat ID in another Navicat 

Data Modeler, you will be signed out from the current Navicat Data Modeler. 

Migration / Upgrade 

Migrate Navicat Data Modeler to a new computer 

1. In Navicat Data Modeler, choose Help -> Registration. 

2. [Perpetual License] Click Deactivate to online deactivate the license key. 

3. [Subscription Plan] Click Sign Out to sign out your Navicat ID. 

4. Uninstall Navicat Data Modeler from the existing computer. 

5. Re-install Navicat Data Modeler in the new computer. 

Upgrade Navicat Data Modeler 

If you want to upgrade an installed copy of Navicat Data Modeler to the latest release, please choose Help -> Check 

For Updates to start the Updater. It will automatically check your installed version. If there is a new version, simply 

follow the steps in the Updater to upgrade your Navicat Data Modeler. It will replace your previous Navicat Data 

Modeler and your current settings will remain unchanged. 

Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement 

Note: For the License Agreement of Navicat Cloud service, please click here. 

https://customer.navicat.com/
https://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN. 

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a 

natural person and not a corporation, company, partnership or association or other entity or organization (ii) the 

individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit 

organization or charity organization only. For purposes of this definition, "educational institution" means a 

public or private school, college, university and other post secondary educational establishment. A non-profit 

organization is an organization whose primary objective is to support an issue or matter of private interest or 

public concern for non-commercial purposes. 

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and 

evaluate the Software, only. 

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any. 

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in each case, 

supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials, 

and online or electronic documentation. 

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE 

("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of 

fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial 

period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The 

UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation. 

f. "Navicat Data Modeler Lite" means a free-to-use version of the Software with limited features, identified as 

"Lite". 

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA: 

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the 

Software on a storage device, such as a network server, used only to install the Software on your other 

computers over an internal network, provided you have a license for each separate computer on which the 
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Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not 

be shared, installed or used concurrently on different computers. 

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on 

which the Software is installed may make a second copy of the Software and install it on either a portable 

computer or a computer located at his or her home for his or her exclusive use, provided that: 

A. the second copy of the Software on the portable or home computer (i) is not used at the same time as 

the copy of the Software on the primary computer and (ii) is used by the primary user solely as allowed 

for such version or edition (such as for educational use only), 

B. the second copy of the Software is not installed or used after the time such user is no longer the 

primary user of the primary computer on which the Software is installed. 

c. In the event the Software is distributed along with other PremiumSoft software products as part of a suite of 

products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the 

products in the Studio, including the Software, may be separated for installation or use on more than one 

computer. 

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You must 

reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the 

Software. You may not sell or transfer any copy of the Software made for backup purposes. 

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time, 

upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full 

compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses 

related to such audit in addition to any other liabilities you may incur as a result of such non-compliance. 

f. Your license rights under this EULA are non-exclusive. 

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically 

transfer the Software from one computer to another or over a network. 

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form. 

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software. 

d. Other than with respect to a Trial / Demo Version, Lite Version or a Not For Resale Version of the Software, 

you may permanently transfer all of your rights under this EULA only as part of a sale or transfer, provided you 

retain no copies, you transfer all of the Software (including all component parts, the media and printed 

materials, any upgrades, this EULA, the serial numbers, and, if applicable, all other software products provided 

together with the Software), and the recipient agrees to the terms of this EULA. If the Software is an upgrade, 

any transfer must include all prior versions of the Software from which you are upgrading. If the copy of the 
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Software is licensed as part of the whole Studio (as defined above), the Software shall be transferred only with 

and as part of the sale or transfer of the whole Studio, and not separately. You may retain no copies of the 

Software. You may not sell or transfer any Trial / Demo Version, Lite Version or Not For Resale Version of the 

Software. 

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the 

Software. 

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial 

purpose. 

g. Unless otherwise provided herein, you shall not 

A. in the aggregate, install or use more than one copy of the Trial / Demo Version of the Software, 

B. download the Trial / Demo Version of the Software under more than one username, 

C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of 

the Software for an aggregate period in excess of the trial period for one license to such Trial / Demo 

Version, 

D. disclose the results of software performance benchmarks obtained using the Trial / Demo Version or 

Lite Version to any third party without PremiumSoft prior written consent, or 

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining 

whether to purchase a license to a commercial or education version of the software; provided, however, 

notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo 

Version or Lite Version of the Software for any commercial training purpose. 

h. For Navicat Data Modeler Lite: For avoidance of doubt, Navicat Data Modeler Lite is licensed, not sold. Under 

this EULA, PremiumSoft grants you the right to 1) download [one copy] of the software, and 2) install and run 

[one instance] of the software on your [one device], whether physical or virtual with an internal storage device 

capable of running the software, so long as you comply with all the terms of this EULA. 

If you were in possession of multiple software versions, you may only install and run [one] of those versions at 

a time. If you use the software on more than one physical or virtual device, you must obtain a separate license 

for each instance. 

[Commercial Use] 

The number of users at any time within a business, whether incorporated or not, shall not exceed [five persons]. 

To use the software on more than one device, you are required to obtain a dedicated license and you may 

allow up to [five other devices] to access the software installed on the licensed device for commercial use. 

[Non-Commercial Use] 

Users qualified for PremiumSoft's Non-Commercial Licensing Program, subject to the conditions of the 

program as detailed in Navicat Non-Commercial Licensing Program 

(www.navicat.com/en/store/non-commercial), are granted the right to download, install, run, and use the 

software. 

https://www.navicat.com/en/store/non-commercial
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i. You may only use the Not for Resale Version of the Software to review and evaluate the Software. 

j. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for the 

server or computer on which the Software is to be installed. 

k. You may receive the Software in more than one platform but you shall only install or use one platform. 

l. You shall not use the Software to develop any application having the same primary function as the Software. 

m. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must 

destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA 

surviving any such termination). 

n. This program may include Oracle Instant Client (OCI). You agree that you shall 

a. not use of the Oracle Instant Client to the business operations; 

b. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual or 

entity; 

a. make the Programs available in any manner to any third party for use in the third party's 

business operations; and 

b. title to the Programs from passing to the end user or any other party; 

c. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and one copy 

of each Program media; 

d. discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after 

termination of the Agreement; 

e. not publish any results of benchmark tests run on the Programs; 

f. comply fully with all relevant export laws and regulations of the United States and other applicable 

export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof, 

are exported, directly or indirectly, in violation of applicable laws; 

g. allow PremiumSoft to audit your use of the Oracle Instant Client; 

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or 

entity unless such transfer is pursuant to Section 3. 
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5. Ownership 

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title 

and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and 

as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not 

specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its 

suppliers. 

6. LIMITED WARRANTY AND DISCLAIMER 

a. Except with respect to Trial / Demo Version, Lite Version and Not For Resale Version of the Software, 

PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by a copy of 

your receipt): the physical media on which the Software is furnished will be free from defects in materials and 

workmanship under normal use. The Software is provided "as is". PremiumSoft makes no warranties, express 

or implied, arising from course of dealing or usage of trade, or statutory, as to any matter whatsoever. 

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, Lite 

version and the Not for Resale version of the Software. Trial / Demo version, Lite version and the Not for 

Resale version of the Software are provided "as is". 

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version, 

Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other warranties and 

representations, whether express, implied, or otherwise, including the warranties of merchantability or fitness 

for a particular purpose. Also, there is no warranty of non-infringement and title or quiet enjoyment. 

PremiumSoft does not warrant that the Software is error-free or will operate without interruption. The Software 

is not designed, intended or licensed for use in hazardous environments requiring fail-safe controls, including 

without limitation, the design, construction, maintenance or operation of nuclear facilities, aircraft navigation or 

communication systems, air traffic control, and life support or weapons systems. PremiumSoft specifically 

disclaims any express or implied warranty of fitness for such purposes. 

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration 

to thirty (30) days from the date of delivery. 

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees 

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN. 

7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access 

data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the 

Software and based on any theory of liability including breach of contract, breach of warranty, tort (including 

negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised of the 

possibility of such damages. 

8. Third Party Software 
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The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software. 

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA. 

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any 

varying or additional terms contained in any purchase order or other written notification or document issued by you in 

relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of 

its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the 

breach. 

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will 

be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and 

Effect. 

10. Basis of Bargain 

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the 

agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic 

basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of 

PremiumSoft's licensors. 

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License. 

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory, 

as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a particular purpose or 

non-infringement of third party rights are expressly excluded. 

12. License Termination 

Without prejudice to any other rights, PremiumSoft may terminate this EULA if you fail to comply with the terms and 

conditions of this EULA. In such event, you must destroy all copies of the software and all of its component parts. 

13. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction 

and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 
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Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you 

desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft 

CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and 

logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any 

trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the 

Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective 

trademarks. 
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Chapter 2 - User Interface 

Main Window 

 

 Navigation Pane 

The Navigation pane allows you to create new models, open local model files, recently opened model files, or model files 

in Navicat Cloud / On-Prem Server. If the Navigation pane is hidden, choose View -> Show Navigation Pane from the 

menu bar. 

 Content Pane 

The Content pane contains the models that are in the selected section of the Navigation pane. Use the  Detail or  

Icon buttons to change the view. 

 Information Pane 

The  General tab shows the general information of the model or the selected item. 

The  Project tab shows the project members and the project activities done by the members. Click + to add 

members to the project. 

If the Information pane is hidden, choose View -> Show Information Pane from the menu bar. 
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Chapter 3 - Collaboration 

About Collaboration 

Navicat Data Modeler allows you to synchronize connection settings, model workspaces and virtual group information 

from Navicat Data Modeler, other Navicat family members, different machines and different platforms. You can use 

Navicat Cloud to host the files. Or, if you have installed our another product, Navicat On-Prem Server, in your 

environment, you can hosts everything in-house. 

Our collaboration feature allows you to give your teammates access to your projects when they log into their accounts. 

That way, you and your teammates can work on the same project without revealing your username and password. You 

can even choose to restrict the type of access your teammates have to your project. 

Manage Cloud 

Navicat Cloud 

Navicat Cloud is a cloud service provided by PremiumSoft for synchronizing connection settings, queries, aggregation 

pipelines, snippets, model workspaces, BI workspaces and virtual group information. 

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection 

settings, queries, aggregation pipelines, snippets, model workspaces, BI workspaces and virtual group information; your 

database passwords and data (e.g. tables, views, etc) will not be stored to Navicat Cloud. 

Note: You can only sign in to one Navicat Cloud account in the software. PremiumSoft will keep all synchronized files 

strictly confidential, and all employees are prohibited from viewing/accessing content of files you may store in your 

Navicat Cloud account. 

Create Navicat Cloud Account 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Create Navicat ID. 

4. Enter the required information and click Sign Up. A verification email will send to your email address. 

5. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign In Navicat Cloud 

1. In the menu bar, choose File -> Manage Cloud. 
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2. In the Manage Cloud window, select Navicat Cloud. 

3. Enter your Navicat ID and Password. 

4. Click Sign In. 

5. If you enabled two-step verification in Navicat Cloud Portal, a code will be sent to your phone via your mobile 

app. Enter the received code to sign in. 

Sign Out Navicat Cloud 

1. Close all models in Navicat Cloud. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select Navicat Cloud. 

4. Click Sign Out. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Your usage and current plan will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, upgrade Cloud Plan, etc in Navicat Cloud Portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Manage Account. 

4. A web browser will automatically open up to Navicat Cloud Portal. 

https://cloud.navicat.com/
https://cloud.navicat.com/
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On-Prem Server 

Navicat On-Prem Server is an on-premise solution that provides you with the option to host a cloud environment for 

storing Navicat objects (connection settings, queries, aggregation pipelines, snippets, model workspaces, BI 

workspaces and virtual group information) internally at your location. 

Before you can add an On-Prem Server, you must first set up Navicat On-Prem Server in your environment. 

Note: You can add multiple On-Prem Server in the software. 

Add New On-Prem Server 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server. 

3. Enter your On-Prem Server login information. 

Option Description 

Host The host name or IP address of your On-Prem Server. 

Port The port number of your On-Prem Server. 

Verify Server Certificate Enable this option to verify the server certificates. 

Enable Push 

Synchronization 

Navicat Data Modeler receives a silent push notification whenever its 

files stored in your On-Prem Server changes. 

4. Click OK. 

Add New On-Prem Server with URI 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server with URI. 

3. Paste your On-Prem Server URI. 

4. Click OK. 

Note: The URI can be copied from your On-Prem Server portal site. 

Sign In On-Prem Server 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Enter your Username and Password. 

4. Click Sign In. 
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5. If you enabled two-step verification, a code will be sent to you via the verification method you have selected. 

Enter the received code to sign in. 

Sign Out On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

Edit On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Edit On-Prem Server. 

6. Edit the On-Prem Server information. 

7. Sign in your server. 

Edit On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Edit On-Prem Server. 

6. Edit the On-Prem Server information. 

7. Sign in your server. 

Remove On-Prem Server 

1. Close all models in your On-Prem Server. 

2. At the top right, click your avatar. 



 20 

 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Remove On-Prem Server. 

6. Click Delete. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Your usage will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, etc in your On-Prem Server web portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click Manage Account. 

4. A web browser will automatically open up to your On-Prem Server web portal. 

Push Synchronization 

Push Synchronization enables Navicat Data Modeler to receive a silent push notification whenever the files stored in 

Navicat Cloud or On-Prem Server changes. 

Enable Push Synchronization 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server. 

3. Turn on Enable Push Synchronization. 
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Disable Push Synchronization 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server. 

3. Turn off Enable Push Synchronization. 

Cache and Local Copies 

When you logged into Navicat Cloud or your On-Prem Server, Navicat Data Modeler saves the cloud object files and 

some information in the local computer. The cache and local copies use to make sure your changes are saved in the 

cloud. 

Clear Cache and Local Copies 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud or your On-Prem Server. 

3. Click Sign Out. 

4. Right-click Navicat Cloud or your On-Prem Server and select Clear Cache and Local Copies. 

5. Click Clear. 

Open Containing Folder 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Open your project. 

3. Right-click anywhere in the project and select Open Containing Folder. 

Projects 

Work With Projects 

A project is a way to structure and organize Navicat objects. You can put related objects in one project, and then share 

the project with other accounts for collaboration if necessary. 

Create New Projects 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Click + New Project. 

3. Enter the name of the new project. 

4. Click OK. 
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Manage Existing Projects 

To rename a project 

1. In the main window, right-click the project and select Rename. 

2. Enter a new project name. 

Note: Only the project owner and the members with the Can Manage & Edit right can rename the project. 

To delete a project 

1. In the main window, right-click the project and select Delete Project. 

2. Click Delete. 

Note: Only the project owner can delete the project. 

Note: Before you delete the project, you must remove all objects in the project. 

To quit a project 

1. In the main window, right-click the project and select Quit Project. 

2. Click Quit. 

Manage Members 

Add Members 

1. In the main window, right-click the project and select Manage Members. 

2. Click Add Members. 

3. [Navicat Cloud] Enter the member's Navicat ID and press ENTER. 

4. [On-Prem Server] Check the boxes of the users that you want to add. 

5. Select the member right. 

6. Click Add. 

Member Rights Privileges 

Can Manage & Edit Read Objects, Write Objects, Manage Members and Rename 

Projects 

Can Edit Read Objects and Write Objects 

Can View Read Objects 

Manage Existing Members 
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To edit the right of a member 

1. In the main window, right-click the project and select Manage Members. 

2. Use the drop-down list next to the member to change the right. 

3. Click Apply. 

To remove a member from a project 

1. In the main window, right-click the project and select Manage Members. 

2. Click the X icon next to the member. 

3. Click Apply. 
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Chapter 4 - Workspace 

About Workspace 

A workspace is the place that comprises models, diagrams and data dictionaries. You can create multiple models, 

diagrams and data dictionaries in a workspace. 

 

 Workspace Toolbar 

The Workspace Toolbar provides controls that you can use to create models, diagrams and data dictionaries. 

 Tab Bar 

The Tab Bar allows you to switch among the opened items. 

 Content Pane 

The Content pane shows all items in the workspace. To change the view, click the  Detail or  Icon button at the 

bottom of the window. 

Detail View displays additional information about each item. You can sort items in Detail View, click the column header 

by which you want to sort the items. 

Icon View displays your items as a grid of thumbnail images. You can filter the items by clicking a category (All, Model, 

Diagram, Data Dictionary) in this view. 

 Properties Pane 

The  General tab shows the general information of the workspace or the selected item. 
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If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Create Workspace 

Local Workspace File 

The essential steps to create a workspace are: 

1. In the main window, click  New Workspace. 

2. Create models, diagrams and data dictionaries. 

3. Choose File -> Save. 

4. Enter the file name and choose the save path. 

5. Click Save. 

Cloud Workspace File 

If you have logged into Navicat Cloud / On-Prem Server, you can store the workspace in a project. 

The essential steps to create a workspace are: 

1. In the main window, click New Workspace. 

2. Create models, diagrams and data dictionaries. 

3. Choose File -> Save. 

4. Enter the workspace name and choose the project. 

5. Click Save. 
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Chapter 5 - Model 

About Model 

A model is a collection of database objects that can be effectively utilized within diagrams. These objects can be 

reused across various diagrams, thereby increasing efficiency and consistency in the design and presentation of 

database structures. 

 

 Model Pane 

The Model pane is the basic way to navigate with databases/schemas, tables, views, functions or entities. 

 Object Toolbar 

The Object Toolbar provides controls that you can use to manipulate the object. 

 Object Pane 

The Object pane shows the objects you created in the model. 

 Properties Pane 

The  General tab shows the general information of the selected object. 

The  DDL tab shows the DDL of the selected object. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Create Model 

The essential steps to create a model are: 
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1. In the Workspace window, click  New Model. 

2. Enter the name of the model and select a model type, target database, and database version. 

3. Click OK. 

4. A tab will open for you to edit the model. 

Add Database / Schema 

When creating a new model, a database (named default) is automatically created and it is the default database. 

You can view all databases/schemas with their objects as tree structure on the Model pane. 

To create a new database 

1. On the Model pane, right-click the model name or database and select New Database. 

2. Enter the name of the database. 

3. Click OK. 

To create a new schema 

1. On the Model pane, right-click the database or schema and select New Schema. 

2. Enter the name of the schema. 

3. Click OK. 

Create Table 

The essential steps to create a table are: 

1. On the Model tab, select Tables in the Model pane. 

2. Click  New Table, or click the down arrow and choose the table type. 

3. Enter the name of the table. 

4. Click OK. 

5. A tab will open for you to edit the table. 

Create RDBMS View 

Create View 

The essential steps to create a view are: 
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1. On the Model tab, select Views in the Model pane. 

2. Click  New View. 

3. Enter the name of the view. 

4. Click OK. 

5. A tab will open for you to edit the view. 

View Editor 

In Definition tab, you can create and edit the SELECT statement SQL for a view. Navicat Data Modeler provides a 

wide range advanced features for editing the view definition, such as compelling code editing capabilities, smart 

code-completion, sql formatting, and more. 

Hint: SELECT statement will be automatically generated while you build in View Builder. 

Beautify SQL 

To format messy SQL code into a well-structured script, you can click the  Beautify SQL button. 

Code Completion 

Code completion feature in Navicat Data Modeler pops up a list of suggestions as you type your SQL statement in the 

editor. It assists you with statement completion and the available properties of database objects, for example 

databases, tables, fields, views etc with their appropriate icons and information. 

To invoke code completion, just simply press '.' for the available properties of database object currently in the scope. 

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 

 

In addition, code completion can be invoked by typing a character or pressing ESC on your keyboard for SQL 

keywords/database objects. 

If you select a snippet name from the list, the saved code will be inserted to the editor. 

Hint: Resize the suggestion list by dragging the lower right corner. 



 29 

 

You can enable or disable the code completion feature in Options. 

Clipboard Stack 

When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack. 

Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you 

can press CTRL+SHIFT+V. Press CTRL+SHIFT+V multiple times to cycle through Clipboard Stack. 

Code Folding 

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in the 

editor. 

A block of code that can be folded is indicated by an icon  to the left of the first line of the block. A vertical line 

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon  

to left of the code block. You can fold the block by clicking  or expand it by clicking . 

 

Syntax Highlight 

Navicat Data Modeler uses syntax highlighting which depending on the database associated with the query. Different 

databases have different sets of reserved keywords. You can configure the associated colors for different text 

fragments in Options. 

Brace Highlight 

Navicat Data Modeler supports to highlight the matching brace in the editor, i.e. () . 

Note: The cursor must be on a brace to show the highlight. 

 

Find and Replace 
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Find 

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or 

press CTRL+F, and then enter a search string. 

The search starts at the cursor's current position to the end of the file. 

To find the next occurrence, just simply click Next or press F3. 

Replace 

To open the Replace bar, simply check the Replace box. Then, enter the text you want to search and replace. 

Click the Replace button to replace the first occurrence. 

Click the Replace All button to replace all occurrences automatically. 

There are some additional options for Find and Replace, click : 

Option Description 

Highlight All Highlight all matches in the editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Match Case Enable case sensitive search. 

Regular Expression Search regular expressions. 

Whole Word Return the objects that match the entire word of the search string. 

Zoom In/Zoom Out 

Navicat Data Modeler has the ability to zoom in or zoom out the SQL in the editor. 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 

Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

Reset: [CTRL+0] 

View Builder (Available only in Enterprise Edition) 

Navicat Data Modeler provides a useful tool called View Builder for building views visually. It allows you to create and 

edit views without knowledge of SQL. Even if you are familiar with SQL, the convenient and fluent graphical interface 

makes it easier to create relations and visualize the view. 

In View Designer, click the  View Builder button to open the visual View Builder. 

All database objects are displayed on the left Object pane. Whereas on the middle pane, it is divided into two portions: 

the upper Diagram pane, and the lower Criteria pane. When building the view, you can view the auto-generated SQL 

on the right SQL pane. 
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Add Objects to View 

The first step is to decide which tables and views you need to add to the view. 

To add tables and views to the view, use one of the following methods: 

• Drag them from the Object pane to the Diagram pane. 

• Double-click them on the Object pane. 

You can set aliases for tables, views and subqueries by double-clicking the object title on the Diagram pane and 

entering the name to use as an alias for the object name. 

After you have added objects to the diagram, you can use the FROM tab to adjust the view to your needs. 

• To change the object, click the object and select an identifier. 

• To add the table alias, click <Alias>. 

 

You can right-click an object on the Diagram pane and select Remove, or simply press DELETE key to remove the 

selected object from the view. 
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When you remove an object, View Builder automatically removes joins that involve that object. 

Choose Output Fields 

To include fields in the view, use one of the following methods: 

• Check the left checkbox of a field name you want to add to the view on the Diagram pane. 

• To include all the fields for an object, check the * checkbox on the Diagram pane. 

• To add all fields for all objects, click  on the SELECT tab and select All fields(*). 

The selected fields display on the SELECT tab. You can specify additional output field options. 

• Check the DISTINCT checkbox to force the view to return distinct results. 

• To add the field alias, click <Alias> and enter the name. 

• Click the identifier and select the Aggregate function. 

• Use the up arrow and down arrow buttons to change the order of fields. 

Set Field Association 

View Builder will automatically join the tables as per the foreign key relations. If you want to associate database objects 

manually, just select a field from an object and drag it to a field in another object. A connector line appears between the 

two objects to visually represent the relationship and the join type. 

There are two views to show the connector lines: Table Relation and Field Relation. The Field Relation view allows 

you to identify matching fields in two tables, while the Table Relation view displays the join relationship between the 

two tables. 

All joins are initially created as INNER JOIN by default. To change the association, click or double-click the connector 

line on the Diagram pane or click the JOIN keyword on the FROM tab, and then select a join type. If a join type is not 

listed, you can enter a customized one in the Custom textbox. 



 33 
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To remove a join, right-click the connector line and select Remove. 

To modify the join condition, right-click a connector line and select Edit Join, or click the condition on the FROM tab. 

 

The pop-up menu options of the FROM tab: 

Option Description 

Insert Add an identifier, an expression or a subquery. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the identifier, expression or subquery. 

Clear and Convert to 

USING Clause 

Remove the ON condition and convert it to USING clause. 

Clear and Convert to ON 

Clause 

Remove the USING condition and convert it to ON clause. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Set Filter Criteria 

When retrieving data, you may want to set up a filtering expression. To filter data returned by the view, right-click a field 

on the Diagram pane and select Add Field To -> WHERE and an operator. 
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The condition is added to the WHERE tab. You can edit the value there by clicking <Value>. If you want to add a 

condition with parentheses, click . You can change a logical operator (and/or) by clicking it. Use the up arrow and 

down arrow buttons to change the order of conditions. 

 

The pop-up menu options of the WHERE tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Group Resulting Data 

You can set the conditions for grouping records by right-clicking a field in the Diagram pane and selecting Add Field To 

-> GROUP BY. 

The condition is added to the GROUP BY tab. Use the up arrow and down arrow buttons to change the order of fields. 

On the HAVING tab, you can filter summarized data or grouped data. Select the identifiers, operators, aggregate or 

enter expressions to include in the condition. Use the up arrow and down arrow buttons to change the order of 

conditions. 

The pop-up menu options of the HAVING tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 



 35 

 

Sort Resulting Data 

You can set the way of sorting records by right-clicking a field on the Diagram pane and selecting Add Field To -> 

ORDER BY -> ASC or DESC. The condition will be added to the ORDER BY tab. 

Limit Resulting Data 

On the LIMIT tab, you can limit your view results to those that fall within a specified range. 

Offset 

Specify the number of records to be skipped. It is optional. 

Limit 

Specify the number of records to be displayed. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Add Expressions/Subqueries 

You can add an expression or a subquery to further limit the view results. On the FROM tab, click  and select the 

Expression/Subquery tab. 

After entered an expression or a subquery, confirm editing by pressing the ENTER key. It will be added to the Diagram 

pane indicates that the statement contains an expression or a subquery and identifies the columns it is on. 

 

By clicking the  button, you will be switched to a subquery layer where you can build it visually in the same way as 

the main query. 

You can always go back to the main query by clicking (Main Query). 

View Generated SQL 

The SQL pane presents a read-only, formatted representation of the SQL generated by View Builder. You can copy the 

SQL that appears in the SQL pane for use in other tools. In a subquery layer, you can enable Show Current Layer 

Only to show the subquery SQL. 

Zoom In/Zoom Out 
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Navicat Data Modeler has the ability to zoom in or zoom out the diagram. Right-click anywhere on the Diagram pane 

and select Zoom -> Zoom In/Zoom Out/100%. The same effect can be achieved with keyboard shortcuts. 

Zoom In: [CTRL+=] 

Zoom Out: [CTRL+-] 

Reset: [CTRL+0] 

Code Snippets 

Code Snippets provide an easy way for you to insert reusable code into editor when writing statements or scripts. The 

Code Snippet pane is on the right side of the editor. 

The library includes built-in and user-defined snippets. Choose a label from the drop-down list or enter a search string 

in the Search box to filter the list. If you want to show the available snippets according to your database type, you can 

right-click anywhere on the library and disable Show Snippets For Other Database Type. 

 

Built-in snippets are non-editable. A user-defined snippet can be edited by double-clicking it in the library. If you want to 

hide the built-in snippets, you can right-click anywhere on the library and disable Show Preset Snippets. 

Use Code Snippets 

There are two ways to insert a snippet into the editor. 

• You can start typing the name of a snippet in the editor. Smart code completion will pop up a list of suggestions 

for the word completion automatically. Select a snippet name from the list, the saved code will be inserted to 

the editor. 
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• You can simply drag and drop a snippet from the library into the editor. 

After inserting the snippet with placeholders to the editor, you can easily navigate to them by clicking on one of the 

placeholders, and then using the TAB key and entering the information. 

 

Create Code Snippets 

You can create your own code snippets and add them to the library. To create a code snippet, select your desired code 

in the editor, then right-click and select Create Snippet. 

Alternatively, click  in the Code Snippet pane. If you use this method, you must manually enter the code in the New 

Snippet window; code selected in the editor is not automatically added to the Code box. 

Hint: Code snippets (.nsnippet) are stored in the snippets folder under the Profiles Location. 

Option / Button Description 

Untitled text box Enter the name of the snippet that displays in the library and the code 

completion list. 

Database Type Choose the database server type of the snippet. 

Label Choose an existing label or enter a new label name for the snippet. 

Remarks Enter a description for the snippet that displays in the library. 

Code Enter the code. 
 

Add a placeholder by highlighting any words in the code and click this button. 

The placeholder will be highlighted in light green. 
 

Remove a placeholder by highlighting it in the code and click this button. 

Move / Copy Snippet To Project 

If you have logged in to Navicat Cloud or On-Prem Server, you can synchronize the custom snippet in My Connections 

to a project. 

1. Right-click a snippet and select Move Snippet To or Copy Snippet To. 

2. Select an existing project. 
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3. The snippet will be moved or copied to the project. 

Hint: You can move / copy a snippet in a project to My Connections in a similar way. 

Create Function / Procedure 

The essential steps to create a function/procedure are: 

1. On the Model tab, select Functions in the Model pane. 

2. Click  New Function. 

3. Function Wizard will pop up and it allows you to create a function/procedure easily. 

4. Click Finish. 

5. A tab will open for you to edit the function/procedure. 

Create Collection 

The essential steps to create a collection are: 

1. On the Model tab, select Collections in the Model pane. 

2. Click  New Collection, or click the down arrow and choose the collection type. 

3. Enter the name of the collection. 

4. Click OK. 

5. A tab will open for you to edit the collection. 

Add Embedded Document 

1. Click  Add Field. 

2. Enter the name of the field and select object data type. 

3. Click the arrow icon left to the field name. 

4. Click  Add Field and define the item. 

Add Embedded Array of Documents 

1. Click  Add Field. 

2. Enter the name of the field and select object data type. 

3. Enable Is Array. 
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4. Click the arrow icon left to the field name. 

5. Click  Add Field and define the item. 

Add Predefined Object 

1. Click  Add Field. 

2. Enter the name of the field and select (Predefined Object) data type. 

3. Choose the predefined object. 

Create Predefined Object 

A predefined object refers to a specific document structure that is predefined or preconfigured. It is a predetermined 

schema or template that defines the fields and their data types within a MongoDB document. You can use predefined 

objects in any collection in the model to help maintain data integrity and establish consistent document structures. 

The essential steps to create a predefined object are: 

1. On the Model tab, select Predefined Object in the Model pane. 

2. Click  New Predefined Object. 

3. Enter the name of the predefined object. 

4. Click OK. 

5. A tab will open for you to edit the predefined object. 

Create MongoDB View 

Create View 

The essential steps to create a view are: 

1. On the Model tab, select Views in the Model pane. 

2. Click  New View. 

3. Enter the name of the view. 

4. Click OK. 

5. A tab will open for you to edit the view. 
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Pipeline Builder 

Pipeline Builder allows you to build a simple aggregation pipeline by defining stage operators. It consists of the 

following sections: Pipeline, Stage Editor. 

 

 Pipeline 

A diagram to illustrate the aggregation pipeline. You can see all stages at a glance and add, delete, and move them as 

needed. 

 Stage Editor 

The Stage Editor is where you edit the selected stage. 

Choose Source Collection 

The source input of the pipeline is a single collection or view. Select Source in the pipeline and choose the Source 

Collection. 

Work with Aggregation Pipeline Stage 

You can break down a complex view into easier stages. In each stage, you complete a different operation on the data, 

such as filtering, grouping, sorting, and transforming. There is no limit to the number of stages used in the view, or how 

you combine them. 

Add Stage 

1. Hover over an arrow. 

2. Click the  icon. 

Move Stage 

1. Hover over a stage. 
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2. Click and hold the  icon. 

3. Move it to the desired location. 

Enable / Disable Stage 

1. Hover over a stage. 

2. Turn on or off the stage. 

Delete Stage 

1. Right-click a stage and select Delete. 

Modify Pipeline Settings 

You can click Option to view and change pipeline settings. 

Create Entity 

The essential steps to create an entity are: 

1. On the Model tab, select Entities in the Model pane. 

2. Click  New Entity. 

3. Enter the name of the entity. 

4. Click OK. 

5. A tab will open for you to edit the entity if your model is a logical model. 
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Chapter 6 - Diagram 

About Diagram 

A diagram is a visual representation of the relationships and structure of a data model. It depicts the tables, fields, 

collections, entities, attributes, and relationships between them in a clear and concise manner. You can use it in 

database design and development processes to communicate and document the logical organization of data within 

your system. 

 

 Object Pane 

The Object pane displays a list of all objects used in the diagram. 

 Toolbar 

The Toolbar is located near the top of the diagram. The buttons display in the toolbar depend on the model type 

(physical, logical and conceptual) and server type. You can use the toolbar to perform some basic tasks, such as 

adding tables, views, functions, collections or entities, applying Auto Layout feature, etc. 

 Canvas 

You can design your diagram on the Diagram Canvas. All added objects can be moved (by dragging them with mouse 

or by keyboard), resized, aligned to the grid, etc. 

 Properties Pane 

The  Properties tab includes the basic layout settings, object settings and so on. The properties vary with the type 

of the object selected. 

The  DDL tab shows the DDL of the selected object. 

 Overview Pane 
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The Overview pane displays the whole active diagram in the canvas. To zoom in or zoom out the selected area of the 

diagram, adjust the slider. Same effect can be achieved with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 

Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

Create Diagram 

The essential steps to create a diagram are: 

1. In the Workspace window, click  New Diagram. 

2. Enter the name of the diagram. 

3. Click OK. 

4. A tab will open for you to edit the diagram. 

Properties 

Once you have selected the diagram canvas, you can customize the diagram by changing its properties: 

Option Description 

Diagram 

Default Model Choose the default model of the diagram. All objects created in the diagram 

belong to the default model. 

Diagram Notation Choose the notation of the diagram. 

Database Object Font Set the font style of the database objects. 

Black and white Change the diagram color to black and white. 

Show database object 

comments 

Show object comments in the diagram. 

Show table field 

comments 

Show field comments in the diagram. 

Show collection subfields Show subfields in MongoDB collections. 

Show database names Show the database names of objects in the diagram. 

Paper Size Set the paper size of the canvas. 

Pages Set the Width and Height (pages) of the canvas. 

 

Add Model Objects 

If you have already created a model, you can add existing objects in the model to the diagram. 

The essential steps to add a model object are: 

1. In the Diagram tab, click  Existing Model Objects. 
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2. Choose a model. 

3. Double-click the object you want to insert into the diagram, or use the drag-and-drop method. 

Add Tables 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 
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Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Collections 

To add a new collection 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the collection to open the designer. 

Hint: The new collection will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the collection object in the canvas include: 

Option Description 

Design Collection Edit the collection structure in a collection designer, e.g. fields, indexes, 
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relations, etc. 

Add Related Objects Add all related objects to the selected collection. 

Add Field Add a field at the end of the collection. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the collection from the diagram and put it on the clipboard. 

Copy Copy the collection from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the collection as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the collection. 

Select All Collections Select all collections in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the collection from the diagram or from both diagram and model. 

Rename Change the name of the collection. 

Color Change the color of the collection. 

Size to Fit Resize the collection automatically to fit its contents. 

Bring to Front Bring the collection to the foreground. 

Send to Back Move the collection to the background. 

Group / Ungroup Group or ungroup the collection and other objects in the diagram. 

Lock / Unlock Lock or unlock the collection in the diagram. 

Properties 

Once you have selected the collection, you can customize the collection by changing its properties: 

Option Description 

Collection 

Collection Name Enter the name of the collection. 

Database Name Enter the name of the database to which the collection belongs. 

Model Name Show the name of the model to which the collection belongs. 

Position Customize the position of the collection. 

Size Customize the size of the collection. 

Style Choose the style the collection. 

Auto - Auto-arrange the collection into a compact or standard style when 

resizing. 

Standard - Show the collection name and its fields. 

Compact - Show a collection icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 
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Color Set the color of the collection. 

Bold Make the collection border bold. 

Group / Ungroup Group or ungroup the collection and other objects in the diagram. 

Lock / Unlock Lock or unlock the collection in the diagram. 

 

Add Foreign Keys 

To add a foreign key 

1. Click the  button from the toolbar. 

2. Drag and drop the field of the child table/collection to the field of the parent table/collection. 

OR 

Drag and drop the child field to the empty space of the parent table/collection. The referenced field will be 

automatically created in the parent table/collection. 

3. Double-click the foreign key connector to open the designer. 

Hint: When you hover over a foreign key line, the referenced fields and the referencing fields are highlighted. 

The pop-up menu options of the foreign key in the canvas include: 

Option Description 

Design Foreign Key Edit the foreign key in a table designer. The options in the designer depend 

on the diagram database type you are chosen. 

Go to Go to and select the connected table/collection. 

Reroute Connectors Reroute the connector to the closest points between two connected objects. 

Copy Copy the foreign key from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the foreign key as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected by the foreign key. 

Select All Relations Select all foreign keys in the diagram. 

Delete from Diagram and 

Model 

Delete a foreign key from both diagram and model. 

Color Change the color of the foreign key. 

Group / Ungroup Group or ungroup the foreign key and other objects in the diagram. 

Lock / Unlock Lock or unlock the foreign key in the diagram. 

Properties 

Once you have selected the foreign key, you can customize the foreign key by changing its properties: 

Option Description 

Foreign Key 
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Name Enter the name of the foreign key. 

Position Customize the position of the line. 

Offset Customize offset values for the start and end of the line. 

Show name Display the name of the foreign key. 

Font Set the font style of the name. 

Bold Apply a bold style to the name. 

Italic Apply an italic style to the name. 

Color Set the color of the line. 

Line Width Choose the thickness of the line. 

Cardinality Specify the relationship cardinality of the table/collection. 

Visible Show the connector. 

Group / Ungroup Group or ungroup the foreign key and other objects in the diagram. 

Lock / Unlock Lock or unlock the foreign key in the diagram. 

 

Add Views 

To add a new view 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the view to open the designer. See RDBMS View or MongoDB View 

Hint: The new view will also add to the default model. 

The pop-up menu options of the view object in the canvas include: 

Option Description 

Design View Edit the view structure in a view designer. The tabs and options in the 

designer depend on the diagram database type you are chosen. 

Add Related Objects Add all related objects to the selected view. 

Cut Remove the view from the diagram and put it on the clipboard. 

Copy Copy the view from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the view as a PNG file. 

Select All Views Select all views in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the view from the diagram or from both diagram and model. 

Rename Change the name of the view. 

Color Change the color of the view. 

Size to Fit Resize the view automatically to fit its contents. 
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Bring to Front Bring the view to the foreground. 

Send to Back Move the view to the background. 

Group / Ungroup Group or ungroup the view and other objects in the diagram. 

Lock / Unlock Lock or unlock the view in the diagram. 

Properties 

Once you have selected the view, you can customize the view by changing its properties: 

Option Description 

View 

View Name Enter the name of the view. 

Database Name Enter the name of the database to which the view belongs. 

Model Name Show the name of the model to which the view belongs. 

Position Customize the position of the view. 

Size Customize the size of the view. 

Style Choose the style the view. 

Auto - Auto-arrange the view into a compact or standard style when resizing. 

Standard - Show the view name and its content. 

Compact - Show a view icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the view. 

Bold Make the view border bold. 

Group / Ungroup Group or ungroup the view and other objects in the diagram. 

Lock / Unlock Lock or unlock the view in the diagram. 

 

Add Functions / Procedures 

To add a new function/procedure 

1. Click the  or  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the function/procedure to open the designer. 

Hint: The new function/procedure will also add to the default model. 

The pop-up menu options of the function/procedure object in the canvas include: 

Option Description 

Design Function / Design 

Procedure 

Edit the function/procedure structure in a function/procedure designer. The 

tabs and options in the designer depend on the diagram database type you 

are chosen. 

Cut Remove the function/procedure from the diagram and put it on the clipboard. 
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Copy Copy the function/procedure from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the function/procedure as a PNG file. 

Select All Functions Select all functions/procedures in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the function/procedure from the diagram or from both diagram and 

model. 

Rename Change the name of the function/procedure. 

Color Change the color of the function/procedure. 

Size to Fit Resize the function/procedure automatically to fit its contents. 

Bring to Front Bring the function/procedure to the foreground. 

Send to Back Move the function/procedure to the background. 

Group / Ungroup Group or ungroup the function/procedure and other objects in the diagram. 

Lock / Unlock Lock or unlock the function/procedure in the diagram. 

Properties 

Once you have selected the function/procedure, you can customize the function/procedure by changing its properties: 

Option Description 

Function / Procedure 

Function Name / 

Procedure Name 

Enter the name of the function/procedure. 

Database Name Enter the name of the database to which the function/procedure belongs. 

Model Name Show the name of the model to which the function/procedure belongs. 

Position Customize the position of the function/procedure. 

Size Customize the size of the function/procedure. 

Style Choose the style the function/procedure. 

Auto - Auto-arrange the function/procedure into a compact or standard style 

when resizing. 

Standard - Show the function/procedure name and its content. 

Compact - Show a function/procedure icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the function/procedure. 

Bold Make the function/procedure border bold. 

Group / Ungroup Group or ungroup the function/procedure and other objects in the diagram. 

Lock / Unlock Lock or unlock the function/procedure in the diagram. 

 

Add Entities 

To add a new entity 

1. Click the  button from the toolbar. 
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2. Place it on the canvas. 

3. [Logical Model] Double-click the entity to open the designer. 

Hint: The new entity will also add to the default model. 

For Default diagram notation, the  icon means the attribute is a primary key. The  icon indicates that the 

attribute serves as an index. 

The pop-up menu options of the entity object in the canvas include: 

Option Description 

Design Entity Edit the entity structure in an entity designer, e.g. attributes, indexes, 

relations, etc. 

Only for Logical Model. 

Add Related Objects Add all related objects to the selected entity. 

Add Attribute Add an attribute at the end of the entity. 

Insert Attribute Add an attribute above the selected attribute. 

Delete Attribute Delete the selected attribute. 

Primary Key Set the selected attribute as primary key. 

Rename Attribute Change the name of the selected attribute. 

Cut Remove the entity from the diagram and put it on the clipboard. 

Copy Copy the entity from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the entity as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the entity. 

Select All Entities Select all entities in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the entity from the diagram or from both diagram and model. 

Rename Change the name of the entity. 

Color Change the color of the entity. 

Size to Fit Resize the entity automatically to fit its contents. 

Bring to Front Bring the entity to the foreground. 

Send to Back Move the entity to the background. 

Group / Ungroup Group or ungroup the entity and other objects in the diagram. 

Lock / Unlock Lock or unlock the entity in the diagram. 

Properties 

Once you have selected the entity, you can customize the entity by changing its properties: 

Option Description 
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Entity 

Entity Name Enter the name of the entity. 

Database Name Enter the name of the database to which the entity belongs. 

Model Name Show the name of the model to which the entity belongs. 

Position Customize the position of the entity. 

Size Customize the size of the entity. 

Style Choose the style the entity. 

Auto - Auto-arrange the entity into a compact or standard style when 

resizing. 

Standard - Show the entity name and/or its attributes. 

Compact - Show an entity icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the entity. 

Bold Make the entity border bold. 

Group / Ungroup Group or ungroup the entity and other objects in the diagram. 

Lock / Unlock Lock or unlock the entity in the diagram. 

 

Add Labels 

Labels are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. 

To add a new label 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Enter the caption. 

The pop-up menu options of the label object in the canvas include: 

Option Description 

Cut Remove the label from the diagram and put it on the clipboard. 

Copy Copy the label from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the label as a PNG file. 

Select All Labels Select all labels in the diagram. 

Delete from Diagram Delete a label from the diagram. 

Size to Fit Resize the label automatically to fit its contents. 

Bring to Front Bring the label to the foreground. 

Send to Back Move the label to the background. 

Group / Ungroup Group or ungroup the label and other objects in the diagram. 
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Lock / Unlock Lock or unlock the label in the diagram. 

Properties 

Once you have selected the label, you can customize the label by changing its properties: 

Option Description 

Label 

Name Enter the name of the label. 

Position Customize the position of the label. 

Size Customize the size of the label. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Font Set the font style of the label caption. 

Bold Apply a bold style to the label caption. 

Italic Apply an italic style to the label caption. 

URL Enter URL path to set the text as a hyperlink. 

Group / Ungroup Group or ungroup the label and other objects in the diagram. 

Lock / Unlock Lock or unlock the label in the diagram. 

 

Add Notes 

Notes are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. 

To add a new note 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Enter the content. 

The pop-up menu options of the note object in the canvas include: 

Option Description 

Cut Remove the note from the diagram and put it on the clipboard. 

Copy Copy the note from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the note as a PNG file. 

Select All Notes Select all notes in the diagram. 

Delete from Diagram Delete a note from the diagram. 

Color Change the color of the note. 

Size to Fit Resize the note automatically to fit its contents. 

Bring to Front Bring the note to the foreground. 
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Send to Back Move the note to the background. 

Group / Ungroup Group or ungroup the note and other objects in the diagram. 

Lock / Unlock Lock or unlock the note in the diagram. 

Properties 

Once you have selected the note, you can customize the note by changing its properties: 

Option Description 

Note 

Name Enter the name of the note. 

Position Customize the position of the note. 

Size Customize the size of the note. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Font Set the font style of the note content. 

Bold Apply a bold style to the note content. 

Italic Apply an italic style to the note content. 

Color Set the color of the note. 

Group / Ungroup Group or ungroup the note and other objects in the diagram. 

Lock / Unlock Lock or unlock the note in the diagram. 

 

Add Images 

You can insert images (BMP, JPG, JPEG or PNG files) to your diagram for design or identification purposes. 

To add a new image 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Select an image file in the Open dialog box. 

Hint: You can simply add an image from the clipboard by pressing CTRL+V. 

The pop-up menu options of the image object in the canvas include: 

Option Description 

Cut Remove the image the diagram and put it on the clipboard. 

Copy Copy the image from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the image as a PNG file. 

Select All Images Select all images in the diagram. 

Delete from Diagram Delete an image from the diagram. 

Bring to Front Bring the image to the foreground. 
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Send to Back Move the image to the background. 

Group / Ungroup Group or ungroup the image and other objects in the diagram. 

Lock / Unlock Lock or unlock the image in the diagram. 

Properties 

Once you have selected the image, you can customize the image by changing its properties: 

Option Description 

Image 

Name Enter the name of the image. 

Opacity Set the opacity of the image. 

Position Customize the position of the image. 

Size Customize the size of the image. 

Original Size Reset the image to its original size. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

URL Enter URL path to set the image as a hyperlink. 

Group / Ungroup Group or ungroup the image and other objects in the diagram. 

Lock / Unlock Lock or unlock the image in the diagram. 

 

Add Shapes 

Navicat Data Modeler includes some pre-defined shapes for creating database model diagrams: line, arrow, curve, 

connector, rectangle, ellipse, user, database, cloud, trigger, server, desktop, laptop, mobile, man, woman. 

To add a new shape 

1. Click the  button from the toolbar. 

2. Select a shape. 

3. Place it on the canvas. 

To connect objects with a connector 

1. Drag one endpoint of the connector to an object until it snaps to the object (a blue outline appears around the 

object). 

2. Drag the other endpoint until the connector snaps to another object. 

Hint: Lines, arrows and curves can act as connectors. You can enable the As connector option in the Properties 

pane. 

The pop-up menu options of the shape object in the canvas include: 

Option Description 
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Common 

Cut Remove the shape from the diagram and put it on the clipboard. 

Copy Copy the shape from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the shape as a PNG file. 

Select All Shapes Select all shapes in the diagram. 

Delete from Diagram Delete a shape from the diagram. 

Color Change the color of the shape. 

Bring to Front Bring the shape to the foreground. 

Send to Back Move the shape to the background. 

Group / Ungroup Group or ungroup the shape and other objects in the diagram. 

Lock / Unlock Lock or unlock the shape in the diagram. 

Line, Arrow and Curve 

Add Vertex Add a vertex at the mouse cursor position. 

Delete Vertex Delete a vertex at the mouse cursor position. 

Delete All Vertices Delete all vertices on the selected line. 

Go to Go to and select the connected object. 

Connector 

Go to Go to and select the connected object. 

Reroute Connectors Reroute the connector to the closest points between two connected 

objects. 

Properties 

Once you have selected the shape, you can customize the shape by changing its properties: 

Option Description 

Common 

Name Enter the name of the shape. 

Position Customize the position of the shape. 

Show name Display the name label of the shape. 

Name Position Change the label position. 

Font Set the font style of the name. 

Bold Apply a bold style to the name. 

Italic Apply an italic style to the name. 

Color Set the color of the shape. 

Group / Ungroup Group or ungroup the shape and other objects in the diagram. 

Lock / Unlock Lock or unlock the shape in the diagram. 

Line, Arrow, Curve and Connecter 

Offset Customize offset values for the start and end of the line. 

Line Width Choose the thickness of the line. 

Cap Style Choose the cap style of the line. 
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Dash Style Choose the dash style of the line. 

Join Style Choose the join style of the line. 

Begin Style Choose the style of the line's back. 

End Style Choose the style of the line's front. 

As connector Allow you to connect objects. 

Rectangle, Ellipse, User, Database, Cloud, Trigger, Server, Desktop, Laptop, Mobile, Man and 

Woman 

Size Customize the size of the shape. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Border Color Change the color of the shape's border. 

Border Width Choose the thickness of the border. 

Shape Style Change the style of the shape. 

 

Add Layers 

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You can add all related 

objects to the same layer. For example, you may choose to add all your sales related tables to one layer. 

To add a new layer 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Move objects into the layer and select Add To Layer. 

The pop-up menu options of the layer object in the canvas include: 

Option Description 

Cut Remove the layer from the diagram and put it on the clipboard. 

Copy Copy the layer from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the layer as a PNG file. 

Select All Layers Select all layers in the diagram. 

Delete from Diagram Delete a layer from the diagram. 

Color Change the color of the layer. 

Size to Fit Resize the layer automatically to fit its contents. 

Bring to Front Bring the layer to the foreground. 

Send to Back Move the layer to the background. 

Group / Ungroup Group or ungroup the layer and other objects in the diagram. 

Lock / Unlock Lock or unlock the layer in the diagram. 

Properties 
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Once you have selected the layer, you can customize the layer by changing its properties: 

Option Description 

Layer 

Name Enter the name of the layer. 

Position Customize the position of the layer. 

Size Customize the size of the layer. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Font Set the font style of the title. 

Title Position Change the title position. 

Color Set the color of the layer. 

Group / Ungroup Group or ungroup the layer and other objects in the diagram. 

Lock / Unlock Lock or unlock the layer in the diagram. 

 

Work with Diagram Canvas 

Show Grid 

To turn the grid on in the diagram canvas, choose View -> Show Grid from the menu bar. 

Show Page Border 

To turn the page border on in the diagram canvas, choose View -> Show Page Border from the menu bar. 

Snap to Grid 

To align objects on the canvas with the grid, choose View -> Snap To Grid from the menu bar. 

Align Multiple Objects 

1. Select the objects you want to align. 

2. Right-click the selected objects, and then select one of these commands from the Alignment menu: 

Option Description 

Align Left Align objects along their left edges. 

Align Center Align objects vertically through their centers. 

Align Right Align objects along their right edges. 

Align Top Align objects along their top edges. 

Align Middle Align objects horizontally through their middles. 

Align Bottom Align objects along their bottom edges. 

Arrange Objects Equidistant 

1. Select at least three objects. 
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2. Right-click the selected objects, and then select one of these commands from the Distribute menu: 

Option Description 

Horizontally Arrange the objects horizontally. 

Vertically Arrange the objects vertically. 

 

Apply Auto Layout (Available only in Enterprise Edition) 

Navicat Data Modeler provides a layout facility for arranging objects on diagrams. Your diagram is reorganized 

following the specific settings you define. Objects do not overlap and connectors do not cross over one another. 

Apply Auto Layout to Entire Diagram 

1. Click on the canvas. 

2. Click . 

Apply Auto Layout to Selected Objects 

1. Select the objects you want to apply auto layout. 

2. Click . 

Apply Auto Layout to All Objects in Layer 

1. Select the layer. 

2. Click . 

Change Auto Layout Settings 

To change the Auto Layout format settings, simply choose Diagram -> Auto Layout With from the menu and set the 

following options: 

Option Description 

Auto Diagram Dimension Choose the suitable diagram dimension automatically. 

Auto Size Tables To Fit Resize the table to fit its content automatically. 

Quality The quality of the auto layout output. 

Object Distance The distance between the objects in the diagram. 

 

Preview Diagram 

You can preview the diagram using the whole screen. The title bar, toolbar, tab bar, Objects pane and Properties pane 

will be hidden while in this mode. To preview a diagram, click  Preview. 
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To exit the preview mode, press the ESC key and the workspace window will be returned to its previous state. 

Print & Export Diagram 

Print Diagram 

You can print the current diagram to the printer. 

1. Choose File -> Print. 

2. Select your print options. 

3. Click OK. 

Export Diagram to File 

You can export the current diagram to various types of images and files: PDF, PNG, SVG or JPG. 

1. Choose File -> Export To and choose the file format. 

2. Choose the path and enter the file name. 

3. Click Save. 
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Chapter 7 - Data Dictionary (Available only in 

Enterprise Edition) 

About Data Dictionary 

Data Dictionary serves as a reference for understanding and documenting the structure and semantics of the data 

model. It provides a comprehensive description of the structure, relationships, and constraints of the objects in the 

model. 

Create Data Dictionary 

The essential steps to create a data dictionary are: 

1. In the Workspace window, click  New Data Dictionary. 

2. Enter the name of the data dictionary. 

3. Click OK. 

4. A tab will open for you to edit the data dictionary. 

5. Click  Generate. 

Object Selection 

In the list, choose objects to include in the data dictionary. 

Navicat Data Modeler will generate the data dictionary contents based on the sequence of the objects on the list. You 

can select the objects and use the arrow buttons to change the order. 

Theme 

Navicat Data Modeler provides several templates for data dictionary files. You can choose the appropriate template 

and follow the remaining steps to customize your settings. 

Layout Settings 

You can adjust the layout of the template and view the preview on the left pane. 

Option Description 

Cover 

Include cover Add a cover page. 

Header Logo Insert a preceding image in the header. 

Header Enter a header that appears once at the top of the cover page. 

Title Enter the title of the data dictionary. 
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Subtitle Enter the subtitle of the data dictionary. 

Remarks Enter remarks that appear on the cover page. 

Background Image Default - Use the default background image. 

Custom - Insert a background image for the cover page. 

None - Explicitly not insert a background image.  

Footer Enter a footer that appears once at the bottom of the cover page. 

Table of Contents 

Include table of contents Add table of contents to the data dictionary. 

Header/Footer 

Include breadcrumbs 

header 

Add a breadcrumbs header that appears at the top of every page except the 

cover and table of contents. 

Heading Font Set the font style of the heading. 

Subheading Font Set the font style of the subheading. 

Include left footer Add a footer that appears at the bottom left of every page except the cover, 

table of contents and introduction. 

Include page number in 

right footer 

Add page numbers to the right footer of every page except the cover, table 

of contents and introduction. 

Footer Font Set the font style of the footer. 

Main Content 

Include Introduction Add a page for introducing the data dictionary. 

Introduction Enter the introduction. 

Font Set the font style of the introduction. 

Paper 

Paper Choose the paper size. 

Orientation Select a page orientation (Portrait or Landscape). 

Margin (CM) Set the margins of the document. 

File Path 

In this tab, set the export file path and other advanced options. 

Option Description 

Export To File Specify the path of the data dictionary file. 

Append timestamp to file 

name 

Append timestamp information to the file name to show when the file is 

created. 

Overwrite existing file Overwrite if the file already exists. 

Continue on error Ignore errors that are encountered during the generation process. 

Message Log 

After clicking the  Generate button, the Message Log tab will appear. It displays the success or failure messages 

and the file path information. Click the Open button to open the data dictionary file. 
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Chapter 8 - Connection (Available only in 

Enterprise Edition) 

Manage Connections 

You can manage the connections stored in your local machine, or the connections synchronized to Navicat Cloud or 

your On-Prem Server. In the menu bar, choose Tools -> Manage Connections. 

Create New Connections 

1. In the Manage Connections window, select My Connections or a project. 

2. Click New and select New Connection, and then select the server type. 

3. Enter the server login information in the New Connection window. 

Manage Existing Connections 

To edit a connection 

1. In the Manage Connections window, right-click a connection and select Edit Connection. 

2. Change the connection settings. 

3. Click OK. 

To delete a connection 

1. In the Manage Connections window, right-click a connection and select Delete Connection. 

2. Click Delete in the confirm dialog. 

Import Connection Settings 

To import Navicat (e.g. Navicat Premium) connection settings 

1. In the Manage Connections window, right-click My Connections and select Import Connections from 

Navicat. 

2. Select the connections and click OK. 

Note: Available only when Navicat (e.g. Navicat Premium) is installed in the current machine. If the connection exists, 

the newly created connection will be named as e.g. "connection_name Copy #". 

https://navicat.com/products/navicat-premium
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Database Connections 

Connect to Database Servers  

You can create a connection to connect your server: MySQL, MariaDB, PostgreSQL, Oracle, SQLite, SQL Server, 

MongoDB. 

Note: Navicat Data Modeler authorizes you to make connection to remote server running on different platform, i.e. 

Windows, macOS, Linux and UNIX. 

RDBMS General Settings 

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database 

login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) / HTTP is another solution. 

Note: The following options depend on the connection server type and sort in ascending order. 

Add To 

After you logged in Navicat Cloud or On-Prem Server, you can choose to save the connection to My Connections or a 

project. 

Authentication 

SQL Server 

Authentication 

Use login records to validate the connection. Users must provide their 

server login: User Name and Password. 

Windows 

Authentication 

When a user connects through a Windows user account, SQL Server 

validates the account name and password using the Windows principal 

token in the operating system. 

Active Directory - 

Password 

Use an identity and password in Microsoft Entra ID to connect the server. 

Active Directory - 

Integrated 

Use Windows identity federated with Microsoft Entra ID to connect the 

server. 

Active Directory - MFA Use a user account with multifactor authentication (MFA) enabled to 

connect the server. 

Connection Name 

Enter a friendly name to best describe your connection. 

Connection Type 

Basic In Basic mode, it connects to Oracle through the Oracle Call Interface (OCI). 

Enter the Host and Port. Set the Service Name/SID which the user 

connects when making connection. Select the corresponding radio button. 

TNS In TNS mode, it connects to Oracle server using an alias entry from a 
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tnsnames.ora file through the Oracle Call Interface (OCI). User needs to 

provide the Net Service Name. 

OCI is an application programming interface that allows an application developer to use a third-generation language's 

native procedure or function calls to access the Oracle database server and control all phases of SQL statement 

execution. OCI is a library of standard database access and retrieval functions in the form of a dynamic-link library. See 

also: OCI options 

Database File 

Specify the initial database file. If the HTTP Tunnel is enabled, you need to enter an absolute file path of the database 

file in your web server. 

Host 

A host name where the database is situated or the IP address of the server. 

Initial Database 

Set the initial database which user connects when making connection. 

Password 

Password for connecting to the database server. 

Port 

A TCP/IP port for connecting to the database server. 

Type 

Existing Database File Connect to an existing database in the Database File. 

New SQLite 3 Create a new SQLite 3 database in the Database File. 

New SQLite 2 Create a new SQLite 2 database in the Database File. 

User Name 

User name for connecting to the database server. 

MongoDB General Settings 

To successfully establish a new connection to local/remote server - no matter via SSL or SSH, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) is another solution. 

Connection Name 

Enter a friendly name to best describe your connection. 

Add To 



 66 

 

After you logged in Navicat Cloud or On-Prem Server, you can choose to save the connection to My Connections or a 

project. 

Type 

The type of your MongoDB server: Standalone, Shard Cluster or Replica Set. 

SRV Record 

Check this option to connect the server using an SRV Record. 

Host 

A host name, IP address, or UNIX domain socket of the server. 

Port 

A TCP/IP port for connecting to the server. 

Member 

Add or remove the members of replica set or the instances of sharded cluster to the connection. 

Read Preference 

Choose the replica set read preference for this connection. 

Replica Set 

The name of the replica set. 

Authentication 

Choose the authentication mechanism that MongoDB will use to authenticate the connection. 

None No authentication. 

Password Specify the Authentication Database name associated with the User 

Name and Password. 

LDAP Specify the User Name and Password. 

Kerberos Set the Kerberos Service Name and the user Principal. 

X.509 x.509 certificate authentication. 

 

Advanced Settings 

Note: The following options depend on the connection server type and sort in ascending order. 

Cipher Name 
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Choose the encryption algorithm when connecting to an encrypted SQLite database. 

Client Character Set 

Choose the session client character set used in Navicat Data Modeler. 

Client Driver Version 

Choose the client driver used to connect the server. If the default driver does not work, you can change this setting to 

Legacy. 

Compatibility 

Enable the Compatibility tab for setting the compatibility mode for MySQL connection. 

Encoding 

Choose a codepage for converting data to display in Navicat Data Modeler UI. 

Encrypted 

Enable this option and provide Password when connecting to an encrypted SQLite database. 

Initial Queries 

Specify the initial query commands to be executed when connecting to the server. 

Limit connection sessions 

Specify the maximum number of concurrent connections that the server allows. 

Native Client Driver 

Choose the SQL Server Native Client used for the connection. 

OS authentication 

Use OS user login credentials to authenticate database users. 

Retryable Reads 

Disable this option to specify "retryReads=false" in the connection string. 

Retryable Writes 

Disable this option to specify "retryWrites=false" in the connection string. 

Role 

Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege. 
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Use compression 

Use compression protocol. It is used if both client and server support zlib compression, and the client requests 

compression. 

Use encryption 

Use encryption for SQL Server connection. 

Use named pipe, socket 

Use socket file for localhost connection. 

Databases / Attached Databases Settings 

MySQL, Oracle, PostgreSQL, SQL Server, MariaDB, MongoDB 

In the Databases tab, you can set which databases will be shown. It is not obligatory. To start working with custom 

database settings, check Use custom database list. Then, check the preferable databases in the Database column. 

Add a hidden database to the list 

1. Click the Add Database to List button. 

2. Enter the database name. 

3. Check the newly added database in the database list. 

Remove a database from the list 

1. Select the database in the database list. 

2. Click the Remove Database from List button. 

Note: The database will be just removed from the database list box, it will still exist in the server. 

SQLite 

In the Attached Databases tab, you can attach SQLite database files to the connection. Click the Attach Database 

button and enter the information: 

Option Description 

Database File Choose the file path of a database file. 

Database Name Enter the database name which displays in Navicat Data Modeler. 

Encrypted Check this option and provide the Password if the database file is 

encrypted. 

To detach a database, select it from the list and click the Detach Database button. 
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SSL Settings 

Secure Sockets Layer (SSL) is a protocol for transmitting private documents via the Internet. To get a secure 

connection, the first thing you need to do is to install OpenSSL Library and download Database Source. 

Note: Available only for MySQL, PostgreSQL, MariaDB and MongoDB. Support from PostgreSQL 8.4 or later. 

MySQL and MariaDB Connections 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Certificate 

The SSL certificate file in PEM format to use for establishing a secure connection. 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Verify CA Certificate Name 

Check the server's Common Name value in the certificate that the server sends to the client. 

Specified Cipher 

A list of permissible ciphers to use for SSL encryption. 

PostgreSQL Connection 

Choose the SSL Mode: 

require Only try an SSL connection. 

verify-ca Only try an SSL connection, and verify that the server certificate is issued by 

a trusted CA. 

verify-full Only try an SSL connection, verify that the server certificate is issued by a 

trusted CA and that the server hostname matches that in the certificate. 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The path of the client private key. 

Client Certificate 

The path of the client certificate. 
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CA Certificate 

The path of the trusted certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

MongoDB Connection 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Key Password 

The password of the key file. 

Allow any server SSL certificates 

Check this option if your MongoDB server allows any server SSL certificates. 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

Allow invalid host names 

Check this option to allow invalid hostnames in SSL certificates. 

SSH Settings 

Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote 

server, and move files from one machine to another. It provides strong authentication and secure encrypted 

communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network. 

Typically, it is employed as an encrypted version of Telnet. 

In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing 

anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to 

session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent 

such vulnerabilities and allows you to access a remote server's shell without compromising security. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB and MongoDB. 
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Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise, 

the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding 

should be enabled. Please double check the value settings. 

Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat Data Modeler cannot 

connect via SSH Port 22. 

Host 

A host where SSH server is activated. 

Note: The host name in the General tab should be set relatively to the SSH server which provided by your database 

hosting company. 

Port 

A port where SSH server is activated, by default it is 22. 

User Name 

A user on SSH server machine. (It is not a user of database server.) 

Authentication Method 

Password Provide the SSH server user Password. 

Public Key Private Key 

It is used together with your public key. The private key should be readable 

only by you. 

Passphrase 

A passphrase is exactly like a password, except that it applies to the keys 

you are generating and not an account. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

HTTP Settings 

HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80) 

as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP 

connections. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Uploading the Tunneling Script 

To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your 

server is located. 
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Note: ntunnel_mysql.php (for both MySQL and MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php is available in 

the Navicat Data Modeler installation folder. 

Setting up HTTP Tunnel 

The following instruction guides you through the process of configuring a HTTP connection. 

1. Select the HTTP tab and enable Use HTTP Tunnel. 

2. Enter URL of the tunneling script, e.g. http://www.navicat.com/ntunnel_mysql.php . 

3. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64 

option. 

4. If the tunneling script is hosted in a password protected server or you have to access internet over a proxy 

server, you can provide the required authentication details in Authentication or Proxy tab. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

Compatibility Settings 

If your server is a variant of MySQL or has proxy middleware installed, you can enable compatibility mode and set the 

corresponding settings for the connection. 

Note: Available only for MySQL. 

Force lower_case_table_names as 

Set the value of the lower_case_table_name system variable. 

Force sql_mode as 

Set the value of the sql_mode system variable. 

Force NDB cluster support as 

Include or exclude the support for the NDBCLUSTER storage engine. 

Force database listing method as 

Use the SHOW DATABASES statement to retrieve the information for listing databases, or select the information from 

the INFORMATION_SCHEMA database. 

Force view listing method as 

Use the SHOW FULL TABLES statement to retrieve the information for listing tables, or select the information from the 

INFORMATION_SCHEMA database. 
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ODBC Connections 

You can create an ODBC connection to connect your ODBC data source. The following instruction guides you through 

the process of creating a new ODBC connection. 

Setting Up an ODBC Data Source Connection 

1. On the Control Panel, select Administrative Tools. 

2. Select Data Sources (ODBC). 

3. Select User DSN tab. 

4. Click Add. 

5. Select the correct ODBC driver you wish and click Finish. 

6. Enter the required information. 

7. Select OK to see your ODBC Driver in the list. 

Connecting to ODBC data source in Navicat Data Modeler 

Connection Name 

A friendly name to best describe your connection. 

Data Source 

A data source name. 

User Name 

User name for connecting to the data source. 

Password 

Password for connecting to the data source. 
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Chapter 9 - Reverse Engineering (Available only 

in Enterprise Edition) 

About Reverse Engineering 

Reverse Engineering is the process of creating a data model from a database/schema. Navicat Data Modeler allows 

you to load existing database structures to create new models, or synchronize database differences to an existing 

model. 

Synchronize Database to Model 

The Synchronize Database to Model feature allows you to compare a database or schema with an existing model, 

states the differences between their structures, and offers synchronizing modifications in the database or schema into 

the model. 

Navicat Data Modeler provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Reverse Engineering -> Synchronize Database to Model. 

2. Select the source connection, database, schema, and select the target model, database, schema. 

3. Click Options and select the compare / advanced options. 

4. Click Compare to show the differences between source and target objects. 

5. Select the objects you want to synchronize. 

6. Click Next to execute the process. 

Choose Connections 

The first step is to define the source connection and the target model. 

Choose Comparing Options 

Then, click the Options button to select the compare / advanced options for the synchronization process. 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 

Option Description 

Compare auto increment 

value 

Compare the auto increment values of tables. 

Compare character set Compare the character sets of tables. 

Compare checks Compare check constraints. 

Compare collation Compare the collations of tables. 
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Compare definers Compare the definers of views. 

Compare excludes Compare exclusion constraints. 

Compare foreign keys Compare the foreign keys of tables. 

Compare functions Compare function and procedure objects. 

Compare identity last 

value 

Compare the identity last values of tables. 

Compare indexes Compare table indexes. 

Compare owners Compare the owners of database objects. 

Compare partitions Compare table partitions. 

Compare primary keys Compare the primary keys of tables. 

Compare rules Compare rule objects. 

Compare sequences Compare sequence objects. 

Compare sequence last 

values 

Compare the last values of sequences. 

Compare storage Compare table storages. 

Compare table options Compare other table options. 

Compare tables Compare table objects. 

Compare triggers Compare table triggers. 

Compare uniques Compare unique constraints. 

Compare views Compare view objects. 

Drop with CASCADE Drop the dependent database objects with the CASCADE option. 

Identifier Case Sensitivity Ignore or consider the case of identifiers when mapping, or use the server 

default setting. 

Start Comparison 

Click the Compare button to compare the source database and the target model. 

View Comparison Results 

After comparing structures, the tree view shows the differences between the source and target databases or schemas. 

Check the objects you want to apply to the target. You can expand the objects to view the detailed structure. 
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You can choose to group the objects in the tree views by object types or operations by selecting Group by Object 

Type or Group by Operation. 

Operation Description 
 

Object exists in both source and target databases/schemas, but they have 

different definition. The target object will be modified based on the source 

object. 
 

Object does not exist in the target database/schema. It will be created in the 

target. 
 

Object does not exist in the source database/schema. The target object will 

be deleted. 
 

Object exists in both source and target databases/schemas and they have 

identical definition. No operation will be applied. 

When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements/scripts of that 

object in the source and the target, and the Deployment Script tab shows the detailed statements/scripts of the object 

that will be updated in the target model. 

Click the Next button to execute the process. The window will display the execution progress, execution time, and 

success or failure messages. 

Reverse Database to Model 

The Reverse Database to Model feature allows you to create a database model from an existing database or schema. 

Navicat Data Modeler provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Reverse Engineering -> Reverse Database to Model. 

2. Select the source connection, database, schema, and select the target model, database, schema. Choose 

New Model and the model type if you want to create a new model. 



 77 

 

3. Click New. 

4. Select the objects you want to import. 

5. Enable Import To Diagram and select a diagram if you want to add the objects to a diagram. Choose New 

Diagram if you want to import objects to a new diagram. 

6. Click Start. 
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Chapter 10 - Forward Engineering (Available only 

in Enterprise Edition) 

About Forward Engineering 

Forward engineering is the process of generating the physical database schema from a physical model. Navicat Data 

Modeler allows you to synchronize model differences to an existing database, or export models to .sql or .script files. 

Synchronize Model to Database 

The Synchronize Model to Database feature allows you to compare a model with an existing database or schema, 

states the differences between their structures, and offers synchronizing the structures in model to the target 

connection. 

Navicat Data Modeler provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Forward Engineering -> Synchronize Model to Database. 

2. Select the source model, database, schema, and select the target connection, database, schema. 

3. Click Options and select the compare / advanced options. 

4. Click Compare to show the differences between source and target objects. 

5. Select the objects you want to synchronize. 

6. Click Next to generate a set of scripts. 

7. Click Start. 

Choose Connections 

The first step is to define the source model and the target connection. 

Choose Comparing Options 

Then, click the Options button to select the compare / advanced options for the synchronization process. 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 

Option Description 

Compare auto increment 

value 

Compare the auto increment values of tables. 

Compare character set Compare the character sets of tables. 

Compare checks Compare check constraints. 
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Compare collation Compare the collations of tables. 

Compare definers Compare the definers of views. 

Compare excludes Compare exclusion constraints. 

Compare foreign keys Compare the foreign keys of tables. 

Compare functions Compare function and procedure objects. 

Compare identity last 

value 

Compare the identity last values of tables. 

Compare indexes Compare table indexes. 

Compare owners Compare the owners of database objects. 

Compare partitions Compare table partitions. 

Compare primary keys Compare the primary keys of tables. 

Compare rules Compare rule objects. 

Compare sequences Compare sequence objects. 

Compare sequence last 

values 

Compare the last values of sequences. 

Compare storage Compare table storages. 

Compare table options Compare other table options. 

Compare tables Compare table objects. 

Compare triggers Compare table triggers. 

Compare uniques Compare unique constraints. 

Compare views Compare view objects. 

Drop with CASCADE Drop the dependent database objects with the CASCADE option. 

Identifier Case Sensitivity Ignore or consider the case of identifiers when mapping, or use the server 

default setting. 

Start Comparison 

Click the Compare button to compare the source model and the target database. 

View Comparison Results 

After comparing structures, the tree view shows the differences between the source and target databases or schemas. 

Check the objects you want to apply to the target. You can expand the objects to view the detailed structure. 
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You can choose to group the objects in the tree views by object types or operations by selecting Group by Object 

Type or Group by Operation. 

Operation Description 
 

Object exists in both source and target databases/schemas, but they have 

different definition. The target object will be modified based on the source 

object. 
 

Object does not exist in the target database/schema. It will be created in the 

target. 
 

Object does not exist in the source database/schema. The target object will 

be deleted. 
 

Object exists in both source and target databases/schemas and they have 

identical definition. No operation will be applied. 

When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements/scripts of that 

object in the source and the target, and the Deployment Script tab shows the detailed statements/scripts of the object 

that will be executed in the target databases. 

Click the Next button to show the scripts of all selected objects. 

Edit & Execute Selected Scripts 

You can view all scripts that will be executed in the target database in the Deployment Script tab. 

Deployment Options Button Description 

Deployment Options Continue on error - Ignore errors that are encountered during the 

execution process if necessary. 

Include deployment query in message log - Show the deployment 

queries in the Message Log tab during execution. 

Edit Script Open the Edit Deployment Script window to rearrange the order of 
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the scripts. 

Copy Script to Clipboard Copy all scripts from the Deployment Script tab to the clipboard. 

 

In the Edit Deployment Script window, use the arrow buttons to move the scripts. 

Then, click the Start button to execute the scripts. The window will display the execution progress, execution time, and 

success or failure messages. 

Export Model to SQL/Script File 

After finishing your model, you can save structures and relations from the model into a sql or script file. 

Navicat Data Modeler provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Forward Engineering -> Export Model to SQL/Script File. 

2. Enter the file information and select the objects. 

3. Click OK. 

General Properties 

Option Description 

File Set the location path of the output file. 

Model Choose the model you wish to export. 

Schema Choose the schema you wish to export. 

Objects Choose objects in the model you wish to export. 

Advanced Properties 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 

Option Description 

Include auto increment Include the auto increment values of tables. 

Include character set Include table and field character sets. 

Include checks Include check constraints. 

Include collation Include the collations of tables. 

Include Drop SQL Include drop object SQL statements. 

Include Drop With 

CASCADE 

Include drop object SQL statements with the CASCADE option. 

Include excludes Include exclusion constraints. 

Include foreign keys Include the foreign keys of tables. 

Include indexes Include table indexes. 

Include primary keys Include the primary keys of tables. 

Include rules Include rule objects. 
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Include schema Qualify object names with the schema name. Otherwise, only object names 

are included in SQL statements. 

Include triggers Include table triggers. 

Include uniques Include unique constraints. 

Server Version Select the server version for the file. 
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Chapter 11 - Other Advanced Tools 

Useful Features 

Navicat Data Modeler provides variety of tools that improve user experience when working on models. 

 Compare Model Workspace 

 Model Conversion 

 Virtual Grouping 

 Focus Mode 

 Share via URI 

 Search Filter 

 Dark Theme 

Compare Model Workspace (Available only in Enterprise Edition) 

Compare Model Workspace is a powerful tool that allows you to compare two model workspaces, view and resolve 

differences between them. 

Navicat Data Modeler provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Compare Model Workspace. 

2. Select the workspace you want to sync with the current workspace. 

3. Click Compare to show the differences between source and target objects. 

4. Select the objects you want to synchronize. 

5. Click Apply Changes to view the number of changes. 

6. Click Apply. 

Choose Source Workspace 

The first step is to define the source workspace. You can choose an existing workspace in Navicat Data Modeler or an 

external workspace file. 

Then, click the Compare button. 

View Comparison Results 
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After comparing, the tree view shows the differences between the source and target workspaces. Check the objects 

you want to apply to the target. You can expand the objects to view the detailed structure. 

Choose an option from the drop-down list to show the objects. 

Option Description 

All Objects Show all objects in the source and target. 

Objects with Difference Show all objects that are different in the source and target. 

Objects To Be Added Only show the objects that do not exist in the target. 

Objects To Be Updated Only show the objects that exist in both source and target, but they have 

different structures. 

Objects To Be Deleted Only show the objects that do not exist in the source. 

When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements/scripts of that 

object in the source and the target, and the Reference Script tab shows the detailed statements/scripts of the object 

that will be executed in the target database. 

Apply Changes 

Click the Apply Changes button to apply changes to the selected objects. 

Model Conversion 

Navicat Data Modeler allows you to convert your models from one database type to another database type and also 

from one model type to another model type, e.g. MariaDB 10.0 physical model to PostgreSQL 9.0 physical model, 

Oracle 10g physical model to a logical model, a conceptual model to MySQL 5.0 physical model. 

Convert a model 

1. In the Workspace tab, right-click a model and select Model Conversion Wizard. 

2. Select the target workspace. 

3. Enter the model name. 

4. Choose the model type. 

5. Choose the target database and version if necessary. 

6. If you want to convert all related diagrams, enable Convert with related Diagram. 

7. Click Convert. 

8. A tab will open for you to edit the model. 

Conversion Behaviour 

• All data types are converted automatically. 
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• When converting from one database type to another, the conversion process does not change the syntax of 

views, functions, and procedures. 

• When converting a physical model to a logical/conceptual model, all views are converted to entities, and all 

functions and procedures are removed. 

• If the target database version is MySQL 4.0 or below, all views are removed. 

• If the source database type is MongoDB, all views, functions, and procedures are removed. 

• If the target database type is MongoDB, all views, functions, and procedures are removed. 

• If the target database type is SQLite, all functions and procedures are removed. 

Virtual Grouping 

Virtual Group aims to provide a platform for logical grouping objects by categories, so that all objects are effectively 

preserved. It can be applied on all connections and model workspaces. 

Connections 

Create a new group 

1. In the menu bar, choose Tools -> Manage Connections. 

2. In the Manage Connections window, right-click My Connections or a project and select New Group. 

3. Enter a name for the new group. 

Move a connection to a group 

1. In the Manage Connections window, right-click a connection and select Manage Group -> Move To. 

2. Select an existing group. 

Move a connection to the top-level 

1. In the Manage Connections window, right-click a connection and and select Manage Group -> Exclude From 

Group. 

Hint: You can also use the drag and drop method to move objects. 

Models 

Create a new group 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Open a project. 
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3. Right-click anywhere in the project and select New Group. 

4. Enter a name for the new group. 

Move a model file to a group 

1. In the main window, right-click a model and select Manage Group -> Move To. 

2. Select an existing group. 

Move a model file to the top-level 

1. In the main window, right-click a model and select Manage Group -> Exclude From Group. 

Hint: You can also use the drag and drop method to move objects. 

Focus Mode (Available only in Enterprise Edition) 

Focus is a feature that helps you reduce distractions and set boundaries. It removes everything from the screen except 

the form you are working and enters the full screen mode. 

When you want to concentrate on a specific activity, you can turn it on by simply clicking the  icon. 

To exit Focus Mode, you can simply click the  icon at the top right. 

Share via URI 

Navicat Data Modeler allows you share a workspace with your teammates by the URL of the workspace. Navicat users 

can use the generated URI to access the workspace. 

Obtain URI 

You can obtain the URI of a workspace in the General tab of the Information pane. Simply click Share and copy the 

URI in the popup window. You can enable Hide host info to remove the connection host parameter in the URI. 

Open Object via URI 

1. In the main window, choose File -> Open with Navicat URI. 

2. Paste the URI. 

3. Click OK. 

4. Change the connection mapping by clicking Other Options if necessary. 

Option Description 

Mapped Connection Automatically map the connection in the URI to the connection with 

the most similar information in Navicat. 
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Existing Connection Choose an existing connection in Navicat. 

New Connection Create a new connection in Navicat. 

5. Open the object. 

Search Filter 

Navicat Data Modeler provides search filters for searching your objects in the main window, the canvas and tree 

structures. 

In the main window or the canvas, enter a search string in the  Search text box. 

In the tree structures, click on the tree to focus and enter a search string directly. 

You can remove the filter by deleting the search string. 

Dark Theme 

In Dark Theme, Navicat Data Modeler uses a darker color palette for all windows, views, menus, and controls. It works 

on all supported versions of Windows. 

To change your theme, choose Tools -> Options -> General. Then, select Dark. 
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Chapter 12 - Configurations 

Options Settings 

Navicat Data Modeler provides several options for customizing its user interface and performance. 

To open the Options window, choose Tools -> Options from the menu bar. 

General 

General 

Theme 

Choose to use the theme of your Windows OS or a Dark theme. 

Hint: Restart Navicat Data Modeler to take effect. 

Show toolbar caption 

Show text on toolbar buttons in Navicat Data Modeler. Otherwise, only buttons will be presented. 

Hint: Restart Navicat Data Modeler to take effect. 

Use safe confirm dialog (Main Window) 

With this option is on, Navicat Data Modeler will prompt a double confirmation dialog for safe deletion when deleting 

objects in the main window. 

Check for updates on startup 

Check this option to allow Navicat Data Modeler checks for new version when it starts. 

Usage Data 

Share Usage Data 

Check this option to let your device sends us information about how you use Navicat Data Modeler to help us improve it. 

You can view the information being shared by clicking the Usage Data button. 

Code Completion 

Use code completion 

When you type the . (dot) symbol or a character, the editor will offer you a pop-up list that showing some suggestions for 

the code completion. 
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Auto update code completion info 

With this option is on, Navicat Data Modeler will get the latest database information for the code completion from your 

model. 

Clear Code Completion Info 

Delete the information for code completion feature that stored on your device. 

Auto select first suggestion 

Select the first item automatically when the suggestion list pops up. Therefore, pressing ENTER or TAB will insert the 

selected item. Otherwise, you need to use arrow keys to select the suggestion item. 

Editor 

General 

Show line number 

Display line numbers at the left side of the editor for easily reference. 

Use code folding 

Code folding allows codes to collapse as a block and only the first line displayed in the editor. 

Use brace highlighting 

Highlight the pair of braces when your cursor moves to either one brace for easily reference. 

Use syntax highlighting 

Syntax highlight helps viewing codes clearly. Codes are highlighted in the editor with different colors and fonts 

according to the categories they belong to. This feature can be limited by setting the maximum file size (e.g. 10) in 

Disable if file size is larger than (MB) to increase performance. 

Use word wrap 

Enable the word wrap mode in the editor. 

Tab Width 

Enter the number of characters that a tab occupies, e.g. 5. 

Insert spaces when pressing Tab 

Insert space characters when the Tab key is pressed. 

Font and Colors 
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Editor Font 

Define the font and its size used by editors. 

Colors 

Format your queries in the editor with colored syntax highlighting to improve readability. Set font colors to mark out 

different text fragments: Common, Keyword, String, Number, Comment and Background. Click on the color boxes and 

choose your desired color from the Color-Selection dialog window. 

Auto Recovery 

Model 

Save automatically after modifications in model workspaces by defining the Auto Save Interval (seconds) (e.g. 30). 

File Locations 

Logs Location 

Navicat Data Modeler provides number of log files to keep track on the actions have been performed in Navicat Data 

Modeler and they are located in the Logs Location path. 

Profiles Location 

The internal files of Navicat Data Modeler are located in the Profiles Location path. 

Connectivity 

General 

Verify server certificate against CA 

Enable this option to verify that the server certificate against the list of trusted CA. 

Proxy 

Enable the Use proxy option to configure Navicat Data Modeler to use proxy in order to make its network connections. 

Proxy Type 

Specify the type of your proxy server: HTTP or SOCKS5. 

Host 

The host name of your proxy server. 

Port 



 91 

 

The port number of your proxy server. 

User Name / Password 

If your proxy server requires authentication, you can enter a username and a password. 

Connectivity Diagnosis 

Click Test Connectivity to test the network connectivity between the web service and your machine. 

Environment 

Hint: Restart Navicat Data Modeler to take effect. 

OCI library (oci.dll) 

Specify the location of the OCI library (oci.dll) for Oracle connection. By default, it is set to the bundled one in Navicat 

Data Modeler installation folder. 

Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or 

ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle 

Instant Client through - 

Oracle Instant Client 

Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic 

or Basic Lite package. Unzip the packages and set the path points to it. 

Advanced 

Enable diagnostic logging 

Generate a log file in Logs Location to assist with tracking down any problems in Navicat Data Modeler. 

Hint: Restart Navicat Data Modeler to take effect. 

Register on "Open with" List 

Register Navicat Data Modeler program to the "Open with" list in Windows. 

Register Navicat URI Protocol 

Register Navicat URI protocol in Windows. When clicking a Navicat URI link, Navicat Data Modeler opens and adds the 

corresponding Navicat On-Prem Server using the parameters in the URI. 

  

https://www.oracle.com/database/technologies/instant-client/downloads.html


 92 

 

Chapter 13 - Hints and Tips 

Model Hints and Tips 

Navicat Data Modeler provides some useful hints to work on the diagram more effectively. 

Locate Object in the Diagram Canvas 

Double-click an object in the left pane will jump to the corresponding object on the canvas. 

Delete Object from Model 

Select an object in the canvas and press SHIFT+DELETE. 

Open Object Designer 

Double-click an object in the left pane or the canvas. 

Get Object Statement (Available only in Enterprise Edition) 

Select and copy an object on the canvas, and paste it to other text editors. 

Add / Edit Field without Object Designer 

Select an object and click the object name on the canvas, and then press DOWN ARROW to add/edit fields. Navicat 

Date Modeler will predict field types according to field names you entered. 

INTEGER/int/int4/NUMBER 

• suffix "id", "no" (if it is the first column, it will be predicted as a primary key) 

• suffix "num" 

• "qty", "number" 

• exactly "age", "count" 

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL/money 

• suffix "price", "cost", "salary" 

FLOAT/double/float8/NUMBER/REAL/float 

• "size", "height", "width", "length", "weight", "speed", "distance" 

DATE/datetime/date/TEXT/datetime2 

• "date", "time" 
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VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT 

• other field names 

Enter * before the field name to recognize as primary key. e.g. *itemNo:int. 

Enter : between field name and field type to custom field type, e.g. itemName:varchar(255). 

Reorder Field 

Select an object on the canvas, then press and hold the SHIFT key. Use  to drag the field to a desired location. 

Delete Field 

Select an object on the canvas, then press and hold the SHIFT key. Use  to drag the desired field out of the object. 

Add Vertex to Line / Arrow / Curve 

Select a line, arrow or curve on the canvas. Press and hold the SHIFT key and click on it to add vertex. 

Delete Vertex on Line / Arrow / Curve 

Select a line, arrow or curve on the canvas. Press and hold the SHIFT key and click on the vertex. 

View Object's Model and Database 

Press and hold the SPACE key. 

Switch to Hand Mode 

Press and hold the SPACE key, then move the diagram. 

  



 94 

 

Chapter 14 - Hot Keys 

Model Hot Keys 

Keys Action 

Common 

CTRL+S Save 

CTRL+Shift+S Save As 

CTRL+Z Undo 

CTRL+Y Redo 

CTRL+X Cut 

CTRL+C Copy 

CTRL+V Paste 

F11 Focus Mode 

CTRL+U Open with Navicat URI 

Workspace 

CTRL+D Design Object 

Model 

CTRL+N New Object 

Diagram 

CTRL+P Print 

ESC Select 

H Move Diagram 

T New Table/Collection/Entity 

V New View 

R New Foreign Key/Relation 

A New Label 

N New Note 

I New Image 

L New Layer 

CTRL++ or CTRL+Mousewheel Up Zoom In 

CTRL+- or CTRL+Mousewheel Down Zoom Out 

CTRL+0 Reset Zoom 

View Editor 

CTRL+SHIFT+V Paste from Clipboard Stack 
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Chapter 15 - Trace Logs 

Log Files 

Navicat Data Modeler provides number of log files to keep track on the actions have been performed in Navicat Data 

Modeler and they are located in the logs directory, e.g. C:\Users\Guest\Documents\Navicat Data Modeler\logs\. You 

are allowed to change the log files location under Options. 

File Description 

history.log Store the statements or scripts of all operations executed over databases and 

database objects in Navicat Data Modeler. 

Note: This log will be overwritten while Navicat Data Modeler is being 

restarted. 

navicat_log.txt Store information to assist with tracking down any problems in Navicat Data 

Modeler. You can enable this log in Options. 

Note: This log will be overwritten while Navicat Data Modeler is being 

restarted. 

 


